Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

WebView Login Issue using Supervisor ID

Hi,

We are using IPCC Enterprise 7.2.4

In Configuration Manager,we have created one agent id as supervisor and assigned some team members under that agent id. We have added the supervisor in the teamlist as well.

The issue is when we try to login with that supervisor id into the Webview reporting it is keep on throwing the authentication error message. We could not able to login even the first time.

Because of this issue, the callcentre supervisor unable to login to the Webview report to see their team performance.

Kindly help me on the above with respect to any configuration change or is it a known issue ????

FYI : If I create a new user with Webview permission under the USER option in configuration manager , can able to login.

Regards,

PattabiRaman.R

12 REPLIES
Green

Re: WebView Login Issue using Supervisor ID

When you PROMOTED an agent in the Agent Explorer to a Supervisor, it asked for a name and a password. This user was created in the ICM Active Directory and it is that authentication model that WebView uses. This screen asks for the user name and a password. This password must satisfy the complexity required.

You can check in AD that the user was created correctly. Should be under the Cisco ICM OU.

Try to login at the WebView screen with ICM_DOMAIN\ and the password. Obey case, at least to get started.

This WebView user has a limited view - just their team as has been discussed here before. We find that this user is pretty useless - cannot see call types. So we create another USER account for each Supervisor to use in WebView.

Regards,

Geoff

New Member

Re: WebView Login Issue using Supervisor ID

Hi Geoff,

Thanks for your response.

I checked it in AD, the user was created correctly under cisco ICM OU. One small clarification : ICM_DOMAIN -> DOMAIN means our domain name has to be entered or we can enter the same script as it is.

Green

Re: WebView Login Issue using Supervisor ID

>ICM_DOMAIN -> DOMAIN means our domain name has to be entered

Sure. Why not log in correctly?

An alternative is some expression of the form user@icm.domain, but I always use the ICM_DOMAIN\user form.

Regards,

Geoff

New Member

Re: WebView Login Issue using Supervisor ID

I created username - super1

Password - password

Checked in agent explorer - Supervisor checkbox.

Checked this user is supervisor for D_All team

Checked this agent is there in t_agent table and with supervisor field "Y".

Domain name is parsec

Now when i am logging to webview, i am using the username as

ICM_parsec\super1

password - password , however i repeatedly getting, invalid username or password. I tried deleating the username and created again, same issue.

Thanks,

Pattabi.R

Green

Re: WebView Login Issue using Supervisor ID

What are you doing with "ICM_parsec" when the ICM domain is called "parsec". I imagine the name is actually something like

parsec.foobar.icm

Try logging in to webview as PARSEC\super1

Try logging in to webview as super1@parsec.foobar.icm

Go onto the AD. Look at the user ICM created. Make it so the user can login. On an ICM box that is in the domain, log out the Administrator and try to log this guy in. If the system says passwd invalid, try setting it in AD and trying again.

Regards,

Geoff

New Member

Re: WebView Login Issue using Supervisor ID

Hi Geoff,

I logged in ICM machine with the super1 username under Parse domain. It is logging in properly.

The issue is happening only with the webview report.

Plsssss help me......

Thanks,

Pattabi.R

Green

Re: WebView Login Issue using Supervisor ID

Can you log in as

user = Administrator

password = ?

Regards,

Geoff

New Member

Re: WebView Login Issue using Supervisor ID

Yeah Geoff. We logged in with admin too... Its logging in ...

Green

Re: WebView Login Issue using Supervisor ID

Well, that's all I can think of. Sorry, mate.

Better go to TAC.

Regards,

Geoff

Cisco Employee

Re: WebView Login Issue using Supervisor ID

Hi

You may want to verify some things first. When you created the agent and then promoted to supervisor, did you create the username and password to be different then the agent username and password within Agent Explorer?

"I logged in ICM machine with the super1 username under Parse domain. It is logging in properly." Did you login into the AW with these credentials? You need to make sure that you are logged into an AW with domain admin privilege.

What is the url that you are trying to log in with? Should be something like http:///. Are you trying to login to Webview on the AW? Try logging in on a client machine with the supervisor credentials.

New Member

Re: WebView Login Issue using Supervisor ID

Hi,

To answer to your question, We gave same username and password for the agent and supervisor within agent explorer.

We dint try login to AW server with these credentials, but we logged in to other client machine using supervisor's login and password. We may try this today after hours.

<

we are trying to access http:///ipcce and we are opening it from AW machine, we are using any client machine to access webview.

Thanks,

Pattabi

Green

Re: WebView Login Issue using Supervisor ID

>we are trying to access http:///ipcce

Is that just a sloppy misprint on your part? Or do you really have "ipcce" in front of the instance name.

Please take care with your posts.

Regards,

Geoff

585
Views
0
Helpful
12
Replies
CreatePlease login to create content