Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Cisco WAE: Basic Configuration using CLI

 

 

Introduction

The basic configuration is the first configuration applied to each WAE, is performed through the Console port using the CLI interface. The base-configuration contains the minimum amount of configuration settings required to bring the WAE up on the network and register it with the CM.

 

The following settings are configured on each WAE as part of the base-configuration:

Device Naming

Interface Configuration

Default Gateway

Domain Name

Name Servers

Primary Interface

Central Manager Address

 

WAE Basic Configuration

Device Naming

 

A structured naming standard for all network devices ensures unique names, as well as aid in the identification of devices by name. Additionally it allows for scripting and management system parsing where / if required.

 

The syntax for configuring a hostname on the WAAS device is given below.

 

wae#hostname

 

Interface Configuration

 

While it is possible to connect a WAE appliance to the network with only one (1) interface, Cisco Advanced Services recommends using two interfaces (2) as a Best Practice (wherever possible). This will ensure that the WAAS devices are protected against link failures. Two (2) different configurations are supported, as outlined below:

Port-Channel Interface

Standby Interface

 

The configuration syntax for configuring a Port-Channel is shown below.

 

primary-interface PortChannel 1

 

int portChannel 1

ip address

exit

 

interface GigabitEthernet 1/0

channel-group 1

exit

 

interface GigabitEthernet 2/0

channel-group 1

exit

 

The configuration syntax for configuring a Standby Interface is shown below.

 

primary-interface Standby 1

 

interface Standby 1

ip address

exit

 

interface GigabitEthernet 1/0

standby 1 priority 105

exit

interface GigabitEthernet 2/0

standby 1

exit

 

Note that depending on the device which the WAE is being connected to, it will either need to be configured to hard-set the speed and duplex settings, or otherwise leave it at auto-sense.

 

If the WAE is being connected to a Gigabit interface, then the interface needs to be left at auto-sense. The following commands needs to be entered when configuring a Gigabit interface:

 

WAE(config)#interface gigabitEthernet 1/0

WAE(config-if)#ip address

WAE(config-if)#no shutdown

 

If the WAE device is being connected to a FastEthernet port, the interface needs to be hard-set 100Mbps and Full Duplex mode. The following commands need to be entered for configuring a FastEthernet interface:

 

WAE(config)#interface FastEthernet 1/0

WAE(config-if)#ip address

WAE(config-if)#full-duplex

WAE(config-if)#speed 100

WAE(config-if)#no shutdown

 

When connected, it is important to verify the interfaces have negotiated speed and duplex correctly as this severely impacts performance. There should not be any half-duplex links operating in the entire path between Clients and servers.

 

Default Gateway

 

The Default Gateway configured on each WAE will depend on the WAE integration model to that site. Sites with only a single router will use the IP address of the WAE VLAN interface on the router as the Default Gateway. Sites with more than one router with HSRP configured for WAE VLAN, will use HSRP VIP IP addresses as the Default Gateway.

 

WAE(config)#ip default-gateway

 

Domain Name and Name server

 

Each WAE device present in the Customer network should be configured with a DNS suffix and one or more DNS servers.

 

WAE(config)#ip domain-name

WAE(config)#ip name-server

WAE(config)#ip name-server

 

Central Manager Address

 

The Central Manager Address configuration is what instructs the WAE how to contact the WAAS Central Manager. Each WAE is manually configured with the address of the Central Manager.

 

WAE(config)# central-manager address <172.25.44.50>

WAE(config)# cms enable

 

Configuring Core WAE

 

To install and configure the WAAS Core WAE device, and register it with the WAAS Central Manager, first power up the designated Core WAE and open a console connection. When a WAAS device boots, you are prompted to run the first-time setup utility (enter basic configuration), which you use to set up the basic network parameters for the device. Configure its network properties and assign this device's primary interface and specify application-accelerator as its device mode.

WAE(config)# primary-interface gigabitEthernet 1/0

WAE(config)# device mode application-accelerator

 

 

Related Information

WCCP best practices for Cisco WAAS

Cisco WAAS: Basic Troubleshooting and Gathering Information

Version history
Revision #:
2 of 2
Last update:
‎08-29-2017 04:30 AM
Updated by:
 
Contributors