Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

QoS configuration for 1000v in UC on UCS Environment

 

 

Introduction

In a virtualized environment, Unified Communications applications such Cisco Unified Communications Manager (Unified CM) run as virtual machines on top of VMware. These Unified Communications virtual machines are connected to a virtual software switch rather than a hardware-based Ethernet switch for Media Convergence Server (MCS) deployments. UC virtual machine traffic flows from the application, to the virtual machine's vNIC, then to the VMware host's virtual software switch (one of VMware vSwitch, VMware Distributed vSwitch, or Cisco Nexus 1000V Switch), then out a physical adapter.

 

QoS Behavior

By default within the UCS FI, a priority QoS class is automatically created for all fibre channel (FC) traffic destined to the SAN switch. This FC QoS class has no drop policy, and all the FC traffic is marked with Layer 2 CoS value of 3. By default all other traffic (Ethernet and IP), including voice signaling and media traffic, falls into Best Effort QoS class.

 

The VMware local vSwitch, VMWare distributed vSwitch, and UCS FI cannot map L3 DSCP values to L2 CoS values. Traffic can be prioritized or de-prioritize inside the UCS FI based on L2 CoS only. Nexus 1000V software switch has the ability to map L3 DSCP values to L2 CoS values, and vice versa. When Unified Communications traffic leaves a virtual machine and enters the Nexus 1000V switch, its L3 DSCP values can be mapped to corresponding L2 CoS values. This traffic can then be prioritized or de-prioritized based on the L2 CoS value inside the UCS FI.

 

Configuration Guideline for 1000v

Matching the ingress traffic based on dscp value and re-mark the cos values.

 

!! Call signaling for voice and videoconferencing is now classified as CoS 3 (IP Precedence 3, PHB CS3, or DSCP 24)

class-map type qos match-all MATCH_DSCP_TO_COS3

match dscp CS3

 

!! Videoconferencing marking for QoS remains at CoS 4 (IP Precedence 4, PHB AF41, or DSCP 34).

class-map type qos match-all MATCH_DSCP_TO_COS4

match dscp CS4 AF41

 

!! Voice marking for QoS remains at CoS 5 (IP Precedence 5, PHB EF, or DSCP 46).

class-map type qos match-all MATCH_DSCP_TO_COS5

match dscp EF

 

Configuring policies for classes before applying it to an interface to specify a service-policy. Packets which are matched based on DSCP CS3, CS4/AF41 and EF are given cos values of 3, 4 and 5 respectively.

 

policy-map type qos DSCP_TO_COS_POLICY

  class MATCH_DSCP_TO_COS3

    set cos 3

  class MATCH_DSCP_TO_COS4

    set cos 4

  class MATCH_DSCP_TO_COS5

    set cos 5

 

Creating Port profile for the virtual Ethernet port, and the above service policy is attached to it in ingress side.

 

port-profile type vethernet <port-profile-name>

  vmware port-group

  switchport mode access

  switchport access vlan <vlan-id>

service-policy type qos input DSCP_TO_COS_POLICY

  no shutdown

  state enabled

 

The policy maps below are applied as service-policies on the relevant port-profiles. The “SET_COS_VM” service policy is a generic marking policy for our VMs while the SET_COS_VMOTION and SET_COS_NFS-ISCSI are for vmkernel specific port-profiles.

 

Define an IP access list or object-group access control list (ACL) by name or number or to enable filtering for packets that will permit packets based on port numbers.

 

ip access-list MANAGEMENT_PROTOCOLS

  10 permit udp any any eq snmptrap

  20 permit tcp any eq 22 any

  30 permit tcp any eq www any

  40 permit tcp any eq 443 any

  50 permit tcp any eq 8443 any

  60 permit udp any any eq ntp

  70 permit udp any any eq domain

 

Marking the different classes of traffic based on different DSCP values.

 

class-map type qos match-any GOLD

  match dscp 24

class-map type qos match-any BRONZE

class-map type qos match-any SILVER

  match access-group name MANAGEMENT_PROTOCOLS

class-map type qos match-any PLATINUM

  match dscp 46

 

Configure policies for classes before applying it to an interface to specify a service-policy. Packets which are matched based on DSCP CS3, CS4/AF41 and EF are given different cos values.

 

policy-map type qos SET_COS_VM

  class PLATINUM

    set cos 5

  class GOLD

    set cos 3

  class SILVER

    set cos 2

  class BRONZE

    set cos 1

  class class-default

    set cos 0

 

Configure policies for classes before applying it to an interface to specify a service-policy. Packets which are matched based on DSCP CS3, CS4/AF41 and EF are given different cos values.

 

policy-map type qos SET_COS_N1KV

  class class-default

    set cos 2

policy-map type qos SET_COS_VMOTION

  class class-default

    set cos 1

policy-map type qos SET_COS_NFS-ISCSI

  class class-default

    set cos 1

 

Class-map for type queuing. Configure policies for classes before applying it to an interface to specify a service-policy. Packets which are matched based on DSCP CS3, CS4/AF41 and EF are given different cos values.

 

class-map type queuing match-any GOLD

  match cos 3

 

class-map type queuing match-any BRONZE

  match cos 1

 

class-map type queuing match-any SILVER

  match cos 2

 

class-map type queuing match-any PLATINUM

  match cos 5

 

Configure policies for classes before applying it to an interface to specify a service-policy. Different class of traffic which are matched based on COS values are given dedicated bandwidth.

 

policy-map type queuing uplink_queue_policy

 

class type queuing GOLD

bandwidth percent 15

 

class type queuing BRONZE

bandwidth percent 30

 

class type queuing SILVER

bandwidth percent 15

 

class type queuing PLATINUM

bandwidth percent 20

 

Related Information

Nexus 1000v: QoS Overview and Traffic Classification Configuration

QoS Design Considerations for Virtual UC with UCS

Version history
Revision #:
2 of 2
Last update:
‎08-29-2017 04:53 AM
Updated by:
 
Labels (1)
Contributors