Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

WCCP Missing Assignment alarm on Cisco WAAS

 

 

Problem

Getting WCCP Missing Assignment alarm on WAAS device.

 

Major Alarms:

-------------

        Alarm ID                 Module/Submodule               Instance

   ---------------             --------------------          ---------------

   1 missing_assignment        WCCP/svc061

 

   2 missing_assignment        WCCP/svc062

 

 

Description

As per the document

 

Alarm 17004 (missing_assignment) WCCP Missing Assignment alarm.

 

Severity: Major

Category: Communications

 

Description: The device has joined the WCCP farm but does not have any assignments. Traffic redirection to the device does not occur. The possible reasons for this to happen could be:

1) if using mask assignment, the mask value of the device is not consistent with the rest of the farm.

2) the device lost all assignments to other devices with higher weights in the farm.

3) the device cannot communicate to all routers in the farm and thus is not given any assignments. The alarm is raised if the WAE does not acquire assignments within three minutes after a change in the farm.

 

Action: Check configuration and connectivity to all routers and take corrective action as needed.

 

Generally the WCCP Missing Assignment alarm is seen on the WAE's when either one of the below events occur:

 

  1. RA’s(Redirect Assignments) are constantly getting dropped. Router never received an updated assignment.
  2. One or more other WAEs have 100% weight, causing WAE to not own any buckets (even though its still part of the farm)
  3. There are more WAEs than the number of (mask) buckets, so one or more WAEs does not get any assignments
  4. Configured mask value of WAE is different from rest of the farm.
  5. WAE cannot see one of the routers hence it is not included in the assignment. (Missing router in WAE’s router list config)
  6. WAE is configured for L2-redirect but router is not L2-adjacent to the WAE.

 

Resolution

Check the configuration for any errors or mistakes.

 

Example 1

Enter the following command on your WAAS device.

 

M653#show wccp route

 

Router Information for Service: TCP Promiscuous 61

        Routers Seeing this Wide Area Engine(1)

        Router Id       Sent To

        192.168.194.1    192.168.194.21

        Routers not Seeing this Wide Area Engine

                192.168.194.1

        Routers Notified of from other WAE's

                Router Id

                192.168.194.33

        Multicast Addresses Configured

                -NONE-

 

Check the router configuration.

 

R1# sh run

 

---snip----

interface SM1/0

ip address 192.168.194.21 255.255.255.0

 

interface Loopback1

ip address 192.168.194.1 255.255.255.0

 

 

Looking at the router configuration, both of the IP address belong to the same Router. Modify the router-list on your WAAS device to only have single IP

address.

 

Example 2

M653#show wccp route

 

Router Information for Service: TCP Promiscuous 61

        Routers Seeing this Wide Area Engine(1)

        Router Id       Sent To

        192.168.194.1    192.168.194.1

        Routers not Seeing this Wide Area Engine

                192.168.194.31

        Routers Notified of from other WAE's

                Router Id

                192.168.194.33

        Multicast Addresses Configured

                -NONE-

 

Check the router configuration.

 

R1# sh run

 

---snip----

interface SM1/0

ip address 192.168.194.21 255.255.255.0

 

Looking at the router configuration it looks like the IP address of the router is misconfigured on the WAAS device. Correct the router IP address.

 

Reference

Monitoring WAAS Using WAAS Central Manager

WCCP missing assignment alarm for service id

Cisco WAAS Troubleshooting Guide for Release 4.1.3

Version history
Revision #:
2 of 2
Last update:
‎08-29-2017 04:34 AM
Updated by:
 
Contributors
Everyone's tags (5)