cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión

Realizar port fowarding en ACE 4710

Tengo un cluster de ACE 4710 y necesito balancear un servicio publicado en los dos server en el port TCP 9763 a traves de una VIP pero esta debe públicar en el puerto TCP 80.

Intente publicarlo cambiando el puerto en class-map de la VIP pero no funciona.

 

Les adjutno una salida del show running para ver si alguno puede ayudarme.

 

------------------------------------------------------

ACE4710# show  run
Generating configuration....

 

logging enable
logging timestamp
logging trap 6
logging buffered 5
logging device-id context-name

access-list GLOBAL line 8 extended permit ip any any

probe icmp GW_172.29.158.1
  ip address 172.29.158.1
  faildetect 2
  passdetect interval 2
  passdetect count 2
probe tcp TCP_9763
  port 9763
  interval 3
  faildetect 2
  passdetect interval 2
  passdetect count 2


rserver host SERVER_A
  ip address 172.29.141.12
  weight 4
  inservice
rserver host SERVER_B
  ip address 172.29.141.13
  weight 4
  inservice

 

serverfarm host Web-Pago-Diferido
  rserver SERVER_A
    probe TCP_9763
    inservice
  rserver SERVER_B
    probe TCP_9763
    inservice


class-map match-any Web-Pago-Diferido
  2 match virtual-address 172.29.158.70 tcp eq www

class-map type management match-any remote_access
  2 match protocol xml-https any
  3 match protocol icmp any
  4 match protocol telnet any
  5 match protocol ssh any
  6 match protocol http any
  7 match protocol https any
  8 match protocol snmp any

policy-map type management first-match remote_mgmt_allow_policy
  class remote_access
    permit


policy-map type loadbalance first-match Web-Pago-Diferido
  class class-default
    serverfarm Web-Pago-Diferido

policy-map multi-match BALANCEO
   class Web-Pago-Diferido
    loadbalance vip inservice
    loadbalance policy Web-Pago-Diferido
    loadbalance vip icmp-reply
 

service-policy input BALANCEO
access-group input GLOBAL


interface vlan 141
  description DMZ-SERVER
  ip address 172.29.141.8 255.255.255.0
  alias 172.29.141.1 255.255.255.0
  peer ip address 172.29.141.9 255.255.255.0
  service-policy input remote_mgmt_allow_policy
  no shutdown
interface vlan 158
  description UPLINK
  ip address 172.29.158.8 255.255.255.0
  alias 172.29.158.7 255.255.255.0
  peer ip address 172.29.158.9 255.255.255.0
  service-policy input remote_mgmt_allow_policy
  no shutdown
 
ft track host GW_172.29.158.1
  probe GW_172.29.158.1
  peer probe GW_172.29.158.1

ip route 0.0.0.0 0.0.0.0 172.29.158.1

 

Etiquetas (1)
1 RESPUESTA

Hola, Pudieran haber tratado

Hola,

Pudieron haber tratado lo siguiente:

serverfarm host Web-Pago-Diferido
  rserver SERVER_A 9763 
    probe TCP_9763
    inservice
  rserver SERVER_B 9763
    probe TCP_9763
    inservice

Aunque la VIP estaba configurada para escuchar en puerto 80, en la granja de servidores pudieron haber usado el puerto en que escuchaban sus servidores.

Saludos!

Jorge

-----

Marquen la respuesta como correcta para que otros usuarios puede tenerla de referencia

39
Visitas
0
ÚTIL
1
Respuestas