Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Advanced System Tasks

I'm having trouble turning an IP command into an Advanced System Task so that it can be scheduled. I know this is a basic function and I'm more than certain I'm overlooking something here, but I just can't seem to get it.

The command to turn on our InFocus televisions is this:

https://admin:password@ip_address/set_param?init.startService_rs232=yes&rs232.device=/dev/ttyS0&rs232.speed=19200&rs232.tx_hex=070001504F4E08

Works great if I execute it from the FireFox address bar. Which is why I don't understand why creating an advanced task, as type "SET" and the request string set to:

init.startService_rs232=yes&rs232.device=/dev/ttyS0&rs232.speed=19200&rs232.tx_hex=070001504F4E08

is causing such a problem.

Is there something fundamentally different about the way the Advanced Tasks are executed as opposed to just making generic http request?

Thanks,

-- Chris G

Everyone's tags (5)
5 REPLIES
Cisco Employee

Re: Advanced System Tasks

The string appears to be ok. The one thing I notice is that you are send

multiple mib set parameters in one task (which is supported).


So I suggest the following to test, record results, and we can then try

to determine the issue.


- First, copy & paste the results of the STATUS mib into a file and

  upload a text file (status-before.txt)


- Then create a SET Task for each set parameter.


ie.


SET

init.startService_rs232=yes


SET

rs232.device=/dev/ttyS0


SET

rs232.speed=19200


SET

rs232.tx_hex=070001504F4E08



- Then, execute each task in sequence to the DMP in question

  Record any errors and the behavior of the attached display

  after the last task is sent.


- Repeat the first step, copy & paste the results of the STATUS

  mib into a file and upload a text file (status-after.txt)


Then we can review the diffs and see what is working and what is not...


Cheers!


T.



New Member

Re: Advanced System Tasks

Tomas,

Thank you for your reply. I thought I'd narrowed down the issue to the type of serial cable I was using. I managed to get the system task to work perfectly with my test setup.

The issue I'm running into, which was addressed in another forum post, is that the DMPs have to have RS-232 initialized first.

When I run the Initialization task, I noticed that it was pointing to the device /dev/ttyS1. I believe it has to be set to /dev/ttyS0, so I created a new initialization task using all the same parameters only pointing to the zero device. After running the task, I get several errors when I check the status. The errors that I'm seeing are attached as DMP_4400_5.2.1.txt. The status of my properly running device is in the file DMP_4400_5.2.txt.

The difference between these two boxes are the versions of the software. One (properly working) is 5.2, the one that is not working is 5.2.1 (a brand new dmp).

Here are a few of the key differences that I'm noticing:

1) On the 5.2 DMP there are 3 extra entries in the mng.slots.

  a) cmd2browser

  b) udp

  c) stream <-- this one appears in the error messages at the end of the 5.2.1 text as "Can not find service [stream]"

2) On the 5.2 DMP one of the slots (14) is called mib365, on the 5.2.1 DMP there is an mib3 (slot 13) that contains similar information to the one previously mentioned.

It seems like something may have possibly changed in this latest version of the firmware. I just can't tell what it is just yet.

-- Chris

Message was edited by: Chris Garrett Blanked ftp passwords. doh.

Cisco Employee

Re: Advanced System Tasks

Chris,


Which advanced task are you looking at?


Also the rs232.device is /dev/ttyS0 but I know the

advanced task on the DMM referencing ttyS1 but it

does work.  As you mentions it is working on the DMP-5.2

device.  They are the same.


So my question is what is not working?

Do not worry about some of the errors in the status. Most

of these occur during bootup and things just had initialized yet...


T.



New Member

Re: Advanced System Tasks

There is a prepackaged System Task called RS-232: Control supported, non-DMTech displays with the request string below:

init.startService_dmttv=no&init.startService_rs232=yes&rs232.device=/dev/ttyS1&mib.save=1&mng.reboot=1

In mine, I set the rs232.device to /dev/ttyS0 and left everything else the same.

Here's the request string on mine:

init.startService_dmttv=no&init.startService_rs232=yes&rs232.device=/dev/ttyS0&mib.save=1&mng.reboot=1

-- Chris

-- Edit

Sorry, I didn't read your response closely enough, it's nearing 5pm here.

The television is not responding to any RS-232 commands that I send through the DMM to the 5.2.1 device. However, the same commands work perfectly fine when sent to my 5.2 device from the DMM.

My concern was that something might have changed from version 5.2 to 5.2.1 that's causing the DMP not to transmit my RS-232 commands.

Thanks,

-- Chris

Cisco Employee

Re: Advanced System Tasks

Chris,


I haven't had an issue with 5.2.1 over rs232.


Some questions:


- What TV\Display (vendor\Model) do you have attached to the working DMP 5.2?

- What TV\Display (vendor\Model) do you have attached to the non-working DMP 5.2.1?


- Are the in the same building or Floor?  Is there a way to swap the two to see of the

problem follows the 5.2.1?


I do not believe it is the version.  You can downgrade the DMP 5.2.1 to 5.2 and verify.


T.

896
Views
0
Helpful
5
Replies
CreatePlease login to create content