Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Routing Multicast Test

I've been testing multicast with DMPs in version 5.2 and VLC.

I have two VLANs: VLAN vlan 20 and 30, my VLC Server is in the vlan 20 and streaming reaches the DMPS that are in this vlan.

The vlan 30 I do not get any streaming.

Attached the configuration I have in my switches:

ip multicast-routing

ip multicast multipath

!

!

interface Vlan20

description "DMS1"

ip address 10.9.2.254 255.255.255.0

ip pim sparse-dense-mode

ip cgmp

!

interface Vlan30

description "DMS2"

ip address 10.9.3.254 255.255.255.0

ip pim sparse-dense-mode

ip cgmp


Anyone know any extra configuration or something I see missing out?


Greetings and thanks

Aurelio Zavaleta

10 REPLIES
Cisco Employee

Re: Routing Multicast Test

ip multicast-routing distributed

! change -> ip multicast-routing

! remove -> ip multicast multipath

!

!

interface Vlan20

description "DMS1"

ip address 10.9.2.254 255.255.255.0

ip pim sparse-dense-mode

ip cgmp

!

interface Vlan30

description "DMS2"

ip address 10.9.3.254 255.255.255.0

ip pim sparse-dense-mode

ip cgmp

Please provide the display output for

the following commands:

#sh ip multicast

#sh ip multicast interface vlan 20

#sh ip multicast interface vlan 30

Thanks

T.

New Member

Re: Routing Multicast Test

Hi Tomas

I tested with the command that you suggested, but I have not been successful.

Annex the configuration of the switch.

Regards

Cisco Employee

Re: Routing Multicast Test

Aurello,


Why do you have the switch ports in VLAN 20 & 30

when your interface VLANs and Multicast interfaces are VLAN 200 & 300?


The Switch ports should be VLAN 200 & 300 not 20 & 30



T.

New Member

Re: Routing Multicast Test

Hi Tomas

I changed the number of interfaces vlan in my lab.

I change the 200 vlan 20 and vlan 30 for 300.

But the problem continues.

This is my current configuration.

interface GigabitEthernet4/5

switchport access vlan 200

switchport mode access

media-type rj45

!

interface GigabitEthernet4/6

switchport access vlan 300

media-type rj45

!

interface Vlan1

no ip address

!

!

interface Vlan200

ip address 100.9.2.254 255.255.255.0

ip pim sparse-dense-mode

ip cgmp

!

interface Vlan300

ip address 100.9.3.254 255.255.255.0

ip pim sparse-dense-mode

ip cgmp

!

Regards

Cisco Employee

Re: Routing Multicast Test


Switch#sh ip multicast interface vlan 200

Vlan200 is up, line protocol is up

  Internet address is

  Multicast routing: enabled

  Multicast switching: fast

  Multicast packets in/out: 3185688/0

  Multicast boundary: not set

  Multicast TTL threshold: 0

  Multicast Tagswitching: disabled


Switch#sh ip multicast interface vlan 300

Vlan300 is up, line protocol is up

  Internet address is

  Multicast routing: enabled

  Multicast switching: fast

  Multicast packets in/out: 8/0

  Multicast boundary: not set

  Multicast TTL threshold: 0

  Multicast Tagswitching: disabled


!

interface FastEthernet2/10

switchport access vlan 20

switchport mode access

!

interface FastEthernet2/11

switchport access vlan 20

switchport mode access

!

interface FastEthernet2/12

switchport access vlan 20

switchport mode access

!

interface FastEthernet2/13

switchport access vlan 30

switchport mode access

!

interface FastEthernet2/14

switchport access vlan 30

switchport mode access


!

interface Vlan200

ip address

ip pim sparse-dense-mode

ip cgmp

!

interface Vlan300

ip address

ip pim sparse-dense-mode

ip cgmp

!

** change the VLAN 20 & 30s to VLAN 200 & 300

New Member

Re: Routing Multicast Test

HI Aurelio,

I am providing you with our configuration (in case that helps),

source svi
---------------------

ip pim sparse-dense-mode

Receiving svi
------------------------
ip pim sparse-dense-mode
ip igmp static-group 239.192.X.X

ip igmp static-group *

and on all point to point links (on your l3 devices)

interface gig

ip pim sparse-dense-mode

The above configuration is valid and functional.

Thank you

New Member

Re: Routing Multicast Test

Hi panayiotiscy

I've tried your commands but I have not been able to set all.
I have a core 6500 and gives me some commands that does not support them.

Thanks for your support

Aurelio

New Member

Re: Routing Multicast Test

Hi Aurelio,

One more command that you need to use is the following (in global mode)

ip multicast-routing 

This command must be issued on all involved l3 devices

It should work for you.

Cisco Employee

Re: Routing Multicast Test

Aurelio,


What is the multicast Address that you are using

for your test?


Please provide the output of the following CLI commands:


Switch# sh ip mroute "the multicast address"



Switch# sh ip mroute



Thanks


T.

New Member

Re: Routing Multicast Test

Hi Tomas:

I found the solution to the problem I had, is a change in the VLC TTL

Check out this link to see the solution: http://forum.videolan.org/viewtopic.php?f=2&t=60983&p=35917

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

******           THIS IS THE SOLUTION              ******

If there is a shortcut on desktop, open the properties.. It must be like "C:\Program Files\VideoLAN\VLC\vlc.exe" --intf wxwin

after this line, add a "--ttl 10" you must ttl value according to your network diameter..

your shortcut will be

"C:\Program Files\VideoLAN\VLC\vlc.exe" --intf wxwin --ttl 10

this will solve ttl issue on GUI.

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Regards and thanks.

1269
Views
0
Helpful
10
Replies