Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EEM Cron-Entry stops working

i don't know if this is the right place for my Problem, but maybe someone have seen something similar.

I gave it to cisco support, but until now, they have no idea what the Problem could be.

I'm using EEM to enable/disable some Interfaces time based. Sometimes the Cron Entrys stops working.

Its running on a C3750X-12S-S with IOS  12.2(58)SE2

I have a Test Job, that produces a syslog Message Every 2 Minutes:

event manager applet Test-cron

event timer cron cron-entry "*/2 * * * *"

action 1 syslog msg "Test Cron"

action 2 cli command "enable"

"The Enable Command is only to check the CLI Commands"

The first Time, this occured, i solved it with a reload. That is a very Bad solution, since every uplink is going down.

Today i tried some things and changed my Test Entry to absolute. And the Job was working. After changing it back to cron, its working again also.

But what could be the reason for the Failure? And how could i track down the issue?

"debug event manager all" seems not to be a good solution.

The Logs will grow too much.

Maybe something missing in my configured Jobs? Perhaps the maxrun statement or something else?

Thanks for your Help.

Everyone's tags (3)
5 REPLIES
Cisco Employee

EEM Cron-Entry stops working

I am familiar with your issue, but we have thus far been unable to recreate it.  What you have said here is new information, though.  Have you relayed this to your TAC engineer?  Perhaps the problem is with the number of times the policy executes, and the timer becomes corrupted somehow.  If we can isolate the trigger, we can get developers looking into the problem.

New Member

EEM Cron-Entry stops working

yes, i gave the Infomration to my TAC. Im trying to collect anything to find the issue. Because the EEM is a cool feature.

Since i figured it out today in the Morning, im waiting for reply.

New Member

Hello,I follow on your post

Hello,

I follow on your post because I have the same problem with a cisco 819. I have a cron job that stops working.

event tag e2 timer cron cron-entry "0 4 * * *"

The job should run every day at 4:00. Some days it runs other days it does not run.

Did you receive a solution to your problem?

Thanks in advance.

New Member

Hi Stefan, there was no

Hi Stefan,

 

there was no solution for the Problem. The case was on detailed investigation, but it was not possible to recreate the failure in a lab Environment.

For us, we deleted an recreated the Job when it stopped working. After the 2nd recreation it was stable for the Time it was needed. But at the moment i have no active EEM Jobs anymore.

New Member

Re: EEM Cron-Entry stops working

Hello Team,

I have the same problem with the event timer cron cron-entry
The configuration works for a certain time, then it does not work.
1512
Views
0
Helpful
5
Replies
CreatePlease login to create content