Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

EEM not working

I have had hit and miss with the EEM  but lately it has stopped working completely. My intent for this EEM is to shut the port if port status show down/disconnected (either system reboots or someone pulls the cable)

track 2 interface FastEthernet3/7 line-protocol

event manager applet interface_fa3/7_down

event track 2 state down

action 1.0 cli command "enable"

action 2.0 cli command "conf t"

action 3.0 cli command "Interface fastEthernet 3/7"

action 4.0 cli command "shut"

action 5.0 mail server "1.1.1.1" to "networkengineering@mail.com" from "devicename@mail.com" subject "EEM has shut down FastEthernet3/7 on devicename and hostname"

I see the following two syslog entry and saw some interface resets on the fa3/7. I suspect that port might have briefly gone down but EEM never kicked in but i still received the email stating that EEM has shut down interface FastEthernet3/7 but EEM never executed.

Jul 18 14:26:52.971: %TRACKING-5-STATE: 2 interface Fa3/7 line-protocol Up->Down

Jul 18 14:27:40.195: %TRACKING-5-STATE: 2 interface Fa3/7 line-protocol Down->Up

I'm runnig this on Cisco 6506E with WS-SUP32-GE-3B  and the following IOS

s3223-advipservicesk9_wan-mz.122-33.SXJ3.bin

Please Advise

2 REPLIES
Cisco Employee

EEM not working

EEM would have tried to shutdown the interface, but perhaps AAA command authorization prevented that from happening.  If so, you would need to configure "event manager session cli username USER" where USER is a user authorized to run all of the CLI commands.  If that's done and it's still not working, then enable "debug event manager action cli" and see why EEM is unable to shutdown the port.

Community Member

EEM not working

Yes, have this command missing, thank you for pointing this out

event manager session cli username USER

320
Views
0
Helpful
2
Replies
CreatePlease to create content