Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Not enough TTY lines to run some EEM applet

Hi everybody,

I'm new in the EEM world and I was trying to set up an automatic backup script as follows (is set up to run every 10 seconds just to check if it works)

event manager applet AUTO-BAKCUP

event timer watchdog time 10 maxrun 31536000

action 1.0 cli command "enable"

action 2.0 cli command "copy run ftp://192.168.xxx.xxx/Original/JoseManuelCortes/running"

action 3.0 cli command "copy start ftp://192.168.xxx.xxx/Original/JoseManuelCortes/startup"

action 4.0 syslog msg "FTP backup Successful"

the problem here is I'm receiving this log message:

Nov 28 16:09:28.223: %HA_EM-3-FMPD_ERROR: Error executing applet AUTO-BAKCUP statement 1.0

ROUTER-TIGO#

Nov 28 16:09:38.223: %HA_EM-3-FMPD_CLI_CONNECT: Unable to establish CLI session: 'Embedded Event Manager' detected the 'fatal' condition 'no tty lines available, minimum of 2 required by EEM'

The device that I have is a Cisco Router 887 with IOS  15.0(1)M7. When I check for the TTY lines I found this:

ROUTER-TIGO#sho line

   Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int

      0 CTY              -    -      -    -    -      0       0     0/0       -

      1 AUX      0/0    -    -      -    -    -      0       0     0/0       -

*     6 VTY              -    -      -    -    -      1       0     0/0       -

*     7 VTY              -    -      -    -    -      1       0     0/0       -

*     8 VTY              -    -      -    -    -      1       0     0/0       -

      9 VTY              -    -      -    -    -      0       0     0/0       -

     10 VTY              -    -      -    -    -      0       0     0/0       -

Line(s) not in async mode -or- with no hardware support:

2-5

ROUTER-TIGO#sho line su

ROUTER-TIGO#sho line summary

        0: ???? ?.UU U??

   3 character mode users.           (U)

   7 lines never used.               (?)

   1 lines do not exist.             (.)

   3 total lines in use, 0 not authenticated (lowercase)

What should I do here? am I unable to run EEM on this router even if it allows the configuration??

Thanks and Regards,

Jose

Everyone's tags (2)
5 REPLIES
Cisco Employee

Not enough TTY lines to run some EEM applet

Generally speaking ftp requires a username and password.  How are you handling that?  Is the ftp server prompting for those and causing the applet to hang?  You have such a huge max run that if that happens these will never timeout and thus the vty's will sit in use forever.  Maybe 'ip ftp username' and 'ip ftp password' in the config can help?

New Member

Not enough TTY lines to run some EEM applet

Hi,

The ftp username and password are already configured in the router. Before I use the script I tested the commands and the transfers were successful, but with the script the problem happens at the very begining that is the "enable" command:

Error executing applet AUTO-BAKCUP statement 1.0

action 1.0 cli command "enable"

Regards,

Cisco Employee

Not enough TTY lines to run some EEM applet

Hi Jose,

In that case it sounds like there is a potential issue with either AAA authorization or the cli_lib parsing of the hostname when the enable mode changes the hostname.  Do you have AAA command authorization enabled?  If so you may need to follow the advice outlined here:

https://supportforums.cisco.com/docs/DOC-12757#EEM_and_AAA_Command_Authorizationdebug event manager action cli

If that doesn't help, then we may need to see the output of some cli debugs, specifically:

debug event manager action cli

Mike

New Member

Not enough TTY lines to run some EEM applet

You need to exit the EEM session by following up your script with:

action 5.0 cli command "end"

action 6.0 cli command "exit"

Otherwise the sessions will pile up until they max out.

New Member

Can you expand on how the

Can you expand on how the sessions backup?  I'm trying to run autocommand as well as an EEM session.  Both are pretty small.  If I remove the autocommand, my EEM works fine, but if I try to run them both, I run out of vty lines???   How do I minimize what vty lines are being used by each?  and how do I clear the vty lines?

7057
Views
10
Helpful
5
Replies
CreatePlease to create content