Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Smartport - 1142 and 3502

Does Smartport support the 1142 AP and the 3502 AP?  It keeps comming up as a Router device - CISCO_ROUTER_EVENT

The 1131 AP work fine.

16 REPLIES
Hall of Fame Super Gold

Smartport - 1142 and 3502

Does Smartport support the 1142 AP and the 3502 AP?

You need to explain a bit more. 

New Member

Smartport - 1142 and 3502

Using the Smartport built-in macros:

macro auto execute CISCO_WIRELESS_LIGHTWEIGHT_AP_EVENT

macro auto execute CISCO_WIRELESS_AP_EVENT

macro auto execute CISCO_ROUTER_EVENT

When we plug in a 1142 AP, the port is assigned to the correct vlan (240) and the macro description shows "CISCO_WIRELESS_LIGHTWEIGHT_AP_EVENT"

When we plug in a 3502 AP, the port is not assigned to the correct vlan (176) and the macro description shows "CISCO_ROUTER_EVENT"

Here are the macros:

macro auto execute CISCO_WIRELESS_LIGHTWEIGHT_AP_EVENT  {

    if [[ $LINKUP -eq YES ]]; then

        conf t

            interface  $INTERFACE

                macro description $TRIGGER

                switchport access vlan 240

                switchport mode access

                spanning-tree portfast

            exit

        end

    fi

    if [[ $LINKUP -eq NO ]]; then

        conf t

            interface  $INTERFACE

                no macro description

                no switchport access vlan 240

                no spanning-tree portfast

                if [[ $AUTH_ENABLED -eq NO ]]; then

                    no switchport mode access

                fi

            exit

        end

    fi

}

!

macro auto execute CISCO_WIRELESS_LIGHTWEIGHT_AP_EVENT  {

    if [[ $LINKUP -eq YES ]]; then

        conf t

            interface  $INTERFACE

                macro description $TRIGGER

                switchport access vlan 176

                switchport mode access

                spanning-tree portfast

            exit

        end

    fi

    if [[ $LINKUP -eq NO ]]; then

        conf t

            interface  $INTERFACE

                no macro description

                no switchport access vlan 176

                no spanning-tree portfast

                if [[ $AUTH_ENABLED -eq NO ]]; then

                    no switchport mode access

                fi

            exit

        end

    fi

}

!

Macro auto execute CISCO_ROUTER_EVENT  {

    if [[ $LINKUP -eq YES ]]; then

        conf t

            interface  $INTERFACE

                macro description $TRIGGER

                switchport access vlan $ACCESS_VLAN

                switchport mode access

                spanning-tree portfast

            exit

        end

    fi

    if [[ $LINKUP -eq NO ]]; then

        conf t

            interface  $INTERFACE

                no macro description

                no switchport access vlan $ACCESS_VLAN

                no spanning-tree portfast

                if [[ $AUTH_ENABLED -eq NO ]]; then

                     no switchport mode access

                fi

            exit

        end

    fi

}

!

Hall of Fame Super Gold

Smartport - 1142 and 3502

Move this thread to the EEM section. 

If Joe Clark is not busy, he should be able to help you.

New Member

Smartport - 1142 and 3502

ok, how do I move the thread?

Hall of Fame Super Gold

Smartport - 1142 and 3502

Upper right-hand corner, under "Action".

Cisco Employee

Smartport - 1142 and 3502

The CDP platform needs to be AIR-LAP for it to fire that macro.  Perhaps these APs identify themselves differently...

New Member

Smartport - 1142 and 3502

So what macro trigger do I use?

Here is what is available by typing the command - macro auto execute ?

CISCO_CUSTOM_EVENT

CISCO_DMP_EVENT

CISCO_IPVSC_EVENT

CISCO_LAST_RESORT_EVENT

CISCO_PHONE_EVENT

CISCO_ROUTER_EVENT

CISCO_SWITCH_EVENT

CISCO_WIRELESS_AP_EVENT

CISCO_WIRELESS_LIGHTWEIGHT_AP_EVENT

Cisco Employee

Smartport - 1142 and 3502

You may have to define your own trigger and a custom profile.  What is the platform advertised by this AP?

New Member

Smartport - 1142 and 3502

AIR-LAP1131AG-A-K9 - this one works (CISCO_WIRELESS_LIGHTWEIGHT_AP_EVENT)

AIR-LAP1142N-A-K9 - this one does not work

AIR-CAO3502I-A-K9 - this one does not work

Cisco Employee

Smartport - 1142 and 3502

But what do you see in show cdp neighbor for these APs?

New Member

Smartport - 1142 and 3502

I typed the 3502 wrong is should be AIR-CAP3402I-A-K9

This is what I see as the platform (above) when I run "sh cdp n d".  If I just type "sh cdp n" I see:

AIR-LAP11 for the AIR-LAP1131AG-A-K9

AIR-LAP11 for the AIR-LAP1142N-A-K9

AIR-CAP35 for the AIR-CAP3502I-A-K9

Cisco Employee

Smartport - 1142 and 3502

Okay, this is bug CSCtk00846, and it should be fixed in 12.2(55)SE4 (on the switch) with the CISCO_WIRELESS_LIGHTWEIGHT_AP_EVENT macro event.  What version of code are you running?

New Member

Smartport - 1142 and 3502

We are running 12.2(55)SE3.  So, this bug is for both the 1142 and 3502?

Cisco Employee

Smartport - 1142 and 3502

The fix for this bug should handle both regardless of whether or not they are native lightweight or were converted to lightweight.

New Member

Smartport - 1142 and 3502

We finally had a chance to update the IOS to 12.2(55)SE8.  The 1142N is still causing the CISCO_ROUTER_EVENT to trigger.

Here is some more info:

cs-VangPao-M-C#sh run | b 7/0/1

interface GigabitEthernet7/0/1

macro description CISCO_ROUTER_EVENT

!

================================================================================

cs-VangPao-M-C#sh ver

Cisco IOS Software, C3750E Software (C3750E-UNIVERSALK9-M), Version 12.2(55)SE8,

RELEASE SOFTWARE (fc2)

Technical Support:

http://www.cisco.com/techsupport

Copyright (c) 1986-2013 by Cisco Systems, Inc.

Compiled Wed 26-Jun-13 09:56 by prod_rel_team

Image text-base: 0x00003000, data-base: 0x02800000

Device ID: VangPao107_APa44c.117f.8a77
Entry address(es):
  IP address: 10.20.0.118
Platform: cisco AIR-LAP1142N-A-K9,  Capabilities: Router Trans-Bridge
Interface: GigabitEthernet7/0/1,  Port ID (outgoing port): GigabitEthernet0.1
Holdtime : 174 sec

Version :
Cisco IOS Software, C1140 Software (C1140-K9W8-M), Version 15.2(4)JA1, RELEASE S
OFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2013 by Cisco Systems, Inc.
Compiled Tue 30-Jul-13 23:25 by prod_rel_team

advertisement version: 2
Duplex: full
Power drawn: 15.400 Watts
Power request id: 9536, Power management id: 2
Power request levels are:15400 14500 0 0 0
Management address(es):

cs-VangPao-M-C#sh ver

Cisco IOS Software, C3750E Software (C3750E-UNIVERSALK9-M), Version 12.2(55)SE8,

RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2013 by Cisco Systems, Inc.

Compiled Wed 26-Jun-13 09:56 by prod_rel_team

Image text-base: 0x00003000, data-base: 0x02800000

================================================================================

Device ID: VangPao107_APa44c.117f.8a77
Entry address(es):
  IP address: 10.20.0.118
Platform: cisco AIR-LAP1142N-A-K9,  Capabilities: Router Trans-Bridge
Interface: GigabitEthernet7/0/1,  Port ID (outgoing port): GigabitEthernet0.1
Holdtime : 174 sec

Version :
Cisco IOS Software, C1140 Software (C1140-K9W8-M), Version 15.2(4)JA1, RELEASE S
OFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2013 by Cisco Systems, Inc.
Compiled Tue 30-Jul-13 23:25 by prod_rel_team

advertisement version: 2
Duplex: full
Power drawn: 15.400 Watts
Power request id: 9536, Power management id: 2
Power request levels are:15400 14500 0 0 0
Management address(es):

================================================================================

Any other thoughts here?

Cisco Employee

Smartport - 1142 and 3502

The problem is the "Router" capability of the AP.  I found a bug that was unreproducible that hinted controller version may have something to do with this.  I'm not sure what controller version you're using, but perhaps a change in controller code will fix this.  Unfortunately, I couldn't find any more specifics on this as the one customer that encountered it (in controller 7.3.101 code) just used the CISCO_ROUTER_EVENT as a workaround.

556
Views
0
Helpful
16
Replies