Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Tcl Script on Device Not Supporting EEM Features

Hello Community,

This may be a dumb question, however is it possible to apply a Tcl script to a device that doesn't support certain EEM commands.

For example, I'm about to convert the following EEM commands to Tcl using the EEM converter.

event manager applet object

event tag SLA1 track 1 state down

event tag SLA2 track 2 state down

event tag SLA3 track 3 state down

trigger

  correlate event SLA1 or event SLA2 or event SLA3

action 1.0 syslog msg "Track $_event_tag1 is down"

!

However, I'm going to register the converted Tcl on a device that doesn't support, things like trigger, correlate or event tag.

Will the script still work?

Cheers

Carlton

1 REPLY
Cisco Employee

Tcl Script on Device Not Supporting EEM Features

No.  Even with Tcl you need to adhere to minimum EEM versions.  Multi-event support requires EEM 2.4 or higher.

247
Views
0
Helpful
1
Replies