Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Help with Group Query

Hello,
I have this C100 with v6.0.0-747 asyncos.

I configured LDAP Server Profile and Group Query with:

Query String:(&(memberOf={g})(mail={a}))

or

(&(memberOf={g})(|(mail={a})(proxyAddresses=smtp:{a})))

When I run a Test query for both, I receive an:

Success — Action: match positive.
Reason: address confirmed as a member of the group.

Showing that my configuration is OK.

Then I go to the Mail policies, Outgoing Content Filters and created the following filter:

Tamanho_de_email_Armazens_outgoing_sender: if (recv-listener == "Outgoing") AND (mail-from-group == "cn=G_Email_ARMAZENS,ou=Grupos de Departamentais,dc=xxxx,dc=corp") AND (body-size >= 2097152) { notify ("$EnvelopeSender", "", "", "Tamanho de email Armazens"); drop(); }

When I do a trace, here is the result for the same email that mached in the test query:

Tamanho_de_email_Armazens_outgoing_sender Condition: recv-listener == "Outgoing": True
Condition: mail-from-group == "cn=G_Email_ARMAZENS,ou=Grupos de Departamentais,dc=caramuru,dc=corp": False

I configured a Log Subscriptions of LDAP Debug Logs, there I can see the following messages:

Fri Apr 11 00:05:27 2008 Critical: LDAP: Listener Outgoing does not reference a valid group query, comparison in filter will evaluate as false

Any ideias?

many thanks for your help, Leon.

4 REPLIES
New Member

Re: Help with Group Query

Did you make sure you enabled the Group query on your Outgoing listener? [Network > Listener > Outgoing listener], then expand the LDAP queries at the bottom and make sure you turn on the Group query.

Same goes for Inbound if you plan to use Group query with the "Incoming Mail policies"


Hello,
I have this C100 with v6.0.0-747 asyncos.

I configured LDAP Server Profile and Group Query with:

Query String:(&(memberOf={g})(mail={a}))

or

(&(memberOf={g})(|(mail={a})(proxyAddresses=smtp:{a})))

When I run a Test query for both, I receive an:

Success — Action: match positive.
Reason: address confirmed as a member of the group.

Showing that my configuration is OK.

Then I go to the Mail policies, Outgoing Content Filters and created the following filter:

Tamanho_de_email_Armazens_outgoing_sender: if (recv-listener == "Outgoing") AND (mail-from-group == "cn=G_Email_ARMAZENS,ou=Grupos de Departamentais,dc=xxxx,dc=corp") AND (body-size >= 2097152) { notify ("$EnvelopeSender", "", "", "Tamanho de email Armazens"); drop(); }

When I do a trace, here is the result for the same email that mached in the test query:

Tamanho_de_email_Armazens_outgoing_sender Condition: recv-listener == "Outgoing": True
Condition: mail-from-group == "cn=G_Email_ARMAZENS,ou=Grupos de Departamentais,dc=caramuru,dc=corp": False

I configured a Log Subscriptions of LDAP Debug Logs, there I can see the following messages:

Fri Apr 11 00:05:27 2008 Critical: LDAP: Listener Outgoing does not reference a valid group query, comparison in filter will evaluate as false

Any ideias?

many thanks for your help, Leon.

New Member

Many thanks

What a silly question!! I'm ashemed :oops: . After turning on the group query, everything works as expected.

I had this filter working on incoming listener then I created another listener and forgot to turn on the group query.

Maybe in future releases, LDAP Debug Logs can point to turn on the group query.

Many thanks for your help, Leon.

New Member

Re: Many thanks

Actually, the LDAP debug log kind of already does that. This entry is what helped me think that the group query wasn't being assigned to anything yet.



Fri Apr 11 00:05:27 2008 Critical: LDAP: Listener Outgoing does not reference a valid group query, comparison in filter will evaluate as false

New Member

Re: Help with Group Query

Just to share this scenario with all citizens.
They have a qmail server. But doing all search usind AD. I know all information is duplicated but as almost every customer have AD and is easy to administrate it is a good alternative. But as exchange is not installed schema wasnt extended.

Here follow LDAP Server Settings to use with AD without exchange installed:

Domain controlers are Win2003
Port:3268

Accept Query
Query String: (mail={a})

Group Query
Query String: (&(memberOf={g})(mail={a}))

Tested and working.

Cheers, Leon.

438
Views
0
Helpful
4
Replies
CreatePlease to create content