Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

ASK THE EXPERT- CALL MANAGER PROTOCOLS

Welcome to the Cisco Networking Professionals Ask the Expert conversation. This is an opportunity to discuss Call Manager Protocols with Cisco expert Chester Rieman. Chester is a customer support engineer at Cisco Systems, Inc. He has been with Cisco for three years, working primarily with the AVVID team Architecture for Voice, Video and Integrated Data in RTP. Feel free to post any questions relating to Call Manager Protocols. Remember to use the rating system to let Chester know if you’ve received an adequate response.

Chester might not be able to answer each question due to the volume expected during this event. Our moderators will post many of the unanswered questions in other discussion forums shortly after the event. This event lasts through September 19. Visit this forum often to view responses to your questions and the questions of other community members.

40 REPLIES
New Member

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

A question in regards to MGCP and the WS-6608 blade for the Catalyst 6500. When will this or a version of IOS be supported if ever on that blade? Using skinny is very easy to implement these T1 spans but troubleshooting leaves a lot to be desired. I would love to have a version IOS loaded on these so they would support typical debug commands like ' debug isdn q931' so you can view the in and out call information.

John

Cisco Employee

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

John,

The 6608 is actually controlled via MGCP from the call manager. I agree that the troubleshpooting tools for this device leave som ething to be desired.

The best way to see the q931 debugs is to set callmanager tracing to detailed and make sure you have gateway traces enabled. Find a file on your callmanager called q931translator.exe and run it.

From within this .exe open the .txt trace file from the time in question. This will show the debugs almost like the debug isdn q931 from an IOS device.

I don't think we will ever see IOS on the 6608, unfortunatly. Hope this helps.

Chester

New Member

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

I'm using the Call Manager 3.3 with Cisco IP phones 7960 and 7905 and I'm having problems with the outbound calls from the phones. How should I configure the Cisco 1760 for correct outbound calling?

Moreover, is it possible to interconnect the three protocols with this gateway?

and a SIP phone can call to a SCCP phone?

Thanks

Cisco Employee

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

All outbound calling configuration is done at the callmanager, you should not have to do anything special on the phones themselves. WHy would you want to use 3 protocols? Pehaps if you explain what you are trying to do here....

A SIP phone cannot call an SCCP without the aid of a SIP proxy server and a callmanager.

New Member

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

Hi Chester,

I have a couple of quick Q's re security/securing of VoIP protocols in "Cisco" enviroment

When will call signalling and payload encryption become available using sRTP and ipsec ?

I heard encrypting intra cluster traffic will be secured as well any update ?

Also when is 802.1x support for Cisco range of desk phones available.

thanks

Allan

Cisco Employee

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

Allan,

This will start coming out in the next major release of callmanager (4.0) starting with phone encryption. Gateway encryption will be in a service release for 4.0 sometime after the main release. Encryption support for IOS gateways will be around the same timeframe. HEre is our whitepaper for VoIP security:

http://www.cisco.com/en/US/netsol/ns110/ns170/ns171/ns128/networking_solutions_white_paper09186a00801b7a50.shtml

802.1x is there now, take a look at this link.

http://www.cisco.com/en/US/partner/products/hw/switches/ps628/products_configuration_guide_chapter09186a00800d84c0.html

Hope this helps,

Chester

New Member

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

Hi,

I would like integrate live audio source through sound card to the call manager. How can i integrate this system.

Cisco Employee

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

You could do this by substituting the live audio source for the cd player...http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_administration_guide_chapter09186a00800b3eac.html

Cisco Employee

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

I found a bit more info:

You can use the Telex P-800 USB audio device to support music from an external music on hold source. The following servers support the device: MCS-7825H-2.2-EVV1, MCS-7835H-2.4-EVV1, MCS-7835I-2.4-EVV1, MCS-7845H-2.4-EVV1 and MCS-7835-1266.

New Member

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

i'm running an all-cisco voip network (6608-T1/E1 on C7609OSR, AS5400HPX,7960 IP Phones, n x CCM 3.3).

since there has been a lot of dos attacks going on, i'd like to secure the voip side most specially. i have looked into the ports being used by ccm. i made a named-access list on my 7600. below is the snip. calls wouldn't go through.. someone might have had a similar case:

! -------------------------------

! ip access-list extended ccm_out

! To be applied outbound VLAN9

! to filter packets destined for CCM Server

! -------------------------------

! CCM_IP = x.x.y.243

! CCM_IP2 = x.x.z.211

! DNS_IP = x.x.y.2

! AS5400_A = x.x.x.74

! AS5400_B = b.b.b.50

! AS5400_C = c.c.c.114

! IP_PHONE_NET = x.x.z.192 /26

! WS6608_NET = x.x.y.64 /26

ip access-list extended ccm_out

! ---UDP PORTS---

! DNS

permit udp host x.x.y.2 eq 53 any

! TFTP (IP Phone/MGCP Gateway)

! udp 69

permit udp host x.x.x.52 host x.x.y.243 eq 69

permit udp x.x.x.64 0.0.0.63 host x.x.y.243 eq 69

! NTP

! udp 123

permit udp host x.x.x.35 eq 123 any

! snmp

! udp 161

permit udp host x.x.x.35 any eq 161

permit udp host x.x.x.39 any eq 161

! snmp-trap

! udp 162

! MGCP

! udp 2427

permit udp x.x.x.64 0.0.0.63 host x.x.y.243 eq 2427

! RTP

! udp range 16384 32767

permit udp host a.a.a.50 host x.x.y.243 range 16384 32767

permit udp host c.c.c.114 host x.x.y.243 range 16384 32767

permit udp x.x.x.64 0.0.0.63 host x.x.y.243 range 16384 32767

permit udp x.x.z.192 0.0.0.63 host x.x.y.243 range 16384 32767

! ---TCP PORTS---

! HTTP/Admin pages

! tcp 80

permit tcp host x.x.x.39 any eq 80

! LDAP

! tcp 389

! SSL/Admin pages

! tcp 443

permit tcp host x.x.x.39 any eq 443

! SMB (CCM Servers)

! tcp 445

permit tcp host x.x.z.211 host x.x.y.243 eq 445

permit tcp x.x.x.64 0.0.0.63 host x.x.y.243 eq 445

! MS-SQL (Callmanager Servers)

!tcp 1433

permit tcp host x.x.x.39 host x.x.y.243 eq 1433

permit tcp host x.x.z.211 host x.x.y.243 eq 1433

! h.323 RAS (Gateway/Gatekeeper)

! tcp 1719

permit tcp host a.a.a.50 host x.x.y.243 eq 1719

permit tcp host c.c.c.114 host x.x.y.243 eq 1719

permit tcp x.x.x.64 0.0.0.63 host x.x.y.243 eq 1719

permit tcp x.x.z.192 0.0.0.63 host x.x.y.243 eq 1719

! h.323 h.225 (H.323 Gateway)

! tcp 1720

permit tcp host a.a.a.50 host x.x.y.243 eq 1720

permit tcp host c.c.c.114 host x.x.y.243 eq 1720

permit tcp x.x.x.64 0.0.0.63 host x.x.y.243 eq 1720

permit tcp x.x.z.192 0.0.0.63 host x.x.y.243 eq 1720

! SCCP (IP Phone)

! tcp 2000

permit tcp host x.x.x.52 host x.x.y.243 eq 2000

permit tcp x.x.x.64 0.0.0.63 host x.x.y.243 eq 2000

! Backhaul (MGCP)

! tcp 2428

permit tcp x.x.x.64 0.0.0.63 host x.x.y.243 eq 2428

! CTI/QBE (Jtapi/Tapi/CTI Apps)

! tcp 2478

permit tcp x.x.z.192 0.0.0.63 host x.x.y.243 eq 2478

! Tapi/Jtapi (Softphone/IP-IVR/IPCC)

! tcp 2748

permit tcp x.x.z.192 0.0.0.63 host x.x.y.243 eq 2748

! terminal services

! tcp 3389

! HID Agent (HID Console)

! tcp 5000

! ICCS (CCM Servers)

! tcp 8002

permit tcp x.x.x.64 0.0.0.63 host x.x.y.243 eq 8002

permit tcp host x.x.z.211 host x.x.y.243 eq 8002

! CTIM (CCM Servers CTI Manager)

! tcp 8003

permit tcp x.x.x.64 0.0.0.63 host x.x.y.243 eq 8003

permit tcp host x.x.z.211 host x.x.y.243 eq 8003

! DC Directory (SoftPhone)

! tcp 8404

permit tcp x.x.z.192 0.0.0.63 host x.x.y.243 eq 8404

! Cisco Tomcat IIS Web Requests

! tcp 2912

! tcp 8007

! tcp 8009

! tcp 8111

! tcp 8222

! tcp 8333

! tcp 8444

! tcp 8555

! tcp 8666

! tcp 8998

! tcp 9007

! h.323 h.245 (H.323 Gateway)

! tcp range 11000 65535

permit tcp host a.a.a.50 host x.x.y.243 range 11000 65535

permit tcp host c.c.c.114 host x.x.y.243 range 11000 65535

permit tcp x.x.x.64 0.0.0.63 host x.x.y.243 range 11000 65535

permit tcp x.x.z.192 0.0.0.63 host x.x.y.243 range 11000 65535

! --- ICMP ---

! echo (IP Phone)

! icmp echo/echo-reply

permit icmp host a.a.a.50 any echo

permit icmp host a.a.a.50 any echo-reply

permit icmp host c.c.c.114 any echo

permit icmp host c.c.c.114 any echo-reply

permit icmp x.x.x.0 0.0.0.255 any echo

permit icmp x.x.x.0 0.0.0.255 any echo-reply

permit icmp x.x.z.192 0.0.0.63 any echo

permit icmp x.x.z.192 0.0.0.63 any echo-reply

! --- EXPLICITY DENY ---

deny ip any any

Cisco Employee

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

By calls don't go through, do you mean you get a fast busy or does the call setup work OK and you get no audio? I see you have this for RTP:

RTP

! udp range 16384 32767

permit udp host a.a.a.50 host x.x.y.243 range 16384 32767

permit udp host c.c.c.114 host x.x.y.243 range 16384 32767

permit udp x.x.x.64 0.0.0.63 host x.x.y.243 range 16384 32767

permit udp x.x.z.192 0.0.0.63 host x.x.y.243 range 16384 32767

This looks like you are allowing the RTP traffic between callmanager and the endpoints, but when the call is up, the RTP stream will be between the phones and the gateways (or between the phones) and the only RTP traffic that touches the callmanager is music on hold.

Hope this helps....

New Member

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

I can't decide whether to use MGCP or H323 for my gateways. which one is best?

Cisco Employee

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

It all depends how much you want to centralize control at callmanager. Since MGCP has the callmanager directly controlling the endpoints, all the call routing decisions are made at the callmanager where with H323 the call routing decisions through gateways are determined by the configuration of the dial peers. So with MGCP you just need to make callmanager changes for any routing changes and with H323 you may need to change dial peers on the gateways. H323 is a peer to peer protocol while MGCP is more of a controller/gateway protocol.

New Member

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

Hi Chester,

The IOS version 12.2(15)T5 has serious software issue.I found that all the bug about the IOS. BUt I don't found any bugs I meet. Now I have installed a vg200 which has 2 port T1 card. The vg200 is configed to MGCP and connects to callmanager ver 3.1(4b).

Some IP phone user always says ip phone has a silence during the outside call.

That does not happen in every call. My situation, We have a hotline to receive outside call. My users receive 30-40 calls in every day. But the case only happens about 3-4 calls. Those calls happen a silence about 1 or 2 sec.

Is it the software bug ???

Thank You

Cisco Employee

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

It is hard to say whether this is a bug or not without more detailed information. When does the silence happen -at the beginning of a call? To troubleshoot something like this we would need to see the MGCP messages between the callmanager and the gateway. From this we could tell if it was a callmanager issue where the MGCP messages were not sent correctly or a gateway issue where it received the right message but did not start the audio stream correctly. You may want to try 12.2(15)T7 as a test. Hope this helps.

New Member

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

Question on H323 gw fast start and CCM compatibility. Can I run H323 fast start between a 7206 (12.2 15T5) and CCM 3.3(3)SR1?

Cisco Employee

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

Callmanager can be configured to accept faststart calls, but does not place fatsstart calls. to configure callmanager to accept inbound faststart calls from the gateway, go to ccmadmin>service>service parameters>choose the publisher server and callmanager service.

Under the section titled "Cluster Wide Parameters (Device - H323)" there is a parameter called "H323 FastStart Inbound" that is set to flase by default. Change this to true, hit update and callmanager will be ready to accept faststart inbound calls.

Hope this helps....

New Member

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

Hi,

I have Callmanager 3.3(2), H.323 gateways and Cisco Conference Connection 1.2(2). When i set "H323 FastStart Inbound" to true, PSTN users who try use CCC cannot participate in conference (they can interact with IVR in CCC, but then hear nothing and disconnect). When i set "H323 FastStart Inbound" to false, all users can use CCC without problems, but then arise problem with regions, which could be resolved with faststart calls. Could you explain how must CCM, CCC and H.323 gateway interact in this case. Is described situation a bug or expected behavior ? What can i do if i need both - using H.323 faststart and using CCC not only for inbound users.

Thank You,

Sergey

New Member

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

Hi Chester,

That does not happen at the beginning of the call. It happens during the call. The Ip phone user can not hear the voice but

the external user can hear the voice. After 1 or 2 sec, the call become normal.

Would you suggest some tools or command which can help to see the status of gateway ??

THX

Cisco Employee

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

THis would be some type of issue in the RTP strem between the phopne and the gateway. The best way to find out what is happening is a sniffer capture. Things that can cause a symptom like this would be a routing topology change, spanning tree re-converging, or an interface problem. Check all the interfaces between the gateway and the phone to be sure there are not drops, errors, deffers, etc.

New Member

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

Hi Chester,

We have a IPT network with arounf 600 Ip phones with Call Manager3.3(3).

We need to integrated a SIP network with it so that we can pass calls between the SIP proxy servers and the Call Manager servers so that SIP clients can talk to IP phones.

Do you have any design white papers on this which I can reference.

And also when can we expect the IP phones to dual boot in MGCP as well as SIP.

I will appreciate your response.

Cisco Employee

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

Currently the only way to do this is by using back to back gateways to a sip proxy. There are plans to support sip in callmanager version 4.0 which is still a bit in the future. There are a couple of other projects in the works to get this all working together, but nothing is avaible right now.

I am looking into what white papers or background info I can on this.

The phones will not be able to dual boot into SIP or MGCP with the same load, the load needs to be changed for this to happen. I don't think they will ever be able to dual boot to SIP or MGCP with the same load due to memory limitations.

Hope this helps....

New Member

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

Using ccm's software conferencing resources, can an analog phone attached to a gateway (like the 8 port fxs module for routers) make ad hoc conference calls? Can they drop the last caller? I noticed that the ATA adapter had the ability to simulate hookflash, but that is using h.323 and I don't know if ccm would recognize the h.323 hookflash. Regardless, I would want higher port density that the ATA.

Also, what degree of integration do analog phones have with Conference Connection via CCM? Can they transfer into the confernce, put calls on hold while in the conference, etc? (Kind of doubt it :()

Cisco Employee

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

I don't see why this wouldn't work. For greater port density use an IOS gateway with a couple of 4 port FXS cards or for even more use a VG248.

The analog phone should be able to do all the functions for conference connection. I don't have the specific, but I am trying to get this info.

I'll post it here when I get it.

New Member

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

Hi

We are currently using H323 Gateway for Remote sites. We have SRST implemented on all the remote router. If we use MGCP for Remote sites, will it support SRST?

Thanks

Cisco Employee

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

New Member

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

Are there any issues with mgcp and call manager 3.3 when integrating FAX machines. I have this scenario and although i have dialtone that is all i have. Ant pointers???

Cisco Employee

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

It all depends on what gateways, whatt version of gateway SW and version of callmanager.

See this page for the support matrix:

http://www.cisco.com/en/US/tech/tk652/tk777/technologies_tech_note09186a0080159cf3.shtml

Let me know if you find what you need on this page.

New Member

Re: ASK THE EXPERT- CALL MANAGER PROTOCOLS

Regarding Call Manager on the 7815I-2000 server, everything I have been reading says that the server can handle up to 300 phones, and can be run in a 2-server cluster. Is there anything preventing the 7815 from having more than 2 servers in a cluster to increase the number of phones to 600 or more?

59
Views
8
Helpful
40
Replies