Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CONNECTIVITY

Welcome to the Cisco Networking Professionals Ask the Expert conversation. This is an opportunity to get an update on how to configure and troubleshoot Cisco Access Servers for ISDN/Modems/PPP connectivity with Cisco expert Makarand Chitale. Marakand is a manager in the Cisco Technical Assistance Center (TAC) based out of San Jose. He joined Cisco as a TAC engineer in 1999. Makarand was involved in escalations for troubleshooting complex issues, provided training, and authored documentation. His areas of expertise included configuration and troubleshooting of Access Servers, PPP, VPDN etc. He is a CCIE # 7071 for ISP Dial. Makarand was the world wide Subject Matter Expert (SME) for Access technology which involves improving the web documentation. He holds a bachelor's degree in Marine Engineering (mechanical/electrical & telecommunication engineering).

Remember to use the rating system to let Makarand know if you have received an adequate response.

Makarand might not be able to answer each question due to the volume expected during this event. Our moderators will post many of the unanswered questions in other discussion forums shortly after the event. This event lasts through September 19, 2008. Visit this forum often to view responses to your questions and the questions of other community members.

21 REPLIES
Silver

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

Hi

How does a Access server differential between an incoming ISDN call and analog call?

Thanks!

Cisco Employee

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

In the output of "debug isdn q931" the Bearer Capability (or bearercap) tells the router what kind of call is coming in. For example 0x8890 (Bearer Capability i = 0x8890) indicates "ISDN Speed 64 Kb/s". If the bearercap had been 0x8090A2, it would have indicated "Speech/voice call u-law".

Example of debug isdn q931:

Router# debug isdn q931

RX <- SETUP pd = 8 callref = 0x06

Bearer Capability i = 0x8890

Channel ID i = 0x89

Calling Party Number i = 0x0083, `5551234'

TX -> CONNECT pd = 8 callref = 0x86

RX <- CONNECT_ACK pd = 8 callref = 0x06

Thanks, Mak

Community Member

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

Guys,

I am setting up some BRIs to be used in a DDR configuration. For right now, I am just trying to get the basics working and then build up the design. I can get the dialer to come up but ran into a problem when trying to get more B channels to come up (more than 2 and I have a total of 8).

The main symptom is that the router never tries dialing past the first two dialer strings. So, just to check, I removed the first two after the corresponding B channels had come up and the router moved on, creating a bundle of 4 B channels (2 more). At that point, it wouldn't move on to the next two.

I found an old bug (CSCeb20580) which talks about this exact symptom but it is supposedly resolved and has been since 12.3.

Any chance there is another command I could be missing that would cause the same symptom?

Thank you,

Jeremy

Cisco Employee

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

Jeremy, please post the show runn/ sh ver / sh diag for me.

After the first 2 channels are up make sure you have an extened ping going on to generate enough traffic for additional channels to be brought up.

Thanks, Mak

Community Member

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

re-server

!

dialer-list 1 protocol ip permit

!

scheduler allocate 20000 1000

!

end

Router1#sh ver

Cisco IOS Software, 2800 Software (C2800NM-ADVENTERPRISEK9-M), Version 12.4(18b), RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by Cisco Systems, Inc.

Compiled Mon 19-May-08 15:43 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

System image file is "flash:c2800nm-adventerprisek9-mz.124-18b.bin

Cisco 2811 (revision 53.50) with 509952K/14336K bytes of memory.

Processor board ID FTX1138A387

2 FastEthernet interfaces

4 ISDN Basic Rate interfaces

2 Channelized (E1 or T1)/PRI ports

1 Virtual Private Network (VPN) Module

Integrated NT1's for 4 ISDN Basic Rate interfaces

DRAM configuration is 64 bits wide with parity enabled.

239K bytes of non-volatile configuration memory.

125440K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

Router1#sh flash

-#- --length-- -----date/time------ path

1 50938004 Sep 19 2007 22:13:00 +00:00 c2800nm-advipservicesk9-mz.124-15.T1.bin

2 1823 Sep 19 2007 22:24:22 +00:00 sdmconfig-2811.cfg

3 6036480 Sep 19 2007 22:24:58 +00:00 sdm.tar

4 861696 Sep 19 2007 22:25:16 +00:00 es.tar

5 1164288 Sep 19 2007 22:25:36 +00:00 common.tar

6 1038 Sep 19 2007 22:25:52 +00:00 home.shtml

7 113152 Sep 19 2007 22:26:06 +00:00 home.tar

8 1697952 Sep 19 2007 22:26:34 +00:00 securedesktop-ios-3.1.1.45-k9.pkg

9 416354 Sep 19 2007 22:26:52 +00:00 sslclient-win-1.1.3.173.pkg

10 40149900 Sep 5 2008 21:10:56 +00:00 c2800nm-adventerprisek9-mz.124-18b.bin

26775552 bytes available (101404672 bytes used)

Community Member

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

Ok,

Here is the first part of the config:

sh ver h run

Router1k#sh running-config

Building configuration...

Current configuration : 2831 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router1

!

boot-start-marker

boot system flash:c2800nm-adventerprisek9-mz.124-18b.bin

boot-end-marker

!

! card type command needed for slot/vwic-slot 0/0

no logging console

enable secret 5

!

aaa new-model

!

!

!

aaa session-id common

--More-- !

!

ip cef

!

!

no ip domain lookup

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

isdn switch-type basic-5ess

!

voice-card 0

no dspfarm

!

!

!

!

!

!

!

!

!

!

--More-- !

!

!

!

username Router2 password 0

archive

log config

hidekeys

!

!

!

!

!

!

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface FastEthernet0/0

ip address 10.10.0.1 255.255.255.248

duplex auto

speed auto

!

--More-- interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface BRI1/0

description ISDN B1:71234, B2:71235

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-5ess

isdn point-to-point-setup

isdn spid1 0000071234

isdn spid2 0000071235

ppp authentication chap

ppp multilink

!

interface BRI1/1

description ISDN B1:71236, B2:71237

no ip address

encapsulation ppp

dialer pool-member 1

--More-- isdn switch-type basic-5ess

isdn point-to-point-setup

isdn spid1 0000071236

isdn spid2 0000021237

ppp authentication chap

ppp multilink

!

interface BRI1/2

description ISDN B1:71238, B2:71239

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-5ess

isdn point-to-point-setup

isdn spid1 0000071238

isdn spid2 0000071239

ppp authentication chap

ppp multilink

!

interface BRI1/3

description ISDN B1:71230, B2:71231

no ip address

encapsulation ppp

--More-- dialer pool-member 1

isdn switch-type basic-5ess

isdn point-to-point-setup

isdn spid1 0000071230

isdn spid2 0000071231

ppp authentication chap

ppp multilink

!

interface Dialer1

description BRI bundle to Router2

ip address 2.1.1.1 255.255.255.252

encapsulation ppp

dialer pool 1

dialer remote-name Router2

dialer idle-timeout 0

dialer string 70001

dialer string 70002

dialer string 70003

dialer string 70004

dialer string 70005

dialer string 70006

dialer string 70007

dialer string 70008

--More-- dialer load-threshold 1 either

dialer persistent

dialer-group 1

ppp authentication chap

ppp multilink

ppp multilink links minimum 8

ppp multilink multiclass

!

router ospf 0

log-adjacency-changes

network 2.1.1.1 0.0.0.3 area 0

network 10.10.0.1 0.0.0.7 area 0

network 1.1.1.1 0.0.0.0 area 0

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!

ip http server

no ip http secure-server

!

Cisco Employee

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

Please try the "dialer order xxxx" command under the dialer interface.

dialer order [sequential | round-robin | last-successful]

More details at:

http://tools.cisco.com/Support/CLILookup/cltSearchAction.do

Thanks, Mak

Silver

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

Hi,

What is the use of “magic number” during a PPP connection?

Thanks

Cisco Employee

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

The LCP negotiation uses the MagicNumber to determine if the link is looped back. A random string is sent across the link and, if the same value is returned, then the router determines that the link is looped back.

Another way to explain is,PPP detects looped links using a feature involving magic numbers. When the node sends PPP LCP messages, these messages may include a magic number. If a line is looped, the node receives an LCP message with its own magic number, instead of getting a message with the peer's magic number.

Thanks, Mak

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

Hi,

are there any good link to learn and hands on about PPPoE, which can provide debugs/show commands output too?

regards

Devang Patel

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

hi,

As PPPoE is the point to point technology on the broadcast media, so what are the advantages of using it other than providing the isolation between the different service provider customers?

as PPPoE will assign the /32 to the client of it will it be possible to assign the same subnet mask as the server is holding on its interface?

"Peer-neighbor route, it is changing the way peer will build their neighborship" what is that exactly? can you provide me one example of the same case?

regards

Devang Patel

Cisco Employee

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

No. PPPoE will always assign a /32 as it is assigning an IP from a pool of IP's defined on the router. All hosts get a single IP address otherwise we will be wasting address space that we are using to assign to hosts.

Thanks, Mak

Cisco Employee

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

PPPoE has a lot of features.

Here are a few links that can help understand, configure and troubleshoot PPPoE technology.

RFC 2516 - A method to transmit PPP over Ethernet (PPPoE) http://www.faqs.org/rfcs/rfc2516.html

Configuring PPPoE Client on the Cisco 2600 to Connect to a Non-Cisco DSL CPE http://www.cisco.com/en/US/partner/tech/tk175/tk15/technologies_configuratio

n_example09186a0080126dc0.shtml

Cisco DSL Router Configuration and Troubleshooting Guide - PPPoE Online Form http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_exampl

e09186a008071a7d1.shtml

Troubleshooting my existing DSL connection with the Cisco DSL Router as a PPPoE client http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_exampl

e09186a008071a7c2.shtml

Troubleshooting my existing DSL connection with the PC as a PPPoE client http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_exampl

e09186a008071a7f1.shtml

PPPoE Baseline Architecture for the Cisco 6400 UAC

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_white_paper09186a008

0093e55.shtml

Thanks, Mak

Community Member

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

Hi,

i dont know whether this is the right forum.however i can seem to get a solution for this problem that i have.

I have calls coming in through voip on a cisco AS5400. Once the calls come in, the should be routed to a CTI server. now this works but i need to equaly distribute the calls on the dial-peer to the voice ports.

the dial peers have been configured as follows

dial-peer voice 100 pots

destination-pattern 00400

direct-inward-dial

port 3/0:D

forward-digits all

!

dial-peer voice 101 pots

destination-pattern 00400

direct-inward-dial

port 3/1:D

forward-digits all

as you can see, the calls are being routed to the first voice port and will only be sent to the second voice port only if the limit is reached.

i need to have the calls balance between the two voice ports. how do i do this.

i tried setting a hunt on the dial-peers as

dial-peer hunt 4 which describes as follows

<0-7> Dial-peer hunting choices, listed in hunting order within each choice:

0 - Longest match in phone number, explicit preference, random selection.

1 - Longest match in phone number, explicit preference, least recent use.

2 - Explicit preference, longest match in phone number, random selection.

3 - Explicit preference, longest match in phone number, least recent use.

4 - Least recent use, longest match in phone number, explicit preference.

5 - Least recent use, explicit preference, longest match in phone number.

6 - Random selection.

7 - Least recent use.

i appreciate any insight given thanks

Cisco Employee

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

Please post this question on the Unified Communications and Video Forum of NetPro.

Community Member

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

Hi Makarand,

before I start with my main question, could you please confirm the following statement: AS5xxx is the only Cisco box able to terminate data calls (analog or digital) and voice calls (and fax calls) on the same PRI link.

Now, as far as I know c28xx is using same DSPs as AS5350/AS5400. So, here is my main question: is there any technical reason, not marketing or sales, why c2800 running as voice gateway (i.e., with MFT card and enough DSPs) is not able to terminate data calls (analog/ISDN) too? Again, I'm talking about one PRI line as customer is not willing to pay separate PRI for voice traffic and additional PRI to terminate data traffic (analog modem calls or GSM data calls or ISDN calls)?

Regards,

Tenaro

Cisco Employee

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

Technically they are the same C5510 DSPs on 2800s and 5xxx platforms. So yes, there is a marketing reason to keep them separate.

The newer PVDM will support modem calls on the 28/38xx platform.

http://www.cisco.com/en/US/docs/ios/12_4t/12_4t11/htpvdm2.html

Thanks, Mak

Community Member

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

Hi,

I've three questions:

1) With PPPoE in AAL5MUX implemented by IOS the overhead introduced by AAL5MUX is only AAL5 header (8byte) or it's another 2 byte for PAD? And It's possible to use IP routed in AAL5MUX with IOS (I think with only 8 byte of overhead AAL5)?

2) I've seen the possibility to use the tag PPP-Max-Payload with PPPoE for increment MTU ( > 1492) but I've not see a CPE IOS witch support it, Is it possible?

3) Using PPPoFR instead of IPoFR, in CPE-BRAS scenario, it's transparently for FR and ATM node (not menage)?

Exemple:

IPoFR:

CPE

interface Serial 0/0/1.0

ip address 10.1.1.1 255.255.255.252

encapsulation frame-relay

frame-relay interface-dlci 221

BRAS

interface ATM1/0/1.100 point-to-point

ip address 10.1.1.2 255.255.255.252

pvc 253/101

encapsulation aal5snap

PPPoFR

CPE

interface Serial 0/0/1.0

no ip address

encapsulation frame-relay

frame-relay interface-dlci 221 ppp Virtual-Template1

interface Virtual-Template 1

ip adddress negotiated

ppp ...

BRAS

interface ATM1/0/1.100 point-to-point

pvc 253/101

protocol ppp Virtual-Template1

encapsulation aal5snap

interface Virtual-Template1

ip unnumbered Ethernet0/0

peer default ip address pool default

Regards

Alex

Cisco Employee

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

Sorry, DSL is not my field of expertise.

Community Member

Re: ASK THE EXPERT - CISCO ACCESS SERVERS FOR ISDN/MODEMS/PPP CO

Hi,

I'm currently setting up Multilink PPP for our customers.

The Multilink bundle authenticates successfully at our radius server and goes up. The problem is that the BRAS doesn't obey the Framed-IP-Address, Framed-IP-Netmask and the Framed-Route Attribute.

I don't now why this happens, it's working on regular virtual templates...

When debugging RADIUS i see that the attributes are of course passed to the BRAS.

aaa authorization network is enabled (as it works on a non-multilink virtual template).

Im using a Cisco 10008 PRE2 with IOS version 12.2(31)SB11. Perhaps its somehow related to bug CSCsm82181 ?

167
Views
18
Helpful
21
Replies
CreatePlease to create content