Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHONY NETWORKS

Welcome to the Cisco Networking Professionals Ask the Expert conversation. This is an opportunity to get an update from Cisco experts Kashif Zeeshan and Faisal Chaudhry on how to configure and troubleshoot IP telephony networks. Kashif is a customer support engineer in High Touch Technical Support (HTTS) within the Customer Advocacy organization. In his current role, he is responsible for supporting, deploying and troubleshooting Cisco's Softswitch based Voice over IP Service.

Faisal is a customer support engineer in Cisco's High Touch Technical Support (HTTS) Voice group within the Customer Advocacy organization. He is responsible for supporting & troubleshooting Cisco SP Voice & Enterprise Voice customers.

Remember to use the rating system to let Kashif and Faisal know if you have received an adequate response.

They might not be able to answer each question due to the volume expected during this event. Our moderators will post many of the unanswered questions in other discussion forums shortly after the event. This event lasts through September 8, 2006. Visit this forum often to view responses to your questions and the questions of other community members.

137 REPLIES

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

I would raise a very "hot" question regarding IP telephony implementation in the so called "hostile environment".

I am talking about implementations where the IP connectivity carrier (ISP) prohibits the use of Voice over IP and they do their best to block such type of traffic.

Other VoIP vendors of gateways and softswitches (Quintum, MERA MVTS, GnuGK and other) allow the incoming and outgoing call signalling port to be changed (with something other than 1720 for H323) along with the RTP port range.

How we proceed if we have Cisco? Tunelling (IP-IP, GRE and similar) sometimes are a not preferred choice.

As far as I know, Cisco voice gateways (and the IP-IP gateway) do not offer the ability to change the RTP port range or the call signalling port (incoming / outgoing).

Cisco Employee

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Yes, you are correct in this assumption. Even though our softswitch BTS10200 does allow you to modify the signaling ports but it is not a recommended practice.

Telcos in the US and other countries are reluctant to have their bandwidth encroached on by traffic from which they earn no revenue, and have been challenged over similar alleged incidents of VoIP blocking. Blocking VoIP traffic is technically difficult, but not illegal, and blocking specific types of internet traffic is on the increase.

Most Telcom Operators do have the ability to block proprietary protocols like Skype which is encrypted and spreads from peer to peer, using a random combination of IP addresses and ports. There are still ways to open an encrypted tunnel out of the network and set up VoIP calls but voice quality is comprimised.

I believe most of these Telco's will offer Unified Communication Solutions to their cooperate clients in the future since VOIP customers numbers are on a rise.

Cisco Employee

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Further to what Kashif stated: RTP port number used for a session is negotiated as per initial call signaling (e.g. within H.323 or SIP signaling messages). At the present, RTP Port numbers (16384 to 32767) are hardcoded within the source code in IOS gateways and can not be changed.

Though H.323/H.225 signaling port number can be change on outbound call setup by mentioning the desired signaling port number in the session-target command e.g. "session target ipv4::".

For inbound H.225 calls the listen port can be change by a new command "h225 listen-port " under "voice service voip" & "h323".

Rgds,

Faisal.

New Member

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

I have a question about my lab setup, I have a 3560 switched attached to a 2811 router trunked off of port fa0/1 on the switch to fa0/0 on the router, I have a cisco 7940 phone attached to fa0/2, and I have dhcp pool setup on the router. The problem is my phone is not recieving an IP address from the router, the router show to have leased one address to the switch but the switch is not taking giving the address to the phone, I have IP routing enabled on the switch and I have seperate voice and data vlans setup, with the phone showing in its correct vlan, the vlans are also pingable from the router and the router is pingable from the switch, please help me figure this one out, thanks.

Cisco Employee

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Hi,

Can you paste me your 2811 & 3560 configs and debug dhcp detailed from the router.

Thanks

New Member

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Router Config:

Current configuration : 3338 bytes

!

!

hostname DNT_RTR1

!

boot-start-marker

boot-end-marker

!

logging buffered 4096 debugging

!

no aaa new-model

!

resource policy

!

clock timezone GMT -5

clock summer-time GMT-5 recurring

ip subnet-zero

no ip routing

!

!

no ip cef

no ip dhcp use vrf connected

!

ip dhcp pool voice

network 192.168.101.0 255.255.255.0

default-router 192.168.101.99

option 150 ip 192.168.101.99

!

!

ip dhcp-server 192.168.1.1

!

voice-card 0

no dspfarm

!

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 192.168.101.99 255.255.255.0

ip helper-address 192.168.1.1

no ip route-cache

no snmp trap link-status

!

interface FastEthernet0/0.12

encapsulation dot1Q 12

ip address 10.60.101.99 255.255.255.0

no ip route-cache

no snmp trap link-status

!

interface FastEthernet0/1

ip address 10.40.13.29 255.255.255.0

no ip route-cache

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

no ip route-cache

shutdown

!

ip classless

!

ip http server

no ip http secure-server

!

!

!

tftp-server flash:music-on-hold.au

tftp-server flash:P0030702T023.bin

tftp-server flash:P00307020200.sbn

tftp-server flash:P00307020200.loads

tftp-server flash:P00307020200.bin

tftp-server flash:P00307020200.sb2

tftp-server flash:P00503010100.bin

!

control-plane

!

!

!

!

!

!

!

dial-peer voice 10 voip

description CUE VM, AA, TvT

destination-pattern 3...

session protocol sipv2

session target ipv4:192.168.101.99

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 1 pots

destination-pattern 9T

prefix 9

!

dial-peer voice 2 pots

destination-pattern 9T

prefix 9

!

dial-peer voice 3 pots

!

!

telephony-service

load 7960-7940 P0030702T023

max-ephones 10

max-dn 10

ip source-address 192.168.101.99 port 2000

auto assign 3 to 6 type 7960

create cnf-files version-stamp Jan 01 2002 00:00:00

max-conferences 8 gain -6

moh music-on-hold.au

web admin system name admin password cisco

dn-webedit

time-webedit

transfer-system full-consult

!

!

ephone-template 1

softkeys idle Redial Newcall Cfwdall Pickup

softkeys seized Redial Endcall Cfwdall Pickup

softkeys alerting Callback Endcall

softkeys connected Hold Confrn Trnsfer Park

!

!

ephone-dn 1 dual-line

number 201

huntstop channel

no huntstop

!

!

ephone-dn 3 dual-line

number 203

preference 2

huntstop channel

no huntstop

!

!

!

!

line con 0

line aux 0

line vty 0 4

login local

!

scheduler allocate 20000 1000

!

end

DNT_RTR1#

Switch Config:

config t

hostname Denton

ip routing

vlan 12

vlan 10

!

!

no aaa new-model

ip subnet-zero

ip routing

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface FastEthernet0/1

description connection to Dent-Rtr

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/2

switchport access vlan 12

switchport mode access

switchport voice vlan 10

spanning-tree portfast

!

interface FastEthernet0/3

switchport access vlan 12

switchport mode access

switchport voice vlan 10

spanning-tree portfast

!

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

!

interface Vlan10

ip address 192.168.101.3 255.255.255.0

!

interface Vlan12

ip address 10.60.101.51 255.255.255.0

!

ip default-gateway 10.60.101.99

router eigrp 1

network 192.168.101.0

network 10.60.101.0

!

ip classless

ip http server

end

New Member

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Check you vlan databse in your switc h to make sure all the VLANs are in the database. Thats the main problem with phones not getting IP address.

Jay

New Member

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Your configurations need to be seen in order to verify what is happening (or not happening).

Given the information you provided, where you state that you enabled IP routing on the switch...do you have a 'helper address' configured on the switch for the voice vlan, to forward the dhcp request to the dhcp server, and the dhcp response is returned to the voice vlan?

Just a thought,

Ron

New Member

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Yes I have IP helper on the vlan logical interface that corresponds to my voice vlan, I have posted my config.

Cisco Employee

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Hi,

Just a thought I have a similar setup in the lab, can you make the phone ports as trunk and then try as below.

interface FastEthernet0/11

switchport access vlan 2

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 110

If not please debug dhcp detail and sniffer capture.

Thanks

Kashif

New Member

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

I'm using a 3800 as my voice gateway which connected to ISDN Line (E1) and CCM V.4. My problem is the ISDN line always hang but once I put the command "ccm-manager config server 10.21.100.1 & ccm-manager config" on the VGW. Then the IDSN become up and runing again without doing anything else. And after that I try by removing these commands out and the system can still runing. However, once the problem occur again, I have to put these commands in again. Could you please suggest should I put in these commands permanently and what these 2 commands do?

Cisco Employee

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

First of all, please see if you are not encountering the following issue:

http://www.ciscotaccc.com/kaidara-advisor/voice/showcase?case=K15036482

ccm-manager config

ccm-manager config x.x.x.x (TFTP server IP address)

You do not need ccm-manager config

server once you have configured the gateway and it is working well. In general I do not

recommend using the ccm-manager config server. It is best to do the configuration on the gateway itself. In the old days we had an issue where the gateway would register with the CCM without the ccm-manager config server configuration. Since we have resolved that issue there is no real advantage of using the ccm-manager config server except that it saves you typing of a few lines of configuration.

New Member

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Hi,

I have deployed several 2811 voice gateways with two E1's in the same gateway.

One thing that I've noticed is without the ccm-manager config x.x.x.x statement the second E1 fails to register with CCM 4.x

I have removed the ccm-manager config x.x.x.x statement once both E1 interfaces have registered and then reloaded the router to test, same problem the second E1 fails to register.

New Member

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

CDR Problem: I using CCM V.4 and I would like to add the new route pattaern "08[13-9]xxxxxxx to the same partition with existing route pattern "0[13-9]xxxxxxx. The problem is I can completed calls following both patterns but no CDR record. I tried by 1) Remove the new pattern, leave the existing: Can Call & Have CDR. 2) Remove the existing pattern, leave the new, Can call & Have CDR.

What is the problem & solution?

Cisco Employee

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Can you please verify the following:

1. Full CCM Version 4.x(x)

2. Are you doing any digit manupilation in these route patterns.

3. Are you using any 3rd party CDR Analyser or the plugin in CCM.

I have verified this setup in my lab and it works for me with the following route-pattern having similar partitions:

0[2-3]xxx

08[2-3]xxx

CDR will only be recorded after digit manupilation has been performed. You can verify it on the CCM or on Voice Gateway ( Translation Rules).

Can you provide CCM Traces if you are performing any digit manupilation.

Thanks

Kashif

New Member

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

I have a Call Manager 5.04, which is Linux based. I want to install the IP Communicator Admin program on it. Following all the instructions I can find on Cisco's site and the web, I am told to run the admin program from the Call Manager.

I cannot find a way to do with with Call Manager 5.04.

How am I supposed to install the Admin program so it will automatically create the needed directories for me?

Cisco Employee

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Hi,

As you have noticed, the existing Communicator Admin tool only works for Windows based CCM and will not presently work with Linux based CCM 5.x. Hence, when IPC 2.x is used with CCM 5.x, it will not provide features such as ability for admin to configure & create XML files to access CCM Application Dialing rules and Directory search.

A Linux based Admin Tool was one of the feature which was on the roadmap (being considered) to be provided in future release of IPC.

Rgds,

Faisal.

New Member

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Thank you.

The obvious next question is:

How do I use the IP Communicator with Call Manager 5.04? I need a procedure to allow me to use it.

Is there another product that I can use if unable to use this one?

Cisco Employee

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Hi,

With CCM 5.0(x), you can use IPC 2.0.1a without the Admin tool features.

Rgds,

Faisal.

New Member

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

How do I set it up? When I follow the procedure from Cisco, it says I need to setup the Admin tool first. Do I just ignore that entire portion and start after it?

Cisco Employee

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Correct you can bypass the Admin tool part in IPC documentation. Of course you'll loose that functionality as well.

In CCM 5.x, you will add IPC (Product Type: "Cisco IP Communicator") with Device Protocol of "SCCP" - as per CCM documentation:

http://www.cisco.com/univercd/cc/td/doc/product/voice/c_callmg/5_0/sys_ad/5_0_4/ccmcfg/b06phone.htm

Also, in CCM 5.x you don't have to use the MAC address for Device Name for IPC.

Rgds,

Faisal.

New Member

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

I am trying to find out information on the keys that are listed within the key below. Can someone please help me to figure out the meaning of these keys?

HKEY_USERS\S-1-5-21-4218648668-1394088310-3627603145-1151\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\Unity System Profiles

Cisco Employee

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Guess that you're looking at a Unity Server registry. Unity Sys profile is a MAPI profile and the keys are generated when a MAPI profile is created. Microsoft has an article on their mapi profile settings:

http://support.microsoft.com/default.aspx?scid=kb;EN-US;256976

New Member

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Hi Kashif and Faisal,

Thanks for having this session, I'm sure this would help everybody a great deal.

I have a CallManager 4.1(3) being used locally and it is being used by Remote countries A and B. We have also Inter Cluster Trunk with Country C.

Is there any way to monitor calls out to the PSTN in the CCM?

-Is telneting to the Voice gateway the only way?

-Using the Real Time Monitoring Tool shows the total calls being made for ISDN PRI only.

Is there any way to monitor when how much bandwidth is being used for each region/location?

Is there any way to monitor when AAR kicks in?

Maybe you would suggest using Traces, would these take up more CPU utilization?

Thanks a lot!

Eugene

Cisco Employee

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Hi Eugene,

By using RTMT and 'PerfMon' (Start -> Programs -> Administrative tools -> Performance) we can monitor variety of call counters including:

- Intercluter trunks calls by using Performance Object = 'Cisco H323',

- CallsActive, CallsAttempted, CallsInProgress etc by using Performance Object = 'Cisco CallManager',

- BandwidthAvailable, CallsInProgress etc by using Performance Object = 'Cisco Locations'

... etc

There does not appear to be a direct variable/counter to monitor AAR, but with above PerfMon counter for 'Cisco Locations', you can see when BW_Available or Out_Of_Resources kicked to get an indication for # of times AAR was invoked.

You may already be aware of few Management products such as Cisco Unified Operation Manager (CCM 4.2 & 5.x)

http://www.cisco.com/en/US/products/ps6535/index.html

Rgds,

Faisal.

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

hello expert...

I have one 2621 with two fastethernet port one is connected with internet with golobal ip address and other is connected with the nonmanagable switch for local host to communicate with internet and new 2FXS card... i have only one global ip address and i want to use the same ip address for the phone as well as for the local LAN user to communicate with internet. I have three dedicated prot to communicate with FXS card... now i want to forward the voip traffic to the same port to the FXS card...

Is it possible to configure such thing useing Port forwarding or PAT? if yes then how can i configure it? where i should configure ip nat inside or ip nat outside?

please help me...

regards

Devang

Cisco Employee

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Hi,

Didn't follow the question completely but it appears that VoIP traffic will originate or terminate on your 2600 which has Internet connectivity as well as Analog (FXS) ports. If VoIP is going only towards internet then there is no need to do PAT or NAT. You can bind the VoIP traffic (signaling & RTP) to a specified interface by using "h323-gateway voip bind addr " under that interface (as shown below):

interface Fastethernet /

ip address 1.1.1.1 255.255.255.0

h323-gateway voip bind addr 1.1.1.1

But if you have some other design in mind and above does not solve your issue then lets us know. For reference additional pointers on NAT/PAT with VoIP:

http://www.ciscotaccc.com/kaidara-advisor/iprout/showcase?case=K62749816

http://www.cisco.com/en/US/partner/products/sw/secursw/ps1018/products_implementation_design_guide09186a00800fd670.html

Initial NAT/PAT support with H.323/SIP on IOS has been added since 12.2T and additional features/functionality has been added since:

http://www.cisco.com/en/US/partner/tech/tk648/tk361/technologies_white_paper09186a00801af2b9.shtml

Rgds,

Faisal.

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

hi Faisal,

i am not able to open the link because of the username and password...

actully i have 2621 router with analog FXS port and two FastEthernet port... one FEport is connected with the ISP internet connection and other is connected with the nonmanagable switch to allow access of the internet to my local LAN... now i have only single Global IP address to make communication with internet and i have to run PHONE and LAN on same global ip address to access the internet... now how can i configure both on single router what are the requirement please help me...

regards

Devang

Cisco Employee

Re: ASK THE EXPERT - CONFIGURING AND TROUBLESHOOTING IP TELEPHON

Hi Devang,

Since you've to route VoIP traffic over internet then it is simply the case of using the 'global IP address' i.e. the internet routable IP address for this (VoIP) traffic. This can be achieved simply by using the "h323-gateway voip bind addr " under the FE port which has this . So 2600 will use this IP address for all Signaling/H.323 & RTP traffic.

Rgds,

Faisal.

902
Views
67
Helpful
137
Replies
CreatePlease to create content