Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNALLING AND...

Welcome to the Cisco Networking Professionals Ask the Expert conversation. This is an opportunity to discuss Configuring and Troubleshooting T1/E1 Signalling and Digital Modems with Cisco expert Tejal Patel. Tejal’s current responsibilities include Technical Assistance Center (TAC) Escalation in which he troubleshoots complex issues, provides training, and authors documentation. His areas of expertise are Telco Signaling, Configuration and Troubleshooting of Access Servers, AAA etc. Feel free to post any questions relating to Configuring and Troubleshooting T1/E1 Signalling and Digital Modems. Remember to use the rating system to let Tejal know if you’ve received an adequate response.

Tejal might not be able to answer each question due to the volume expected during this event. Our moderators will post many of the unanswered questions in other discussion forums shortly after the event. This event lasts through July 18. Visit this forum often to view responses to your questions and the questions of other community members.

37 REPLIES
New Member

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

hello,

glad to be here,thanks very much,my name is Best and come from china,

New Member

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

Hello,

I am using an AS5300 as a terminating Voice Gateway connected to PSTN by 4 E1s running R2 signaling (digital , non compelled).

one of our carriers who is sending traffic to us via a GK , is getting a lot of Normal , unspecified disconnect cause code such as :

F69 : 13931692hs.34640 +-1 +872 pid:1000 Answer

dur 00:00:00 tx:0/0 rx:0/0 1F (normal, unspecified.).

Note That for the same carriers some calls are terminated succesfully.

for other carriers there is no problem ,

the same equipments are being used( for that carrier and Others) which are Cisco Brand AS5300 , and the signaling deployed form that carrier( in trouble) is ETSI PRI.

so it s not a config problem , and i did not find any fix on CCO

any suggestions? , what can be the source of problem ?

Regards,

Jacob.

Cisco Employee

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

Since the duration for the call is 00:00:00 that means the call never established. Many things can go wrong for that including E1-R2 signalling. So its little difficult to troubleshoot such issues on this forum where not all the calls are failing and some are successful. So i would request you to open a tac case on this issue so that we can go over the network topology and other detailed analysis. Thanks..Tejal

New Member

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

I am running a 3640 with e1 and nm-12dm.Running several days,some modem has a mark with"B" .

use "no modem bad",no effect.

reloaded the 3640,it be come back.

why?

Cisco Employee

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

Digital Mica modems marked B (Bad) on 3600 platforms is a known issue. Usually that issue appears on the mica modems which are running old firmware and ios image. After some time of operation, the ios loose track of mica modems so it can't allocate it to imcoming calls. So is the reason ios will mark those modems BAD. Rebooting 3600 will fix the issue for a while but it will come back again later.

To fix this issue, First, make sure to use latest mica portware like 2.7.4.0 or 2.9.4.0 with any 12.2 ios. So let me know which ios you have with mica portware and also the output of command "show diag" from 3600.

New Member

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

thank you for your reply.

the part display of command "show ver":

Cisco Internetwork Operating System Software

IOS (tm) 3600 Software (C3640-IS-M), Version 12.1(5)T9, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2001 by cisco Systems, Inc.

Compiled Sat 23-Jun-01 20:40 by cmong

Image text-base: 0x60008950, data-base: 0x61142000

ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

cisco 3640 (R4700) processor (revision 0x00) with 39936K/25600K bytes of memory.

Processor board ID 18042060

R4700 CPU at 100Mhz, Implementation 33, Rev 1.0

Channelized E1, Version 1.0.

MICA-6DM Firmware: CP ver 2720 - 5/30/2000, SP ver 2720 - 5/30/2000.

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

Primary Rate ISDN software, Version 1.1.

1 Ethernet/IEEE 802.3 interface(s)

31 Serial network interface(s)

28 terminal line(s)

1 Channelized E1/PRI port(s)

DRAM configuration is 64 bits wide with parity disabled.

125K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

so i have nm-12dm, the display is MICA-6DM, ver 2.7.2.0. why 6 not 12.

the ios ver is 12.1(5)T9.

i will upgrade the ios.i will try it.please give me a ios ver number.i think the latest ios is not the good choice.isn't it?

Cisco Employee

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

NM-6DM is a 6 port digital mica module which is a base module for all NM-XXDM where XX can be 06, 12,18,24,30 etc. So its a group of six modems. So if you order NM-12DM, you will get 2xNM-6DM. So don't worry about that.

Now as far as ios goes, i reco. to use 12.2(17a) with IP_PLUS featureset.

That ios should come with bundled 2.9.4.0.

New Member

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

hello

i am working in network industry,but i undertand the knowledge about the traditional network structure a few,can anyone provide me some valuable info of links,and i do not know the PSTN is consisted of what devices?thanks very much,you could also email me at best@lightrend.com

Cisco Employee

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

Telco networks consist many devices like class 4, 5 etc switches etc. You can find some books on that topic of "understanding telco networks" in Barnes & Noble or similar book stores OR on google.com as well.

New Member

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

Hi..

My name is Hrvoje, and I have problem with Access Server 5350 and callback. When I want to do callback from my office or some other place where I have small bussines telephone central (like Erricson or Panasonic), everything works fine, I get callback and it's ok.

But when I try from my home, and I tryed also from some other places where there isn't local telephone central, callback isn't working.

In laptop I get message Waiting for callback..... but nothing happens.

On Access Server I have ISDN PRI E1 link. I can provide you configuration if you want. Thanks...

Cisco Employee

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

We need to see why the callback fails when you dialin from home. Need to see the difference in successful callback Vs failed callback. Is there any difference about the local telehone central and Bus. Telephone central?

Here is the link which has sample config and troubleshooting for async callback between access server and windows PC for your ref.

http://www.cisco.com/warp/public/793/access_dial/async_ppp.html

Also turn on the following debug for a callin from home where callback fails. Make sure to post a debug for one call only

debug isdn q931

debug ppp negotiation

debug ppp authentication

debug callback

debug chat

debug modem

debug aaa authorization

debug spe modem stat

Post it here with running config.

Anonymous
N/A

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

The example given the link contains a typo, "TIMEOUT60". There needs to be a space between "TIMEOUT" and "60". I notified Cisco about this after getting burned by it well over a month ago.

New Member

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

Hi,

I'm wondering if you can help me configure my E1 trunk for voice. I've configured the controller and voice port as I think they should be but when I dial it from and external source I get an unavailable tone. If I take out the port on the Dial-peer voice 1 pots I get a dial tone when I dial it.

Can you help?

Many Thanks

Cisco Employee

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

Sure i can help. I need to see the running config from the gateway and also need to know the number you are dialing from outside or external source. I assume that once the call comes over POTS to gateway, it should trigger the call over IP to other Gateway right? Pl. explain more about what should happen once the call comes in the gateway.

New Member

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

Hi,

Below is the config from the gateway. The number I'm dialing is 279571 and that should go the a hunt group on call manager by the same number. If I take out the command port 0/0:15 from dial-peer voice 1 pots I get a diald tone and if I dial the number again it rings.

Thanks

Version 12.2

service timestamps debug uptime

service timestamps log datetime

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname HO-2651-1

!

logging buffered 100000 debugging

memory-size iomem 20

clock timezone GMT 0

voice-card 0

dspfarm

!

ip subnet-zero

!

!

!

isdn switch-type primary-net5

!

!

voice call carrier capacity active

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

!

!

voice class h323 1

h225 timeout tcp establish 4

!

!

mta receive maximum-recipients 0

!

controller E1 0/0

pri-group timeslots 1-18

description Q931 PRI

!

process-max-time 20

translation-rule 99

Rule 1 ^1.% 01

Rule 2 ^2.% 02

Rule 3 ^3.% 03

Rule 4 ^4.% 04

Rule 5 ^5.% 05

Rule 6 ^6.% 06

Rule 7 ^7.% 07

Rule 8 ^8.% 08

Rule 9 ^9.% 09

!

translation-rule 88

Rule 1 ^1.% 901

Rule 2 ^2.% 902

Rule 3 ^3.% 903

Rule 4 ^4.% 904

Rule 5 ^5.% 905

Rule 6 ^6.% 906

Rule 7 ^7.% 907

Rule 8 ^8.% 908

Rule 9 ^9.% 909

!

translation-rule 1

Rule 1 279571 279571

!

!

!

!

interface FastEthernet0/0

no ip address

speed 100

full-duplex

no cdp enable

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 172.20.1.32 255.255.255.0

!

interface FastEthernet0/0.101

encapsulation dot1Q 101

ip address 172.18.1.10 255.255.255.0 secondary

ip address 172.16.1.32 255.255.255.0

no cdp enable

!

interface Serial0/0:15

no ip address

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

no cdp enable

!

ip default-gateway 172.16.1.10

ip classless

ip http server

!

!

!

call rsvp-sync

!

voice-port 0/0:15

echo-cancel coverage 32

cptone GB

!

!

mgcp profile default

!

!

!

dial-peer cor custom

!

!

!

dial-peer voice 1 pots

destination-pattern 9T

progress_ind alert enable 8

translate-outgoing called 1

direct-inward-dial

port 0/0:15

!

dial-peer voice 100 voip

preference 1

destination-pattern 279571

translate-outgoing called 1

voice-class codec 1

voice-class h323 1

session target ipv4:172.16.1.1

dtmf-relay h245-alphanumeric

ip qos dscp cs5 media

no vad

!

!

call-manager-fallback

ip source-address 172.20.253.1 port 2000

max-ephones 40

max-dn 40

voicemail 7000

time-format 24

date-format dd-mm-yy

!

end

Cisco Employee

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

Config looks good. The reason why you are getting a secondary dial-tone is because the incoming call is matching with pots dial-peer 1 which has direct-inward-dial. If you remove the port 0/0:15 from that pots 1 dial-peer, incoming call will match to default pots dial-peer which dosen't have "direct-inward-dial".

But the call should have worked in first place. So with exhisting config, we need to see the debug for dollowing when the call comes in with 279571.

debug isdn q931

debug voice ccapi inout

Pl. post it here. Thanks...Tejal

New Member

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

Our 2600 router drops packets on wan port when full duplex is invoked, and only way it works is half duplex. I suspect that we need to replace the T1 card. If you have any suggestions or comments, please respond.

New Member

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

here is the whole problem analyzed,

vtp server :4006(96 ports)(2 ports for vlan2)

vtp client 2950 g(24 ports)(5 ports configured under vlan2.)

trunking port :gigabit

Problem :

we can communicate system of vlan2 (2950 G) on vlan2 on 4006 switch.system on vlan 1can communicatye to system on vlan 2 by assigning the gateway as ip address of vlan 1,but vlan2 is unable to communicate to vlan1 even if the gateway is assingned the ip address of vlan 2.

Remarks : Even in 4006 itself the system in vlan2 is not able to communicate to vlan 1.and backdone is LX.(from 4006 to 2950 G).

4006 switch.system (vlan2) can communincate (vlan2) (2950 G)

4006 switch.system(vlan 1) can communincate (vlan2) (2950 G)

(vlan2) (2950 G) cannot communicate 4006 switch.system(vlan 1)

(vlan2)4006 switch.system cannot communicate 4006 switch.system(vlan 1)

EAgerly awaiting ur reply;

Sandeep.s.PAtel

Cisco Employee

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

I am kinda confuse about understanding the issue you are trying to report. But looks to me that you are having some problem with routing in and between vlans. I am not a right person to answer this question so post this question in "Lan switching and routing" section.

New Member

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

first : start route by command:

ip routing

New Member

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

Hello,

I'd like to know what do I need to get the ANI information from modem calls on my access server (AS5400). Basically, what I want is to type "show caller ip" and "show csm modem" and get the calling party number. The calls are received on a E1 interface configured like this:

controller E1 6/0

framing NO-CRC4

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled

cas-custom 1

country telmex

answer-signal group-b 1

!

I've tried to add "ani" at the end of the ds0-group line, but then all the incoming calls get a busy tone. What else do I need on my config (or request to my provider) in order to get what I want?

As far as I know my provider send ANI information because I have other E1 for voice and I receive all the caller-id info on my phone display.

I'm running IOS 12.2(15)T2.

Thanks in Advance

Carlos

Cisco Employee

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

Actually, the modem calls and voice calls are different for E1-R2 as far as the digits passing goes. You need to have ani and dnis option configured if you want access server to receive that information when the call comes in. So pl. add ani and dnis if you want after r2-compelled. We need to see the following debug after that when the modem call comes in.

debug sigsm r2

debug modem

debug spe modem stat

debug ppp nego

Pl. post it here for a call.

New Member

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

Thanks for your response. I put "ani" after r2-compelled but I can't add "dnis". Here´s my config. And the messages I got when I tried to connect a modem call with the debugs you told me.

controller E1 6/0

framing NO-CRC4

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 1

country telmex

category 2

answer-signal group-b 1

!

*Jan 8 03:25:10.121: sigsm:R2: INCOMING IDLE Got START

*Jan 8 03:25:10.121: sigsm:R2: sig_r2_in_initialize

*Jan 8 03:25:10.121: sigsm:R2: sig_r2_send_digit digit 16

*Jan 8 03:25:10.353: sigsm:R2: INCOMING PRE_CALLERID Got Digit: 1

*Jan 8 03:25:10.353: sigsm:R2: sig_r2_send_digit digit 6

*Jan 8 03:25:10.457: sigsm:R2: INCOMING CALLERID Got TONEOFF

*Jan 8 03:25:10.457: sigsm:R2: sig_r2_send_digit digit 16

*Jan 8 03:25:10.593: sigsm:R2: INCOMING CALLERID Got Digit: 2

*Jan 8 03:25:10.593: sigsm:R2: sig_r2_send_digit digit 1

*Jan 8 03:25:10.697: sigsm:R2: INCOMING CALLERID Got TONEOFF

*Jan 8 03:25:10.697: sigsm:R2: sig_r2_send_digit digit 16

*Jan 8 03:25:10.777: sigsm:R2: INCOMING CALLERID Got I12/I15

*Jan 8 03:25:10.777: sigsm:R2: sig_r2_send_digit digit 5

*Jan 8 03:25:10.877: sigsm:R2: INCOMING COLLECT_DNIS Got TONE_OFF

*Jan 8 03:25:10.877: sigsm:R2: sig_r2_send_digit digit 16

#

I get a busy tone after a few seconds. The modem never gets to negotiate a connection.

Any ideas?

Carlos

New Member

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

Hi,

I have AS5300 units 4E1 with 2 mica modem slots. What do I need to convert this unit into a voice unit?

Cisco Employee

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

You need to add Voice Feature Card (VFC card) with carrier module as well.

The VoIP card or VFC card contains multiple digital signal processor (DSP) modules. It uses the Cisco AS5300's Quad or Octal T1/E1 Public Switched Telephone Network (PSTN) interface and local-area network (LAN) or wide-area network (WAN) routing capabilities to provide VoIP packetized voice traffic to or from T1/E1 time-division multiplexing (TDM) traffic.

Model AS53-6VOX supports 48/60 channels, and model AS53-VOXD supports 96/120 channels. That cards needs to be plugged in to a carrier card which is the mode AS53-CC-VOX.

Pl. visit following link for more on that

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_serv/5300/hw_inst/spares/4934vcip.htm

New Member

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

I am trying to find the best use of the AS5300 with Mica Modem cards that I have. Currently, there is not much use of the mica modems themselves that are in the AS5300.

I have just bought 3745 with two NM voice cards for IP to IP transit.. Can I use these NM voice cards in AS 5300 to replace the mica modem cards and will these do the function of VFC?

Secondly, in the 3745, IP to IP uses only the ethernet part. Can we use for IP to IP the ethernet routing part of AS5300 sidestepping the mica modems in any case? If yes, What IOS will be required?

Cisco Employee

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

You can not use the voice cards from 3745 for AS5300. They are not compitible that way. So you need to buy a different voice cards for AS5300.

Pl. clarify more on IP to IP transit. You mean to say IP-IP gateway feature for voice traffic? IP-IP gateway feature provides a mechanism to enable H.323 Voice over IP (VoIP) calls from one IP network to another ip network. If so, you need 12.2(13)T3

OR 12.3(1) and above image. No need of DSP's. Pl. visit following url for mroe

http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123cgcr/vvfax_c/callc_c/h323_c/ipipgw/

New Member

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

Thanks for the reply. It clarifies a lot.

New Member

Re: ASK THE EXPERT- CONFIGURING AND TROUBLESHOOTING T1/E1 SIGNAL

Hi,

I have AS5300 units 4E1 with 2 mica modem slots. What do I need to convert this unit into a voice unit?

167
Views
17
Helpful
37
Replies
CreatePlease to create content