Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS MANAGER

Welcome to the Cisco Networking Professionals Ask the Expert conversation. This is an opportunity to discuss with Cisco expert June Zheng about deployment and monitoring of QoS using the Cisco QoS policy manager (QPM). June is a technical marketing engineer supporting CiscoWorks QPM. She has been with Cisco Systems Inc. for 6 years and worked with routing and switching, wireless, security, and network management technologies. June is a CCIE certified in Routing and Switching #14119.

Remember to use the rating system to let June know if you have received an adequate response.

June might not be able to answer each question due to the volume expected during this event. Our moderators will post many of the unanswered questions in other discussion forums shortly after the event. This event lasts through July 14, 2006. Visit this forum often to view responses to your questions and the questions of other community members.

35 REPLIES
New Member

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hello,

Assuming I can put my questions here;

Where (environment/sites) is the product QPM most applied? And how far is this product overall integraded, for instance CiscoWorks?

Thanks,

-Aryan

Bronze

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi Aryan,

Thanks for starting the session!

QoS Policy Manager is a centralized management tool for network-wide end-to-end QoS policy creation, deployment and impact analysis.

The targeted customers for QPM are enterprise networks. QPM is usually applied to HQ and regional offices, geographically dispersed, voice/video/data over LAN and/or WAN.

QPM runs on the CiscoWorks Common Services and works with CiscoWorks RME to enable import of device inventory. It is also integrated with ACS to control privileges for policy view, modification and deployment for different device groups.

Thanks,

June

New Member

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi Juzhang,

My name is pankaj, could you please advise that i m facing lot of SMTP traffic on the router, which actualluy chocks the WAN traffic. Please advise how i can find the exect reson why the smtp chocking and what kind of action i should take.

What are your suggestion if facing slow response.

Thanks & Brgds

Pankaj

Bronze

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi Pankaj,

Is QoS enabled over your WAN? What are the traffic classes and QoS policies deployed?

In an enterprise network infrastructure, bandwidth is the prime resource and also is the scarcest (and, likewise, most expensive) over the WAN. Therefore, the case for efficient bandwidth optimization using QoS technologies is strongest over the WAN.

For example, e-mail download (SMTP, POP3, IMAP, Exchange), Database syncs, network-based backups and Microsoft Outlook can be classifyied as a separate Bulk data class. The Bulk Data class is intended for TCP applications that are relatively noninteractive and not drop sensitive, and that typically span their operations over a long period of time as background occurrences. Because TCP continually increases its window sizes, which is especially noticeable in long sessions (such as large file transfers), constraining Bulk Data to its own class alleviates other data classes from being dominated by such large file transfers.

When addressing the QoS needs of Bulk Data traffic, the following guidelines are recommended:

Bulk Data traffic should be marked to DSCP AF11 at the edge; excess Bulk Data traffic can be marked down by a policer to AF12 or AF13.

Bulk Data traffic should have a moderate bandwidth guarantee but should be constrained from dominating a link.

For a typical 8 class WAN edge model, Bulk Data gets min 4% BW guarantee and random-detect dscp-based enabled.

I would recommend you take a look at the below pointer for the WAN QoS design.

http://www.cisco.com/application/pdf/en/us/guest/netsol/ns432/c649/ccmigration_09186a008049b062.pdf

Thanks,

June

New Member

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Thanks Juhanng..

New Member

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi Juhang,

What should be the check list when troubleshooting CoS, we have d1/d2/d3 pattern 60/30/10.

how to check traffic flowing from which class.

Brgds

Pankaj

Thanks in advance for your great advise.

Bronze

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi Pankaj,

One command might be useful is show mls qos interface queueing .

Here is a example of show mls qos interface queueing Verification for a Catalyst 3550 Switch

CAT3550#show mls qos interface GigabitEthernet0/1 queueing

GigabitEthernet0/1

Egress expedite queue: ena ! Q4 is enabled as a PQ

wrr bandwidth weights:

qid-weights

1 ? 5 ! Q1 is allocated 5%

2 ? 25 ! Q2 is allocated 25%

3 ? 70 ! Q3 is allocated 70&

4 - 1 when expedite queue is disabled

Dscp-threshold map:

d1 : d2 0 1 2 3 4 5 6 7 8 9

----------------------------------------

0 : 01 01 01 01 01 01 01 01 01 01

1 : 02 01 01 01 01 01 01 01 01 01 ! DSCP 10 is mapped to WRED T2

2 : 01 01 01 01 01 01 01 01 01 01

3 : 01 01 01 01 01 01 01 01 01 01

4 : 01 01 01 01 01 01 01 01 02 01 ! DSCP 48 is mapped to WRED T2

5 : 01 01 01 01 01 01 02 01 01 01 ! DSCP 56 is mapped to WRED T2

6 : 01 01 01 01

Cos-queue map:

cos-qid

0 ? 2 ! Best-Effort is assigned to Q2

1 ? 1 ! Scavenger and Bulk are assigned to Q1

2 ? 3 ! Transactional Data and Network Management are assigned to Q3

3 ? 3 ! Mission-Critical Data and Call-Signaling are assigned to Q3

4 ? 3 ! Interactive- and Streaming-Video are assigned to Q3

5 ? 4 ! Voice is assigned to the priority queue: Q4

6 ? 3 ! Internetwork Control (Routing) is assigned to Q3

7 ? 3 ! Network Control (Spanning Tree) is assigned to Q3

CAT3550#

Another useful command is show mls qos maps. It displays different mappings such as CoS-to-DSCP map,DSCP-to-CoS map, CoS input queue threshold map and CoS output queue threshold map.

Thanks,

June

New Member

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hello June

Here on the customer network we have the two types of QoS running CBWFQ and LLQ and the customer needs a product that could measure and provide some reports of the QoS status of the network and I've foud the QPM on the Cisco web site and as I read on the papers the product could be integraded with the Cisco Works but the Cisco Works of the custumer runs on the solaris platform and I didn't foud any information if the QPM is avaliable to solaris platform.

Regards

Demetrio

Bronze

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hello Dernetrio,

QPM will satify your needs by providing real time and historical reports of the QoS status of CBWFQ and LLQ.

Currently QPM doesn't support Solaris. But Solaris support is already in our plan. We also recommend customer to run QPM on a dedicated server. QPM SW package contains CiscoWorks Common Services installation files.

Thanks,

June

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Zheng,

I'm in a position where we are creating Maintenance and Operations acceptance criteria to handoff the operations of a VOIP implementation to a LEC for a very large enterprise consisting of up to 20,000 IP phones when were finished. I was trying to find out how well QPM works for an environment that also uses CSM (Cisco Secuirity Manager) on parts of the network where voice will be traversing.

Patrick

New Member

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi June,

We'd like to know which protocol uses most bandwidth before configuring qos on our router.

We don't have qpm.Is there a way to do so ?

Bronze

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi,

This is certainly achieved by QPM since QPM can baseline the traffic by application and by Diff Serv class to help you determine the QoS policy.

If you don't have QPM, you can utilize the auto discovery qos IOS command to collect data and analyze the traffic at the egress direction of the interface.

In untrust mode, the Auto-Discovery feature uses NBAR to detect network applications as they arrive at an interface, collect data from the offered traffic, and perform statistical analysis.

In trust mode, the Auto-Discovery feature uses DSCP values in the IP header to classify packets and collects the statistics to calculate bandwidth and the average rate/peak rate and passes that data to the template module.

Please see the below link for more details.

http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a00802b7721.html#wp1052784

Thanks,

June

New Member

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Thank you very much June

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi,

Hari, i am ram here from bangalore. yar how do i post my question on this discussion forum. I have set of question for june. Bur i am unable to do so plz guide me. My question are related to Telnetting. I am unable to telnet into my router. Even though i have set line vty 0 password.

Bronze

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi,

Your message is posted succesfully. You are welcomed to direct any QPM related questions to me.

Thanks,

June

Bronze

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi Patrick,

Not sure I interprete your question correctly.

You have indicated that your woice trafic will be traversing parts of the network that is managed by CSM. My interpretation for your question is you want to find out how well QPM works to depoloy QoS technologies over IPSec VPNs environment (site-to-site VPNs and telecommuter VPNs) instead of private WAN environment to provide the required service levels to voice and video applications.

Is that what you were looking for?

Thanks,

June

Bronze

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi Patrick,

Not sure I interprete your question correctly.

You have indicated that your woice trafic will be traversing parts of the network that is managed by CSM. My interpretation for your question is you want to find out how well QPM works to depoloy QoS technologies over IPSec VPNs environment (site-to-site VPNs and telecommuter VPNs) instead of private WAN environment to provide the required service levels to voice and video applications.

Is that what you were looking for?

Thanks,

June

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

June,

Everything my client runs is internal to there network. Do to the size of this entity each department is a client and inside those departments they have employed it staff and there own secuirty measures running across the corporate backbone. On some of the sites we have FWSM and other secuirty technology running to keep seperation between what ever. Across some of these secured zones IPT will also be transported. I'm not familar with QPM but am interested in using it to help support QOS across this enterprise and to ensure its the same. So my real questions comes down to if I'm using a security tool like Cisco Security Manager that can push out security policys, Will I have problems using QPM in these Zones. Weill CSM and QPM conflict with each others policys.

Patrick

Bronze

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi Patrick,

There is little overlap between the 2 product. I wouldn't expect any policys conflicts. Just make sure the snmp polling and telnet from QPM server to managed devices aren't get blocked.

Thanks,

June

New Member

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi June,

Hope you can help.

We have a gig backbone linking 3750's to a 6509. We have deployed ip phones at various locations using mitel handsets. we are trying to work out the best qos config to apply. The phones have dscp set to 46.

I have disabled DSCP rewritting, which as i understand should allow the dscp packet through without changing it.

I have enabled mls qos trust dscp on all the pnone attached interfaces.

On the wan link i have enabled priority queue out and srr queueing.

Do I have to have a policy and class map? or change the map statements?

Do I need to apply anything on the input side of the 6509? or can i config this on just the WAN output interfaces?

3750 config - ver 12.2(25)

interface GigabitEthernet1/0/1

description Link to 6509

no switchport

ip address 10.x.x.x

srr-queue bandwidth shape 50 0 0 0

priority-queue out

mls qos trust dscp

interface FastEthernet4/0/14

description User-VOIP-Lan

switchport access vlan 201

switchport mode access

switchport voice vlan 700

duplex full

speed 100

mls qos trust device cisco-phone

mls qos trust dscp

spanning-tree portfast

interface Vlan700

description VOIP-Lan

ip address 10.x.x

ip helper-address 10.x.x

Many Thanks in advance.

Bronze

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hello,

1.You current configuration does not classify data traffic. If you want to further classfy your data traffic and offer access-edge policers, you will need to attach you inbound policy at fa4/0/14 .

Here is one example policy:

policy-map IPPHONE+PC-ADVANCED

class VVLAN-VOICE

set ip dscp 46 ! DSCP EF (Voice)

police 128000 8000 exceed-action drop

! Only one voice call is permitted per switchport VVLAN

class VVLAN-CALL-SIGNALING

set ip dscp 24 ! DSCP CS3 (Call-Signaling)

police 32000 8000 exceed-action policed-dscp-transmit

! Out-of-profile Call-Signaling is marked down to Scavenger (CS1)

class VVLAN-ANY

set ip dscp 0

police 32000 8000 exceed-action policed-dscp-transmit

! Unauthorized VVLAN traffic is marked down to Scavenger (CS1)

class DVLAN-PC-VIDEO

set ip dscp 34 ! DSCP AF41 (Interactive-Video)

police 496000 8000 exceed-action policed-dscp-transmit

! Only one IP/VC stream will be permitted per switchport

class DVLAN-MISSION-CRITICAL-DATA

set ip dscp 25 ! Interim Mission-Critical Data

police 5000000 8000 exceed-action policed-dscp-transmit

! Out-of-profile Mission-Critical Data is marked down to Scavenger (CS1)

class DVLAN-TRANSACTIONAL-DATA

set ip dscp 18 ! DSCP AF21 (Transactional Data)

police 5000000 8000 exceed-action policed-dscp-transmit

! Out-of-profile Transactional Data is marked down to Scavenger (CS1)

class DVLAN-BULK-DATA

set ip dscp 10 ! DSCP AF11 (Bulk Data)

police 5000000 8000 exceed-action policed-dscp-transmit

! Out-of-profile Bulk Data is marked down to Scavenger (CS1)

class DVLAN-ANY

set ip dscp 0

police 5000000 8000 exceed-action policed-dscp-transmit

! Out-of-profile data traffic is marked down to Scavenger (CS1)

!

2. You might want to apply priority queue out and srr queueing at fa4/0/14 to prioritize the voice traffic from Access switch to phone.

3. You might want to config queueing at 6509 GigabitEtherne downlink to Access-Layer Cat3750 to prioritize the voice traffice from 6509 to Cat3750. This could be a per line card task since different cat6k line card support different queueing.

HTH!

June

Silver

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi June,

Are the lastest IOS and CatOS versions supported by the current QPM?

A customer has decided to upgrade all machines to the most recent versions available to implement Rapid STP.

After that I'm supposed to implement QOS. I'm worried that commands QPM will try to give are not supported anymore by the IOS or syntax may have changed.

Can you confirm this is not the case? Or maybe there a hardware version matrix I haven't come across yet. If so please point me to it.

Cheers,

Michel

Bronze

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi Michel,

Below is the pointer for supported device and software release for QPM 3.2.3.

http://www.cisco.com/en/US/customer/products/sw/cscowork/ps2064/products_device_support_table09186a00805078fe.html

Hope it helps and let me know if you have any questions,

Thanks,

June

Silver

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Exactly what I was looking for!

Thanks

Michel

Silver

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hello June,

How are you ?

Could you advise will the QPM able to measure the QoS between two end points with Cisco devices but the core is not Cisco ? i.e. edge / access switches are Catalyst 3560G and connecting to core switches with other brand w/o turn on any QoS (just pass the traffic) to remote, then this core will connect to another 3560G.

Or we have to use Cisco devices all the way ?

Many Thx.

Jack

Bronze

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi Jack,

No. You don't have to use Cisco devices all the way.

QPM analyzes QoS poloicies performance using CAR and Class Based QoS mibs and the monitoring data can be collected on a real-time or on a periodic basis.

Both historical and real-time QoS monitoring reports display the graphs of the following types of QoS monitoring data for the monitored devices:

The amount of traffic that matched the policy's filters (before QoS)

The amount of matching traffic that was dropped by QoS

The amount of matching traffic that was transmitted (after QoS)

A breakdown of the traffic that matched each of the policy's filters. This information allows you to see how traffic within each class is distributed among its match statements.

So as long as your Cisco devices support Class Based QoS mibs, you can run the monitoring task on that device. In terms of end-to-end monitoring, you might want to run the monistor tasks on multiple devices accross the network to get an end-to-end picture.

Thanks,

June

Silver

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi June,

Thanks for your reply. Refer to your answer, is that mean we have to configure and enable the CB QoS in Cisco devices, will it utilize the Cisco device resource when work w/ QPM ? e.g. CPU process ?

Thx.

Jack

Bronze

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi Jack,

Yes. You have to configure and enable the CB QoS in Cisco devices, either manually or using QPM. QPM will not consume Cisco device resource as it is a separate server application. All the interactions between QPM and network devices are through either telnet or snmp polling.

HTH,

June

Silver

Re: ASK THE EXPERT-DEPLOYING/MONITORING QoS USING THE CISCO QoS

Hi June, thanks a lot for your quick response. I have no more question. Jack

182
Views
34
Helpful
35
Replies
CreatePlease login to create content