Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

ASK THE EXPERT- IP ROUTING PROTOCOLS

Welcome to the Cisco Networking Professionals Ask the Expert conversation. This is an opportunity to discuss IP Routing Protocols with Cisco expert Vivek Baveja. Vivek is a CCIE in routing and switching and has over 8 years of networking experience. He has been with Cisco since 2000 and holds the position of subject matter expert in IP Routing Protocols. Feel free to post any questions relating to IP Routing Protocols.

Vivek might not be able to answer each question due to the volume expected during this event. Our moderators will post many of the unanswered questions in other discussion forums shortly after the event. This event lasts through September 13. Visit this forum often to view responses to your questions and the questions of other community members.

73 REPLIES
New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hi Vivek

I need to configure a 3 ethernet interface router to connect to the LAN and 2 ISP's. The 2 ISP connections are for resilience. I have built a config for this but having problems with NAT entries not being dropped when a connection is unavilable and therefore still trying to go down the connection that is unavailable. The two ISP interfaces will connect to two seperate ISP routers. My config is as follows: (I only have serial interfaces on my test kit)

interface Ethernet0

ip address 192.168.0.253 255.255.255.0

no ip directed-broadcast

no ip proxy-arp

ip nat inside

no ip route-cache

no ip mroute-cache

!

interface Serial0

ip address 10.1.0.1 255.255.0.0

no ip directed-broadcast

ip nat outside

no ip route-cache

no ip mroute-cache

clockrate 2000000

!

interface Serial1

ip address 10.2.0.1 255.255.0.0

no ip directed-broadcast

ip nat outside

no ip route-cache

no ip mroute-cache

clockrate 2000000

!

!

ip nat pool ISP1 10.1.1.1 10.1.1.255 netmask 255.255.255.0

ip nat pool ISP2 10.2.1.1 10.2.1.255 netmask 255.255.255.0

ip nat inside source static tcp 10.2.0.1 23 interface Serial1 23

ip nat inside source static tcp 10.1.0.1 23 interface Serial0 23

ip nat inside source route-map ISP1 pool ISP1

ip nat inside source route-map ISP2 pool ISP2

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.0.2

ip route 0.0.0.0 0.0.0.0 10.2.0.2

!

access-list 1 permit any

route-map ISP2 permit 10

match ip address 1

match interface Serial1

!

route-map ISP1 permit 10

match ip address 1

match interface Serial0

!

When I ping 1.1.1.1 from a host on the LAN, a loopback entry on my remote router, the entry is translated and I get a reply. If I shutdown interface s0 the ping gets a timeout and it continues to do this until I "clear ip naat trans *" at which point the ping rplies resume.

Is there a solution to this or maybe a better way of doing it?

Thanks in advance.

Nick

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hello Nick.

Yes there is a better way of of simulating a Mutihomed network with Network Address Translation. There is a very good white paper “Enabling Enterprise Multihoming

with Cisco IOS Network Address Translation (NAT)” available at http://www.cisco.com/warp/customer/cc/pd/iosw/ioft/ionetn/tech/emios_wp.htm

Regarding your configuration It looks okay and should work since the NAT translation entries should time- out typically in 60 secs for ICMP, ( To check the time left for NAT translation entry time out. Use “sh ip nat translations icmp verbose” )

If the translation entries are not timing out. I would suggest you to open a case with Cisco to help troubleshoot the problem.

Regards

Vivek Baveja

CCIE 8218

Looking for solutions. Go to http://www.cisco.com/tac/

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hi

Thanks for the reply.

I have seen the whitepaper you have mentioned before but it wasn't really applicable as we are not doing any BGP peering with this ISP's as this setup will mainly be used for small and medium sized businesses.

The problem I have with the timeouts is because the ping is continuous the timer is being reset. Just wondered if there was anyway round this or if it worked better in the latest IOS (currently using 12.0.7) Is there someway of tying NAT pools to interfaces so if the interface goes down the NAT pool/translations also go down?

Thanks again.

Nick

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hello Nick

I do not think there is any way you can tie an interface with NAT pools. However the way NAT works, Once the packet is Nat’ed. It is routed based on Routing Information Base(RIB). And if the interface goes down, the ip route tied to that interface will be withdrawn from routing table and hence no more nat will happen across that interface.

Since we are using in this example route-map to decide to create nat entry. It always creates a fully extended entry . This translation will contain the inside local, inside global addresses, port nos etc. With the failover of one link. The Nat translation should immediately switch over to other ISP. I personally think the problem you are facing is not because of nat but something else which needs to be investigated.

One thing I wanted to point is, You said you had three Ethernet interface router, however the configuration shows one Ethernet and two Serials. Am I missing something. If by any chance we have the outside interfaces are multi-access interfaces and if the Ethernet interfaces state remains up even after the failure of one isp. The nat would still presume that interface is up and would continue to nat on that interface.

If you continue to have this issue. I would encourage you to open a case with Cisco and let an engineer login to your router and help you troubleshoot it.

Regards,

Vivek Baveja

CCIE 8218

SME IP Routing Protocols

Looking for solutions. Go to http://www.cisco.com/tac/

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hello Vivek

I am having an issue with the routing protocols over VPN. our VPN tunnel is managed by a 3rd party and the routers on each side (well all sides) are mine.

Site 1

Cisco 2600 IP 10.0.0.1

VPN firewall IP 10.0.0.20

Site 2

Cisco 2600 IP 10.95.0.1

VPN firewall IP 10.95.0.20

currently I have static routs setup

Site 1

ip route 10.95.0.0 255.255.248.0 10.0.0.20

Site 2

ip route 10.0.0.0 255.0.0.0 10.95.0.20

*site 1 is a centeral hub that all sites point to

I have tried eigrp, igrp, rip with no success, what am I missing?

Thank you

Brent Ritchie

Network Manager

TDS Automotive

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hello Brent

Since you did not mention MPLS VPN, So I am assuming you are talking about IPSec VPN. Normal IP Security (IPSec) configurations cannot transfer routing protocols such as Enhanced Interior Gateway Routing Protocol (EIGRP) and Open Shortest Path First (OSPF) Here is a good doc that will help you configure and troubleshoot the issue at hand. Look at http://www.cisco.com/warp/public/707/ipsec_gre.shtml

Hope this helps.

Regards

Vivek Baveja

CCIE 8218

SME IP Routing Protocols.

Looking for solutions. Go to http://www.cisco.com/tac/

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

I am in the process of a migration to an OSPF from a primarily IGRP Frame Relay WAN. There are two "central sites" in this particular network: The "North" side of the company has a Frame Relay WAN running IGRP, the secondary data center and an internet firewall. The "South" side has a point-to-point WAN running primarily OSPF, company headquarters, the primary data center and an internet firewall. Also, there are 7 large campuses in a partial mesh, and about 25 smaller locations that just have PVCs to the two data centers.

The company is two merged companies who have been together for three years, with the "North" sites smaller but more numerous, and the "South" sites are fewer in number, yet larger. The company recently committed to deploying a replacement Frame Relay WAN, which will encompass all the existing FR links, as well as links that have been T1/FT1 links up to this point. While this FR network is being deployed, we will move the customer from being primarily IGRP to being almost exclusively OSPF. In addition, the seven major sites will have backup T1 links to the South headquarters site.

One of the challenges is that the South sites need to use the internet firewall at the South data center, while the North sites need to use the internet firewall at the North data center. I also need to be able to switch the default routes for both halves of the WAN to point to either firewall in case of an internet failure at either of these central sites.

The key to this challenge is that the "south" and "north" designations are really a political designation. As far as the network goes, there is no good way to differentiate a north site from a south site. As we stand today, there is a distinct line between the north and south sides of the network, which made it easy to send the locations to their "native" firewall.

Some colleagues have suggested using BGP throughout the WAN. That is not feasible as we are too committed to OSPF at this point. Others suggested using BGP at both data center firewall locations to inject two default routes, but I beleive I end up with the same problem (how to point some sites to one firewall and other sites to the other firewall).

It seems that the only solution that is flying is to choose a firewall, inject a default route into OSPF for it, and override it at the locations that should go to the other firewall by adding a static 0.0.0.0 route at that site's WAN router. Another idea would be to not inject a default route at all and use static default routes at the head end of each campus's network.

My main goal is to make sure that I design a scalable and resilient network for the customer, which will stand the test of time. I'd sure like to have a more elegant solution than this idea of overlaying static routes. I can't seem to put my hands on it.

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hello Jim

A scalable and resilient way to achieve this in OSPF network is to manipulate “ospf cost” of default routes.

Here is how to do this: Generate default routes in north site of ospf network and south site of OSPF network pointing to there respective firewall gateways. Manipulate the OSPF cost (using “ip ospf cost” subinterface command ) of the default route at the border router of north site connecting to south site such that the ospf cost of default route learned from south site is higher than the ospf cost of default route generated in north site. This way “show ip ospf database external 0.0.0.0” will have two default entries. One generated in North site and the other learned from south site with higher cost because of cost manipulation on border routers. The default route learned from south site will act as backup route in case of failure of default route from north site. Similarly south site will have two routes, one generated in south site with better cost over other learned from north site thus providing redundancy.

Jim, This solution should help you achieve what you wish, a network which will stand the test of time

Hope this helps

Regards,

Vivek Baveja

CCIE 8218

SME IP Routing Protocols

Looking for solutions. Go to http://www.cisco.com/tac/

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hi Vivek,

My core sytem is spread over 2 sites with 2 OC3 linking 4 5509's.

I'm running OSPF in my core network.

I am moving towards a secured solution that requires that all access to my core system are filtered through a firewall.

My problem is that I am going to loose the dynamic aspect of the network because of the firewalls.

I know that GRE tunnel would let OSPF updates go through the firewall but I'm not fully satisfied with this.

Do you know if there are any other solutions for DYNAMIC ROUTING AND FIREWALLS ?

Thank you

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hello Fabrice,

PIX or any other Cisco firewall doesn't allow broadcast and multicast traffic to pass through it. Therefore, we can't use an Interior Gateway Protocol (IGP) such as Open Shortest Path First (OSPF), Enhanced Interior Gateway Routing Protocol (EIGRP), or Routing Information Protocol (RIP), all of which use broadcast and multicast packets to exchange routing information. To work around this limitation, you can encapsulate the multicast packets in a GRE tunnel to pass them through the PIX.

You could also use BGP through firewall to maintain dynamic routing protocols across your network. Establish BGP peering across Firewall and redistribute ospf into bgp and vice versa. Configure firewall to allow TCP port 179 as BGP uses it to communicate among peers. To Allow BGP traffic across pix use the following

access-list acl-1 permit tcp host x.x.x.x host y.y.y.y eq bgp and apply this on outside interface of firewall.

Where x.x.x.x and y.y.y.y are bgp peering addresses.

Hope this helps

Regards,

Vivek Baveja

CCIE 8218

SME IP Routing Protocols

Looking for solutions. Go to http://www.cisco.com/tac/

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hi Vivek,

Thank you for your answer.

Are there any type of Firewall devices that run DYNAMIC ROUTING or should I go for a router with the IOS FW feature ?

Thank you

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hello Fabrice,

PIX firewall learns routes from RIP but does not broadcast it. Cisco PIX software Version 6.3 which will be out soon, would allow OSPF dynamic routing protocols to be run.

Regards

Vivek Baveja

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hello Vivek. My organization is planning to deploy campus IP routing end to end, all the way to the Edge Switches, using Catalyst 3550 EMI series switches. Is it possible for us to activate dispersed VLANS using VTP across active IP routing interfaces?

If so, can we still maintain layer 3 instant failover(perhaps using HSRP) without the conventional Spanning Tree Protocol Fail-Over.

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hello Shahrunizan,

Yes you can configure VTP across your network for multiple vlans and can run dynamic routing protocols across (including HSRP) to achieve redundancy. Running spanning tree will only help you achieve a loop free layer 2 topology.

Hope this helps

Regards,

Vivek Baveja

CCIE 8218

SME IP Routing Protocols

Looking for solutions. Go to http://www.cisco.com/tac/

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

hi vivek,

i wanted to know about setting up of router id on ospf,once the router deteremines the router id can we change it .Also how important is the router ID in the OSPF process.Can we give an ip of the other connected router as a router id.

waiting for reply,

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hello Bilal,

Yes you can change the router id even after the ospf process automatically chooses the highest ip address as router id. You can configure a specific router id by using the command router-id x.x.x.x. The new router-id is used at the next reload or at a manual OSPF process restart. To manually restart the OSPF process, use the clear ip ospf command.

Router-id is the way ospf identifies the ospf neighbors and source of LSA updates. It should be unique in your ospf network.

Regards

Vivek Baveja

CCIE 8218

SME IP Routing Protocols

Looking for solutions. Go to http://www.cisco.com/tac/

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hi Vivek,

I want to configure a router to do port address translation. I have a virus scanner appliance on my inside network that I want to scan http traffic. So I don't have to configure all my desk tops to use proxy, I want my router to redirect all http traffic to port 8080 to the ip address of the virus scanner.

Thanks,

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hi Stan

Typically a Port address translation configuration would look like this

ip nat inside source static tcp 172.16.10.8 8080 172.16.10.8 80

Where any packet received on the outside interface with a destination address of 172.16.10.8:80 will have the destination translated to 172.16.10.8:8080.

For more information on PAT, Refer to http://www.cisco.com/warp/public/556/12.html#4

Regards,

Vivek Baveja

CCIE 8218

SME IP Routing Protocols

Looking for solutions. Go to http://www.cisco.com/tac/

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Vivek, Two questions for you:

First, OSPF configuration recommendations often say that you should configure a loopback interface, primarily for the OSPF router ID. However, within OSPF config there is also the ROUTER-ID command. Does the use of either a loopback or the ROUTER-ID command negate the use of the other? Is there any advantage of configuring my routers with loopbacks versus setting the router ID with the ROUTER-ID command, or vice-versa? Perhaps there are other reasons for having an interface always UP, as a loopback is?

Secondly, I have Frame Relay point-to-point PVC links with IP Addressed masked to 30-bits. If I have an IP Address of 10.10.10.249 with a mask of 255.255.255.252, which way is better (or just more proper):

NETWORK 10.10.10.249 0.0.0.3 AREA 0

-or-

NETWORK 10.10.10.0 0.0.0.255 AREA 0

In this case, all of the WAN links are in the 10.10.10.0 range, and all are in OSPF Area 0. Both seem to work fine, but it seems that there may be a reason to use one over the other. I have chosen to use the 0.0.0.255 method, but am curious to know which one is "more correct", and if there are any implications to either one.

Thanks in advance for the reply!

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hello Jim,

Let me answer your question one by one

First one:

Router ID (RID) is the highest IP address on the box or the loopback interface, calculated at boot time or whenever the OSPF process is restarted. So if you do not have any loopback address configured on router. OSPF process will choose the highest ip address of any physical interface in the box as the router-id. However if there is a loopback interface configured. Then ospf will choose the loopback ip address as the router id irrespective of the ip addresses configured on physical interfaces.

The router-id x.x.x.x command lets you configure router-id of your choice and would take precedence over the loopback address and highest ip address on physical interfaces.

The order of precedence for choosing router-id in ospf processs is

1)If router-id configured, OSPF uses it.

2) If router-id not configured, Check if any loopback interface ip addresses are configured. If yes, Choose that as router–id

3)If neither router-id is configured nor loopback interface is configured. Choose the highest ip address configured on physical interfaces.

4)If there are no interfaces in up/up mode with an IP address, then it returns this error message "cannot allocate router id".

As you correctly said, the most important advantage of choosing router-id using loopback address is to overcome the dependency of physical interface which may flap leading to churn in ospf. Most of the times router-id command is used so as to specifically pin down the router id of ospf router for the purpose of network management and ease in troubleshooting.

Second one:

It is fair to use “network 10.10.10.0 0.0.0.255 area 0” If the complete network 10.10.10.0/24 is in ospf area 0. However using more precise network command is a better practice. There may be a situation where say a part of this network either does not want to run ospf or runs in another area. In that case this command would create problem.

Say for example you have 10.10.10.248/30 in area 0 and instead configured 10.10.10.0 0.0.0.255 area 0 under ospf. Later down the line you wish to have additional 10.10.10.252/30 under area 2. You would not be able to configure it since it overlaps with area 0. OSPF does not allow a network to be in two areas. The only way out would be to remove the 10.10.10.0/24 network from ospf resulting bringing down ospf on network 10.10.10.0 and thus leading to a down time which we can ill afford. Then only we can configure

Network 10.10.10.248 0.0.0.3 area 0

Network 10.10.10.252 0.0.0.3 area 2

Hope I make my point clear

Regards

Vivek Baveja

CCIE 8218

SME IP Routing Protocols

Looking for solutions. Go to http://www.cisco.com/tac/

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Vivek,

To follow up on the first question, it seems that the ROUTER-ID command and a loopback interface accomplish the same exact thing in two different ways. Is that correct? Is there any reason to use one over the other?

I guess I'm looking for which one is better, or perhaps more commonly used. Maybe there's other problems to solve or advantages in using loopback interfaces that the ROUTER-ID command doesn't solve for me?

Maybe it is truly just my personal preference whether to use one over the other! Can it be that simple?

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Jim,

Yes you are right in your understanding. Router-ID command and a loopback ip address accomplish the same thing for ospf and its your choice which one you prefer. However it is important to understand that you can use loopback ip address for many other reasons in addition to configuring OSPF router id like (a) Doing BGP peering with loopback address, (b) Using loopback ip address for “IP unnumbered” interfaces, (c) MPLS etc.

I would suggest to use loopback address as way to configure OSPF router-id.

-Regards

Vivek Baveja

Cisco Employee

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

You have to assign a valid ip address on the loopback interface to be choosen as a RID in OSPF but in case of router-id command you do not have to have that address configured on any interface, also it doesn't have to be a valid ip address. For example 0.0.0.255 can be a vlid router-id. So you can choose to have whatever address be assigned as a router ID without assigning it on a physical interface. So this makes router-id command more flexibale than loopback address. :)

Hope it clears the confussion now.

Faraz

Bronze

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hi,

I had a strange problem when I tried to adjust the ospf priority on a vlan interface in my 6509 (sup1a, msfc and pfc on 5.5(7) and 12.0(7)xe1). This vlan has three 36xx routers attached and they have hundreds of frame relay pvcs to remote sites. My network monitor is on another vlan on the 6509 and a server used by the remote locations is on a third vlan. I have OSPF running between the 36xxs and the msfc. Everything worked fine until (for unrelated reasons) I set the ip ospf priority on the msfc’s vlan interfaces where the 36xxs are to 2 instead of the default 1. That change should only have affected how the msfc set cost on routes it received from the 36xxs. But after the change the network monitor could still reach the remotes and the server but for some reason the remotes could not see the server, or the server could not reach the remotes. I’m not sure which but they couldn’t communicate. The only thing I can think of is something in the CEF environment broke. When OSPF changes are made like this does something need to be cleared to refresh the CEF information?

Thanks

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hello Richard

The command “ip ospf priority ” is used for selection of Designated Router (DR) and Backup Designated router(BDR). Higher value takes precedence in choosing a DR/BDR.

To manipulate cost of ospf routes you should use “ip ospf cost ” sub interface command. For more information refer to http://www.cisco.com/warp/customer/104/2.html#2.1

It is difficult to say without looking into configurations as to what really happened and if it broke in CEF path when you changed ip ospf priority. I would think of asking someone to look into configuration and old logs to figure out the cause of that network churn.

Hope this helps

Regards,

Vivek Baveja

CCIE 8218

SME IP Routing Protocols

Looking for solutions. Go to http://www.cisco.com/tac/

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hello Vivek,

I'm working on a bgp scenario in preparation for my CCIE lab that I have been unable to solve. I have 3 routers in AS 100. I do not have a full mesh but have the middle router functioning as a route reflector. There is a 4th router in AS 200 that has a EBGP peer sesssion with one of the edge routers in AS 100. I'm running ospf as the IGP and have synchronization turned on. The EBGP router is passing routes to AS 100 with the edge router in AS 100 redistributing these routes into ospf. On the route reflector the routes are synchronized but when I check a router reflector client the routes are not synchronized. It is my understanding that the router id's between ospf and bgp neighbor of the route must match when synchronization is turned on but the RR causes a problem by inserting its own ID overriding the orginal bgp peer's id where the route originated. This causes the mismatch between the ospf and bgp router id's because the ospf route will still have the router id of the router that originated the type 5 lsa which is not the RR. Everything works fine when I have a full mesh within AS 100. When I utiilize a route reflector the routes do not synchronize on routers that recieve the routes from the route reflector. The only solution that I have been able to come up with that allowed me to leave synchronization on was to remove the route reflectors and use confederations. I was wondering if you had any solutions to this scenario that would allow me to keep the both the route reflectors and synchronization turned on with ospf as the igp.

any assistance is appreciated,

Greg

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hello Greg,

Your understanding is correct. Because of mismatch between OSPF Router ID and BGP Router ID the BGP routes are not synchronized. A quote from BGP Path selection Criteria

”Paths marked as "not synchronized" in the show ip bgp output. If BGP synchronization is enabled, which it is by default in Cisco IOS® Software, there must be a match for the prefix in the IP routing table in order for an internal (iBGP) path to be considered a valid path. If the matching route is learned from an OSPF neighbor, its OSPF router ID must match the BGP router ID of the iBGP neighbor. Most users prefer to disable synchronization using the no synchronization BGP subcommand”.

Reference http://www.cisco.com/warp/customer/459/25.shtml

Typically in a real world scenario, Synchronization is disabled so this problem does not precipitate. However considering a situation when synchronization is enabled, routes are distributed in OSPF and we also somehow ensure that iBGP learned routes are synchronized, Those iBGP learned routes would still not make it to the routing table as the admin distance of iBGP routes is 200 which is less than OSPF admin distance of 110, unless we change the admin distance of iBGP learned routes to be less than 110.

I summary I would say, Your understanding of the issue at hand is absolutely perfect and

The only way this can be achieved if somehow the RR redistributes the BGP routes into OSPF. This would ensure that OSPF Router ID and BGP router ID are consistent.

Wishing you good luck for your CCIE.

Regards,

Vivek Baveja

CCIE 8218

SME IP Routing Protocols

Looking for solutions. Go to http://www.cisco.com/tac/

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hello Vivek

Hello Greg,

Given your scenario, do you think it is possible to "reconcile" OSPF and BGP router id's as follows:

- first, change BGP router-id on the router from AS100 that has the external peering (let's call it router A)

- second, change BGP router-id on the RR to match router A's OSPF id

This way, we accomplish the following:

- all BGP and all OSPF router-id's are unique

- the other RR client (let's call it B) will know a type 5 LSA originated by A and a BGP valid route; the routes on B will get synced.

Now this will create an asymetric behavior: routes coming from an external peering of B will not get synced on A. Not good.

Given the fact that you can run multiple OSPF processes on the same box (each one with different router-id's) a symmetrical solution could be redistributing OSPF into OSPF on RR.

Regards,

Marius Popa

New Member

Re: ASK THE EXPERT- IP ROUTING PROTOCOLS

Hello Marius

I would not advocate manipulating router-id this way. Doing a reality check most of the production networks do not use synchronization and so would not face this situation. For CCIE purposes, redistributing at RR would be a better way to achieve the goal.

-Regards

Vivek Baveja

238
Views
10
Helpful
73
Replies
CreatePlease to create content