Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

ASK THE EXPERT - MPLS TRAFFIC ENGINEERING

Welcome to the Cisco Networking Professionals Ask the Expert conversation. This is an opportunity to get an update from Cisco expert Aamer Akhter about MPLS traffic engineering and how it can be used for providing recovery of link or node failures as well as for optimizing routing of traffic given constraints by backbone capacity and topology. Aamer is currently leading a team for testing Layer 3 VPNs and related technologies in a cross-Cisco effort. He is a CCIE (# 4543). He is also the vice-chair of the Certification Work Group of the MFA Forum

Remember to use the rating system to let Aamer know if you have received an adequate response.

Aamer might not be able to answer each question due to the volume expected during this event. Our moderators will post many of the unanswered questions in other discussion forums shortly after the event. This event lasts through August 11, 2006. Visit this forum often to view responses to your questions and the questions of other community members.

  • Expert Corner
32 REPLIES
Bronze

Re: ASK THE EXPERT - MPLS TRAFFIC ENGINEERING

ON our CE routers from HQ(T3) to multiple remotes(T1), AT&T has GSR as their PE with a fully-meshed MPLS VPN that is QoS provision on L2 to:

40% Voip Real Time (RT) for Cos 1

On the 60% for data, it is 80/10/10 = cos 2/3/4

Cos 2 through 4 is for data

COS2 Burst High B(H%)=48

COS3 Burst Low (BL)%=6

COS4 Best Effort (BE)%=6

Base on the SRND:

http://www.cisco.com/application/pdf/en/us/guest/netsol/ns432/c649/ccmigration_09186a008049b062.pdf

I am not familiary with MPLS but want to setup Voip Qos for our callmanager. I am looking at the srnd example of using:

class-map match-all ROUTING

match ip dscp cs6

class-map match-all VOICE

match ip dscp ef

class-map match-all MISSION-CRITICAL-DATA

match ip dscp 25

class-map match-any CALL-SIGNALING

match ip dscp af31

match ip dscp cs3

class-map match-all TRANSACTIONAL-DATA

match ip dscp af21

class-map match-all NETWORK-MANAGEMENT

match ip dscp cs2

class-map match-all SCAVENGER

match ip dscp cs1

!

policy-map CE-THREE-CLASS-SP-MODEL

class ROUTING

bandwidth percent 3

class VOICE

priority percent 18

class CALL-SIGNALING

priority percent 2

set ip dscp cs5

class MISSION-CRITICAL-DATA

bandwidth percent 20

random-detect

set ip dscp af31

class TRANSACTIONAL-DATA

bandwidth percent 15

random-detect

set ip dscp cs3

class NETWORK-MANAGEMENT

bandwidth percent 2

set ip dscp cs3

class SCAVENGER

bandwidth percent 1

class class-default

bandwidth percent 24

random-detect

interface serial 1/0

service-policy output CE-THREE-CLASS-SP-MODEL

but not sure if this is correct?

Also, what additional info do I need to grab from ATT or ask?

TIA

Re: ASK THE EXPERT - MPLS TRAFFIC ENGINEERING

Hello Aamer,

refering to a previous discussion about VRF traffic down a specific MPLS TE tunnel:

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Service%20Providers&topic=MPLS&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1dda007d

I understood that a static route will not do it, if the tunnel is not terminating on both PE routers. Still, as written in my last post there, would it be possible, if the IOS code is rewritten? Or in other terms, what is the argument against it?

Regards, Martin

Cisco Employee

Re: ASK THE EXPERT - MPLS TRAFFIC ENGINEERING

Hi Martin,

I might have misunderstood the other discussion- so please feel free to correct me.

You've got a TE tunnel's headend at a PE and the tail on a P router. You'd like to put VPN traffic from the PE into the tunnel.

Yes, this can be done and one way to do this is via a directing the VPN traffic into the tunnel via a static route to the iBGP next-hop of the VPN prefix.

You will need to run LDP on the tunnel. If you do not have a bi-directional tunnel from P->PE, you'll need to have the 'mpls ldp discovery targeted-hello accept'

Re: ASK THE EXPERT - MPLS TRAFFIC ENGINEERING

Hi Aamer,

this approach would insert all VPN traffic into the tunnel unless you use "bgp next-hop" under "ip vrf blah" and create a separate loopback interface/IP address per VRF.

My question was to insert only specific VRF traffic into a specific tunnel through a static vrf route. As Harold Ritter pointed out, this will not work right now, because CEF does not resolve the BGP next hop through the tunnel. But all needed labels are known by the PE (through MBGP, targeted LDP and RSVP), it is just not implemented.

Call it a feature request or rather an idea to discuss.

My argument: a static vrf route would be more handy than the current way of doing it (separate loopback/IP and "bgp next-hop" and possibly a route-map to set bgp next hop per prefix).

Suggested command:

ip route vrf

This command is there, but does not work, when the tunnel is PE to P.

Hope to be understandable.

Regards, Martin

Cisco Employee

Re: ASK THE EXPERT - MPLS TRAFFIC ENGINEERING

Martin,

The scope of the direction of traffic into the tunnel can be per PE, per VRF or per prefix in the VRF. It seems like you are interested in the per prefix in the VRF case.

The per-prefix-in-VRF can be done by using a route-map on the egress PE to change the next-hop to another next-hop (generally another loopback on same egress PE). On the ingress PE you would have to create a static route to direct the traffic to that new next-hop into the tunnel.

For the way you are mentioning I was able to get the CEF entry to look proper, but the forwarding does not appear to work, so definitely more investigation is needed. I?m talking to some people and hopefully we can figure out what is going on. Note that I changed the way you had originally created that static route and added the ?global? keyword. This was tried on 12.0(32)S:

ip route 10.1.1.201 255.255.255.255 Tunnel1

ip route vrf v1 10.1.1.200 255.255.255.255 10.1.1.201 global

(12.0S)

R206PE#show ip cef vrf v1 10.1.1.200

10.1.1.200/32, version 20, epoch 0, cached adjacency to Tunnel1

0 packets, 0 bytes

tag information set, all rewrites owned

local tag: 66

fast tag rewrite with Tu1, point2point, tags imposed {64 33 65}

via 10.1.1.201, 0 dependencies, recursive

next hop 10.1.1.201, Tunnel1 via 10.1.1.201/32 (Default)

valid cached adjacency

tag rewrite with Tu1, point2point, tags imposed {64 33 65}

Note that:

64 is TE label

33 is LDP label to the nexthop from the TE-tail P router

65 is the BGP vpnv4 label from the egress PE

Regards,

Aamer Akhter

Cisco Employee

Re: ASK THE EXPERT - MPLS TRAFFIC ENGINEERING

Martin,

The above should work. I had forgotten to redistribute the static route to the OSPF session between the PE and CE.

In the case of 12.2S, you want to modify the static route such that:

ip route 10.1.1.201 255.255.255.255 Tunnel1 10.1.1.203

ip route vrf v1 10.1.1.200 255.255.255.255 10.1.1.201 global

Where 10.1.1.203 is the loopback on the P router. This is so that the static route will match the address-list advertised by LDP. Apparently in 12.0S this check was not done.

Hope this helps,

Aamer Akhter

Re: ASK THE EXPERT - MPLS TRAFFIC ENGINEERING

Aamer,

so the requirement remains to have a different Loopback IP on the relevant destination PE per VRF/Tunnel, a static route pointing through the tunnel to it and static redistribution of those host routes.

OK, I just thought/suggested, there can be a modification to IOS to avoid those additional Loopback IPs and the static routes through the tunnel towards those IPs plus their redistribution in IGP.

My idea was to avoid all this and modify the static VRF route (maybe with new keyword) to allow the building of the proper label stack without all this - all the labels are known to the PE in any case assuming proper setup.

Anyhow, thanks for your efforts and checking in the lab!

Regards, Martin

Cisco Employee

Re: ASK THE EXPERT - MPLS TRAFFIC ENGINEERING

Hi aamercado,

Be assured that if AT&T is using MPLS-TE in their core, this will not affect the QoS config on their edge.

With regards to the QoS config it doesn't make sense if AT&T is looking at COS (which is layer 2) why the config above is setting DSCP as they are different fields in the frame.

I would suggest finding out exactly what QoS config AT&T is applying to the links facing your CE.

Regards,

Aamer Akhter

New Member

Re: ASK THE EXPERT - MPLS TRAFFIC ENGINEERING

hi i am trying to implement a simple CBWFQ on cisco 3600 and the bandwidth allocation does not work, the 2 sources i use to generate udp traffic towards one source get eaqual share of the bandwidht, the policy maps fail i guess but i think there is nuthin wrong with it ... im pasting the config. below please let me know if somthin is wrong

policy-map utestudp5

class u3p5031

bandwidth 6000

queue-limit 10

class u4p5041

bandwidth 1500

queue-limit 10

class-map match-all u4p5041

match access-group 143

class-map match-all u3p5031

match access-group 133

access-list 143 permit udp host 192.168.4.100 host 192.168.1.100 eq 5041

access-list 143 deny udp any any

access-list 133 permit udp host 192.168.3.100 host 192.168.1.100 eq 5031

access-list 133 deny udp any any

Regards

75
Views
15
Helpful
32
Replies