Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

501 PIX Internet access

We changed over our internet connection to fibre, and started using our 501 pix for pppoe. The problem I am having is that the PPPoE appears to be working, however no computer on the network can access the internet.

From the PIX I can ping 4.2.2.2,

pixfirewall(config)# ping 4.2.2.2

        4.2.2.2 response received -- 30ms

        4.2.2.2 response received -- 20ms

        4.2.2.2 response received -- 20ms

And from the PIX I can ping the computer I am trying to access to the Internet from:

pixfirewall(config)# ping 192.168.16.52

        192.168.16.52 response received -- 0ms

        192.168.16.52 response received -- 0ms

        192.168.16.52 response received -- 0ms

However, from inside the network, I cannot ping the 4.2.2.2 address or get any internet access. Our VPN however, comes up and works fine. I am certain I am missing something very simple, can anyone please spot it in the below?

interface ethernet0 auto

interface ethernet1 auto

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 9jNfZuG3TC5tCVH0 encrypted

hostname pixfirewall

domain-name man4b

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list 101 permit ip 192.168.16.0 255.255.255.0 192.168.0.0 255.255.255.0

access-list NoNAT permit ip 192.168.16.0 255.255.255.0 192.168.0.0 255.255.255.0

pager lines 24

mtu outside 1492

mtu inside 1500

ip address outside pppoe setroute

ip address inside 192.168.16.254 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list NoNAT

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

timeout xlate 0:10:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set chevelle esp-des esp-md5-hmac

crypto map transam 1 ipsec-isakmp

crypto map transam 1 match address 101

crypto map transam 1 set peer 87.194.163.33

crypto map transam 1 set transform-set chevelle

crypto map transam interface outside

isakmp enable outside

isakmp key ******** address 87.194.163.33 netmask 255.255.255.0

isakmp keepalive 10

isakmp nat-traversal 20

isakmp policy 1 authentication pre-share

isakmp policy 1 encryption des

isakmp policy 1 hash md5

isakmp policy 1 group 1

isakmp policy 1 lifetime 86400

telnet timeout 5

ssh 217.155.6.154 255.255.255.255 inside

ssh timeout 5

management-access inside

console timeout 0

vpdn group pppoex request dialout pppoe

vpdn group pppoex localname c987340@hg23.btclick.com

vpdn group pppoex ppp authentication chap

vpdn username c987340@hg23.btclick.com password *********

username cisco password 0s4u2xN1pFqcIn/9 encrypted privilege 15

terminal width 80

The show route looks as below:

pixfirewall(config)# show route

        outside 0.0.0.0 0.0.0.0 217.32.142.2 1 PPPOE static

        inside 192.168.16.0 255.255.255.0 192.168.16.254 1 CONNECT static

        outside 213.123.237.219 255.255.255.255 213.123.237.219 1 CONNECT static

Any help would be gratefully recieved.

Everyone's tags (2)
1 REPLY

501 PIX Internet access

Hi Mark,

The config looks fine. When you changed the internet service have you cleared the 'arp' on PIX ( and any switch in between PIX and ISP) or reload the same? If you still experience issues, two things you can try (One change at a time)..

1. Disable http fixup

2. set outside mtu to 1500

Thx

MS

364
Views
0
Helpful
1
Replies