Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
New Member

515e versions

I have a PIX 515e running version 6.3(4). Is this grossly out of date? Where can I find information on this site for the versions and their release dates? Thanks.

11 REPLIES
jim
New Member

Re: 515e versions

Check this link. Your 515e should be able to support 7.1, though you'll need to check your RAM (min 128mb 256mb unrestricted, failover, and failover active/active)

and 16 Flash min

http://cisco.com/en/US/products/hw/vpndevc/ps2030/products_data_sheet0900aecd8040c5b5.html

This link should show you your download options.

http://www.cisco.com/cgi-bin/tablebuild.pl/pix

Please rate this if I have helped you at all.

New Member

Re: 515e versions

Thank you. From this I gather we should at least be on 7.0, which was release sometime in 2005(?). Better update it to ensure there are no security issues associated with the older version that could be exploited.

Thanks.

Re: 515e versions

Hi,

Please note that the 7.x is a new generation OS that has alot of changes, including the commands, but as well adds alot of new features.

Careful with the update if the machine is in production.

Check the links on: http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/tsd_products_support_series_home.html

Please rate if this helped.

Regards,

Daniel

jim
New Member

Re: 515e versions

Thanks Daniel. Im so use to 7+ now I forget what pain I went through lol.

New Member

Re: 515e versions

Ok, from an auditing standpoint (3rd party audit of my network), is it ok to have version 6.3 or should it be at 7 to ensure all potential security holes are plugged.

New Member

Re: 515e versions

Anyone?

Re: 515e versions

Hi there,

An audit will not tell you what software to use on your firewall.

Morelikely will want to know for example if you receive the security notification from cisco when a vulnerability is detected and if you have a process to assess and fix these.

As well, Cisco is committed to update the 6.x when vulnerabilities are discovered. Simply they will more likely not add additional features, which is ok for someone who don't need additional capabilities.

Please rate if this helped.

Regards,

Daniel

New Member

Re: 515e versions

Thanks. so 6.x is still supported and will be patched as vulnerabilities are discovered. That's all I needed to know. There is no "resolved" issue checkmark now for any of the helpful answers, but together I believe this issue is resolved.

New Member

Re: 515e versions

Can anyone tell me where I can find the page on this site that has the latest update informaiton for 6.x? I have 6.3(4), is that the latest version of 6.x?

Re: 515e versions

Hi,

Here is the PIX page: http://cisco.com/en/US/products/hw/vpndevc/ps2030/tsd_products_support_series_home.html

And here are the security advisories: http://cisco.com/en/US/products/hw/vpndevc/ps2030/prod_security_advisories_list.html

To download the software (Cisco customer account required): http://cisco.com/public/sw-center/ (under VPN Software)

The latest is PIX OS version 6.3(5) software. Requires a minimum of 8 MB Flash and 16 MB RAM.

Please rate if this helped.

Regards,

Daniel

New Member

Re: 515e versions

A typical auditor from an external company will look at known security issues. One source they will read is usually Secunia. A company dedicated to keep track of security and patch related issues for various products and vendors.

http://secunia.com/product/56/

Pix Version 6.x has at this moment no critical issues that would require an immediate update to 7.x

165
Views
23
Helpful
11
Replies
CreatePlease to create content