Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

application access issue to internal users

Hi Every one,

 

We have access issue to application for internal users.

1. We have application url WAN IP 192.168.1.1. which is NAted to 172.16.1.1 on Firewall.

2. Further we have Citrix LB, to load balance the load for application.

3. 172.16.1.1 further binded with 10.10.10.1 and 10.10.10.2 on port 80 and 443 on Load Balancer.

Please find the attached network diagram

NOTE: The application server having images to load on the website.

 

At present we have pointed 192.168.1.1 to www.example.com.

So when we pointed the url www.example.com to WAN ip (192.168.1.1) we have no issue to access the url from inside and outside networks.

Issue comes when we point www.example.com to 172.16.1.1 for internal users.

 

Here I want explain the application functionality.

1. When a user call www.example.com --> it calls 3 urls further to complete the task.

first call is www.example.com/image/logo --> to select the text, font and logo.

second call is www.example.com/image/product --> which gives the product image

third call is to complete the task by combing the both urls

www.example.com/image/product/decall/src=(www.example.com/image/logo)

So here when we point the example.com to NAT IP 172.16.1.1 first two calls are completing and third call is stuck to load image from 1st call i,e www.example.com/image/product/decall/src=(www.example.com/image/logo)

 

44
Views
0
Helpful
0
Replies