Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ASA 5505 ICMP Deny

Hi

I am facing a problem with icmp in ASA 5505, i want to block the icmp from inside to outside , but outside to inside icmp should work, here the configuration.

 

ASA Version 8.0(5)
!
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 172.17.1.1 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
!
ftp mode passive
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group service OPC_Ports tcp
 port-object range 3800 3900
object-group service DM_INLINE_SERVICE_1
 service-object ip
 service-object tcp range 3800 3900
object-group service DM_INLINE_SERVICE_2
 service-object ip
 service-object tcp range 3800 3900
object-group service DM_INLINE_SERVICE_4
 service-object ip
 service-object tcp range 3800 3900
access-list inside_access_out extended permit object-group DM_INLINE_SERVICE_1 host 172.17.1.200 any
access-list inside_access_out extended deny icmp any host 172.17.1.200
access-list inside_access_in extended permit tcp any host 172.17.1.200 range 3800 3900
access-list inside_access_in extended deny icmp host 172.17.1.200 any
access-list inside_access_in extended permit ip any any inactive
access-list outside_access_in extended permit object-group DM_INLINE_SERVICE_2 host 172.17.1.200 any
access-list outside_access_out extended permit object-group DM_INLINE_SERVICE_4 192.168.1.0 255.255.255.0 host 172.17.1.200
access-list outside_access_out extended deny icmp any host 172.17.1.200
pager lines 24
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp deny 192.168.1.0 255.255.255.0 inside
no asdm history enable
arp timeout 14400
global (outside) 1 interface
access-group inside_access_in in interface inside
access-group inside_access_out out interface inside
access-group outside_access_in in interface outside
access-group outside_access_out out interface outside
route outside 0.0.0.0 0.0.0.0 172.17.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:0e7c3f786320372e8e43f7e5f00fb72c
: end

 

with this configuration it worked fine, but after rebooting the device , port 3800-3900 ports are not working, if i enable IP then ICMP and 3800-3900 ports are working,

 

What i need is

inside to outside icmp deny

outside to inside icmp permit

 

thanks in advance

2 REPLIES
Hall of Fame Super Silver

You have no static NAT

You have no static NAT entries - just the global interface dynamic NAT. So all you'd be able to ping from the outside would be the outside interface as the ASA would have no way of knowing what inside host you want to reach via the outside-initiated pings..

It also looks like your been attempting to setup some outside access via the ACLs you have created and applied but they don't appear to be correct given your interface addressing.

If so then you need to have

If so then you need to have the specified settings on the inside and outside interface mapping ACL's....

 

outside to inside ( on outside ) interface mapped acl you can allow the entire icmp....

like

access-list inbound extended permit icmp any any

 

On the inside interface mapped ACL....

 

access-list outbound permit icmp any any echo-reply

access-list outbound permit icmp any any unreachable

access-list outbound permit icmp any any time-exceeded

access-list outbound deny icmp any any

!

Have the above ACL on top of your IP/TCP/UDP ACL's so that it works correctly.....

 

This will allow any kind of icmp requests from outside.... but from inside it allows only the return traffic required icmp messages....

 

Regards

Karthik

 

105
Views
0
Helpful
2
Replies
CreatePlease login to create content