Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

ASA 5505 NAT Issue?

I've been reading the forums for two days and tried many of the solutions and haven't had any luck.

I'm sure I have extra stuff in there now, from trying so many different approaches.

I have an inside network of 192.168.0.0, 255.255.252.0 and an outside network of 10.106.140.0, 255.255.255.192

The router to the internet is 10.106.140.62 and is a sonicwall.  The ASA ip is 10.106.140.23 on the outside and 192.168.0.213 on the inside.

I am able to access the ASDM from both the inside and outside networks, but I can't see across the firewall.

Currently I am looking to have all access open, and then it will have restrictions put on it later.

Any help would be greatly appreciated.

ASDM Version 6.4(5)

ASA Version 8.2(5)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 0
ip address 192.168.0.213 255.255.252.0
!
interface Vlan2
nameif outside
security-level 0
ip address 10.106.140.23 255.255.255.192
!
ftp mode passive
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list inside_access_in extended permit ip any any
access-list inside_access_in extended permit tcp any eq www any eq www
access-list outside_access_in extended permit ip any any
access-list inside_access_in_1 extended permit ip any any
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outside_access_in in interface outside
access-group inside_access_in_1 in interface inside
route outside 0.0.0.0 0.0.0.0 10.106.140.62 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.0.0 255.255.252.0 inside
http 10.160.140.0 255.255.255.192 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.5-192.168.1.254 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:2816e13a745260f8c8544997a414118a
: end

Everyone's tags (7)
1 ACCEPTED SOLUTION

Accepted Solutions
Super Bronze

ASA 5505 NAT Issue?

Hi,

The Sonicwall should have a route which tells where the LAN network that is behind ASA is found. In other words it should know the "next hop" IP address towards that network. And in this case that next hop is the "outside" interface IP address of the ASA.

Naturally I am not sure how the VPN Client connection is configured on the Sonicwall. I would imagine that it can also be configured with Full Tunnel or Split Tunnel VPN.

In a Full Tunnel VPN client connection all connection initiated by the VPN user are forwarded through the VPN Connection.

In a Split Tunnel VPN only the traffic destined to certain networks are forwarded to the VPN connection. Those networks naturally depend on the configurations.

So as you can see, if the VPN Client connection type is Full Tunnel then there is no problem with regards to that but if the VPN Client connection is Split Tunnel then you might need to add the LAN network behind the ASA to the list of networks for which traffic needs to be tunneled.

But I have not configured a Sonicwall so I am not sure how that is done there. But I am not sure if you even have to.

- Jouni

7 REPLIES
Super Bronze

ASA 5505 NAT Issue?

Hi,

Could you change the "inside" interfaces "security-level" to "100" instead of the "0"

Even though this probably doesnt affect your situation anyway I would still suggest it.

Now, we need to make clear what you are attempting to do.

You say you dont have access through the firewall?

Your hosts behind the "inside" interface should already have full access to anywhere behind the "outside" interface. But notice that this naturally doesnt work both ways since you are doing Dynamic PAT for the "inside" hosts.

To be able to initiate connections in both directions you will either have to use NAT0 or have no NAT configurations all with "nat-control" disabled. Naturally in this case the firewall infront of the ASA will have to have routes for the network(s) behind the ASA also or routing will become a problem.

Can you clarify what you need to achieve with this 2 firewall setup and between which networks the traffic is not working and should work.

- Jouni

Community Member

ASA 5505 NAT Issue?

Hi Jouni,

Thanks for the quick response.  I set the security-level back to 100.

If I am connected at port 1-7 I cannot see the internet or the outside network.

If I am connected at port 0 I cannot see the inside network.

I need full access both ways for now, we have a number of companies that will be remoting in through the sonicwall vpn and they will need to be able to access the inside network.  We will also need internet access from the inside network.

Ah, ok, so there needs to be some changes made to the sonic wall for this to work?

I will set no nat-control and see if I can add routes to the sonicwall.

Super Bronze

ASA 5505 NAT Issue?

Hi,

So I assume that this ASA firewall is supposed to acts pretty much as some Internal firewall between some users and some resources?

In that case I would imagine that the easiest setup would be simply to do NO NAT.

You could for example do the following changes

access-list INSIDE-NAT0 remark NO NAT for traffic between INSIDE and OUTSIDE

access-list INSIDE-NAT0 permit ip 192.168.0.0 255.255.252.0 any

nat (inside) 0 access-list INSIDE-NAT0

no global (outside) 1 interface

no nat (inside) 1 0.0.0.0 0.0.0.0

OR

You could remove the current NAT configuration and go without any NAT configuration at all.

In addition to this you will naturally need to have a route configured on the Soniwall for the network 192.168.0.0/22 pointing towards the "outside" interface IP address of the ASA. You will also have to have the correct NAT rules on the Sonicwall to enable the hosts behind ASA to access Internet. And if there are some access rules from LAN to WAN on the Sonicwall then naturally you will have to permit traffic from the LAN behind ASA to the Internet also.

Hope this helps

Please do remember to mark the reply as the correct answer if it answered your question.

Ask more if needed

- Jouni

Community Member

ASA 5505 NAT Issue?

Hi Jouni,

So I am able to get to the Internet from the Inside now, I'm not able to see any devices on the outside network though.

The main thing I need though is for a remote user to login to the VPN at the sonicwall, 10.106.140.62 and reach the inside network on the Cisco.  I would like to do this without messing with the sonicwall too much, it runs some pretty important equipment.  I can see where there would need to be a route set to send traffic from the sonicwall to the Cisco. 

Where should this traffic be sent though?  Should the destination be the outside interface, 10.106.140.23?  And then the cisco takes the traffic from outside to inside?

Thanks

Super Bronze

ASA 5505 NAT Issue?

Hi,

The Sonicwall should have a route which tells where the LAN network that is behind ASA is found. In other words it should know the "next hop" IP address towards that network. And in this case that next hop is the "outside" interface IP address of the ASA.

Naturally I am not sure how the VPN Client connection is configured on the Sonicwall. I would imagine that it can also be configured with Full Tunnel or Split Tunnel VPN.

In a Full Tunnel VPN client connection all connection initiated by the VPN user are forwarded through the VPN Connection.

In a Split Tunnel VPN only the traffic destined to certain networks are forwarded to the VPN connection. Those networks naturally depend on the configurations.

So as you can see, if the VPN Client connection type is Full Tunnel then there is no problem with regards to that but if the VPN Client connection is Split Tunnel then you might need to add the LAN network behind the ASA to the list of networks for which traffic needs to be tunneled.

But I have not configured a Sonicwall so I am not sure how that is done there. But I am not sure if you even have to.

- Jouni

Community Member

ASA 5505 NAT Issue?

Hi Jouni,

Thank you so much for your help.  I was finally able to get it to work with two rules in the sonicwall and a few changes in my configuration.

Super Bronze

ASA 5505 NAT Issue?

Hi,

Glad it worked out

- Jouni

603
Views
0
Helpful
7
Replies
CreatePlease to create content