Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

ASA-5505 NAT to a Range of ports

I have an ASA-5505 running 8.4  I have entered the following ...

 

object service WLG-Rng-1
 service udp source range 10000 11000

Then this ..

nat (inside,outside) source static VOIP-Sys-4 interface service WLG-Rng-1 WLG-Rng-1

The nat command fails with "ERROR: NAT unable to reserve ports."

All other rules, objects, and nat (using single ports) have worked fine.  I have a site-to-site on this ASA.  Here is my config ...

 


:
ASA Version 8.4(4) 
!
hostname ASA-5505
enable password 1234
passwd 5678
names
!
interface Ethernet0/0
 description Connected to provider.
 switchport access vlan 2
 speed 100
 duplex full
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.201.1.1 255.255.255.0 
!
interface Vlan2
 description Pt-to-Pt link to the outside.
 nameif outside
 security-level 0
 ip address 1.2.3.4 255.255.255.252 
!
boot system disk0:/asa844-k8.bin
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 8.8.4.4
 name-server 8.8.8.8
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network NETWORK_OBJ_10.201.1.0_24
 subnet 10.201.1.0 255.255.255.0
object network NETWORK_OBJ_10.201.3.0_24
 subnet 10.201.3.0 255.255.255.0
object network WLG_DataCenter
 subnet 192.168.12.0 255.255.255.0
 description DataCenter
object network VOIP_Provider
 subnet 5.6.7.8 255.255.255.0
 description VOIP Provider
object network VOIP-Sys-1
 host 10.201.1.140
object network VOIP-Sys-2
 host 10.201.1.141
object network VOIP-Sys-3
 host 10.201.1.142
object network VOIP-Sys-4
 host 10.201.1.143
object service WLG-SSH-1
 service tcp source eq 222 
object service WLG-SSH-2
 service tcp source eq 2222 
object service WLG-SIP-5060
 service udp source eq sip 
object service WLG-Rng-1
 service udp source range 10000 11000 
object service WLG-Svc-59002
 service udp source eq 59002 
object service WLG-Svc-59101
 service udp source eq 59101 
object-group protocol DM_INLINE_PROTOCOL_1
 protocol-object icmp
 protocol-object gre
object-group service DM_INLINE_SERVICE_1
 service-object object WLG-SSH-1 
 service-object object WLG-Svc-59002 
object-group service DM_INLINE_SERVICE_2
 service-object object WLG-SIP-5060 
 service-object object WLG-SSH-1 
access-list -VPN_splitTunnelAcl standard permit 10.201.1.0 255.255.255.0 
access-list outside_cryptomap extended permit ip 10.201.1.0 255.255.255.0 object WLG_DataCenter 
access-list outside_access_in extended permit object-group DM_INLINE_SERVICE_1 object ClearFly object VOIP-Sys-1 
access-list outside_access_in extended permit object WLG-Svc-59101 object ClearFly object VOIP-Sys-2 
access-list outside_access_in extended permit object-group DM_INLINE_SERVICE_2 object ClearFly object VOIP-Sys-3 
access-list outside_access_in extended permit object WLG-Rng-1 object ClearFly object VOIP-Sys-4 
access-list outside_access_in extended permit object-group DM_INLINE_PROTOCOL_1 any any 
pager lines 24
logging enable
logging timestamp
logging buffer-size 16384
logging buffered debugging
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool Office_VPN_Pool 10.201.3.100-10.201.3.149 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-711-52.bin
no asdm history enable
arp timeout 14400
nat (inside,outside) source static NETWORK_OBJ_10.201.1.0_24 NETWORK_OBJ_10.201.1.0_24 destination static NETWORK_OBJ_10.201.3.0_24 NETWORK_OBJ_10.201.3.0_24 no-proxy-arp route-lookup
nat (inside,outside) source static NETWORK_OBJ_10.201.1.0_24 NETWORK_OBJ_10.201.1.0_24 destination static WLG_DataCenter WLG_DataCenter no-proxy-arp route-lookup
nat (inside,outside) source static VOIP-Sys-1 interface service WLG-SSH-1 WLG-SSH-1
nat (inside,outside) source static VOIP-Sys-1 interface service WLG-Svc-59002 WLG-Svc-59002
nat (inside,outside) source static VOIP-Sys-2 interface service WLG-Svc-59101 WLG-Svc-59101
nat (inside,outside) source static VOIP-Sys-3 interface service WLG-SSH-2 WLG-SSH-2
nat (inside,outside) source static VOIP-Sys-3 interface service WLG-SIP-5060 WLG-SIP-5060
!
object network obj_any
 nat (inside,outside) dynamic interface
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 1.2.3.4 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL 
http server enable
http 10.201.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS esp-aes esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS esp-aes esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS esp-aes-192 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS esp-aes-192 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS esp-aes-256 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS esp-aes-256 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS esp-3des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS esp-3des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS esp-des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS esp-des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS mode transport
crypto ipsec ikev2 ipsec-proposal DES
 protocol esp encryption des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal 3DES
 protocol esp encryption 3des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES
 protocol esp encryption aes
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES192
 protocol esp encryption aes-192
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES256
 protocol esp encryption aes-256
 protocol esp integrity sha-1 md5
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 match address outside_cryptomap
crypto map outside_map 1 set peer 3.4.5.6
crypto map outside_map 1 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 set ikev2 ipsec-proposal DES 3DES AES AES192 AES256
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ikev2 policy 1
 encryption aes-256
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 10
 encryption aes-192
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 20
 encryption aes
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 30
 encryption 3des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 40
 encryption des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 enable outside
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication crack
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 20
 authentication rsa-sig
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 30
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 40
 authentication crack
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 60
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 70
 authentication crack
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 80
 authentication rsa-sig
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 90
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 100
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 120
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 130
 authentication crack
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 140
 authentication rsa-sig
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 150
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 128.252.19.1 source outside prefer
webvpn
group-policy GroupPolicy_3.4.5.6 internal
group-policy GroupPolicy_3.4.5.6 attributes
 vpn-tunnel-protocol ikev1 ikev2 
group-policy VPN internal
group-policy VPN attributes
 dns-server value 8.8.4.4 8.8.8.8
 vpn-tunnel-protocol ikev1 
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value VPN_splitTunnelAcl
tunnel-group VPN type remote-access
tunnel-group VPN general-attributes
 address-pool Office_VPN_Pool
 default-group-policy VPN
tunnel-group VPN ipsec-attributes
 ikev1 pre-shared-key *****
tunnel-group 3.4.5.6 type ipsec-l2l
tunnel-group 3.4.5.6 general-attributes
 default-group-policy GroupPolicy_3.4.5.6
tunnel-group 3.4.5.6 ipsec-attributes
 ikev1 pre-shared-key *****
 ikev2 remote-authentication pre-shared-key *****
 ikev2 local-authentication pre-shared-key *****
!
class-map SIP
 match port udp eq sip
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map PrioritySIP
 class SIP
  priority
policy-map OutSIP
 class class-default
  shape average 1800000
  service-policy PrioritySIP
policy-map global_policy
 class inspection_default
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect netbios 
  inspect tftp 
  inspect ip-options 
  inspect icmp 
  inspect pptp 
!
service-policy global_policy global
service-policy OutSIP interface outside
prompt hostname context 
no call-home reporting anonymous
Cryptochecksum:[dof8a7sujwq3rfpoiuas=d09u
: end

 

The VOIP provider is requiring these high ports (udp 10000-11000) for their system.

 

 

2 REPLIES
Super Bronze

Hi, For me this has typically

Hi,

 

For me this has typically been caused by a situation where I have had the firewall on for a long time and during that time changed around the NAT configurations quite a bit. (As I use my ASA to test various NAT configurations)

 

So I would suggest a reload of the firewall perhaps.

 

If you don't want to resort to a reload/reboot of the firewall straight away then I would suggest configuring the Static PAT you are attempting to configure but with different range of ports. What I mean is that you could try first forwarding 10500 - 11000 for example and see if that produces an ERROR message too.

 

I don't really know what port the ASA could use from that range by default. If it were TCP/10000 port then it might be related to IPsec over TCP but in your case its only UDP so it should not be the case. It would indeed be helpfull if the actual ERROR message provided more information. I wonder if some NAT related debug would tell more about the problem.

 

- Jouni

Community Member

Journi,Thanks for replying.

Journi,

Thanks for replying.  I have rebooted several times (off hours) and tried to clear xlate.  Right now I am forwarding 10000 to 11000 and that is accepted.  Here are the results of a couple show commands.  Let me know if you want to see something specific.

 

Result of the command: "sh xlate"

8 in use, 8 most used
Flags: D - DNS, i - dynamic, r - portmap, s - static, I - identity, T - twice
       e - extended
NAT from inside:10.201.1.0/24 to outside:10.201.1.0/24
    flags sI idle 9:52:25 timeout 0:00:00
NAT from inside:10.201.1.0/24 to outside:10.201.1.0/24
    flags sI idle 9:51:23 timeout 0:00:00
TCP PAT from inside:10.201.1.140 222-222 to outside:24.106.24.122 222-222
    flags sr idle 9:52:25 timeout 0:00:00
UDP PAT from inside:10.201.1.140 59002-59002 to outside:24.106.24.122 59002-59002
    flags sr idle 9:52:25 timeout 0:00:00
UDP PAT from inside:10.201.1.141 59101-59101 to outside:24.106.24.122 59101-59101
    flags sr idle 9:52:09 timeout 0:00:00
TCP PAT from inside:10.201.1.142 2222-2222 to outside:24.106.24.122 2222-2222
    flags sr idle 9:52:25 timeout 0:00:00
UDP PAT from inside:10.201.1.142 5060-5060 to outside:24.106.24.122 5060-5060
    flags sr idle 9:51:42 timeout 0:00:00
UDP PAT from inside:10.201.1.143 10000-10000 to outside:24.106.24.122 11000-11000
    flags sr idle 9:43:50 timeout 0:00:00

 

Result of the command: "sh nat pool"

UDP PAT pool inside, address 10.201.1.1, range 1-511, allocated 1
UDP PAT pool inside, address 10.201.1.1, range 512-1023, allocated 0
UDP PAT pool inside, address 10.201.1.1, range 1024-65535, allocated 6
TCP PAT pool inside, address 10.201.1.1, range 1-511, allocated 1
TCP PAT pool inside, address 10.201.1.1, range 512-1023, allocated 0
TCP PAT pool inside, address 10.201.1.1, range 1024-65535, allocated 0
TCP PAT pool outside, address 24.106.24.122, range 1-511, allocated 3
TCP PAT pool outside, address 24.106.24.122, range 512-1023, allocated 0
TCP PAT pool outside, address 24.106.24.122, range 1024-65535, allocated 1
UDP PAT pool outside, address 24.106.24.122, range 1-511, allocated 6
UDP PAT pool outside, address 24.106.24.122, range 512-1023, allocated 0
UDP PAT pool outside, address 24.106.24.122, range 1024-65535, allocated 20

 

218
Views
0
Helpful
2
Replies
CreatePlease to create content