Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ASA 5505 Trunking problem with cisco 3760

Here is my asa 5505 configuration  and at bottom i am pasting cisco 3760 configuration, I am having trunking problem and seen other people having the same issue but no solution.

Problem: when i connect any device on Switch 3760 port 1 which is trunked i cannot communicate with niether vlan.

I have tried device with both static vlan configuration

192.168.1.99 (vlan 2)

172.168.1.99 (vlan 8)

if i change port 1 to access mode or define native vlan it work with one vlan.

interface 5 of Cisco ASA is connected with interface 25 (uplink) on  Cisco Switch

!

interface Ethernet0/5

switchport trunk allowed vlan 1-10

switchport mode trunk

!

interface GigabitEthernet1/0/25

  description **UPLINK**

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-10

switchport mode trunk

!

On port 1 of cisco Switch i am creating trunk

!

interface GigabitEthernet1/0/1

description **LAN**

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-10

switchport mode trunk

no logging event link-status

spanning-tree portfast

!

CISCO ASA Config i have configure the following vlans

interface Vlan2

nameif inside

security-level 100

ip address 192.168.1.1 255.255.255.0

interface Vlan8

description Server VLAN

nameif Internal_LAN

security-level 90

ip address 172.168.1.1 255.255.255.0

!

interface Ethernet0/0

switchport access vlan 2

--------------------------------------------

on Cisco 3760 i have configure the following vlan.

v

!

vlan 2

name inside

!

vlan 8

name Internal_LAN

!

interface Null0

no ip unreachables

!

Message was edited by: macboy

  • Firewalling
Everyone's tags (1)
8 REPLIES
Bronze

ASA 5505 Trunking problem with cisco 3760

Hello,

I can see many people have visited the post but there isn't any reply.

I think this is because of the following:

The configurations are long and most people dont want to read it. Try adding only relevant configuration to the issue.

The problem description is not clear. You mention trunking problem but what exactly is the problem? Can you ping from switch to ASA? Is any Vlan information being passed or they are all failing. Try to be as much specific as possible.

Which port of the switch connects to the ASA?

Using portfast on a trunk (interface GigabitEthernet1/0/1) is not recommended.

Regards,

Felipe.

Remember to rate useful posts.

New Member

ASA 5505 Trunking problem with cisco 3760

i have reduce the configuration

Bronze

ASA 5505 Trunking problem with cisco 3760

What device are you connecting to port 1 on the switch?

Seems like that device is either not tagging or not configured as trunk.

Regards,

Felipe.

Remember to rate useful posts.

New Member

ASA 5505 Trunking problem with cisco 3760

I tried connecting windows server and my laptop.

Hall of Fame Super Blue

ASA 5505 Trunking problem with cisco 3760

As Felippe said, is the device connected to the gi0/1 port configured to tag traffic ie. you can't just setup the switch port to be a trunk, the device itself needs to be configured to trunk as well.

Jon

New Member

ASA 5505 Trunking problem with cisco 3760

Yes, is configure to be trunked as well.

Bronze

ASA 5505 Trunking problem with cisco 3760

Servers and laptops I dont think are able to tag traffic, therefore you need to configure the port as access.

A trunk port can only be connected to another trunk port.

Let us know if you have questions.

Regards,

Felipe.

Remember to rate useful posts.

New Member

ASA 5505 Trunking problem with cisco 3760

I found one article which seems  to be my problem. what do thing about this post i am going to give a try to this.

https://learningnetwork.cisco.com/thread/10502

707
Views
0
Helpful
8
Replies