Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ASA 5505 version 9.1(4) NAT issue

Hi,

I am using ASA 5505 version 9.1(4) and using dynamic NAT command to NAT(PAT) inside subnet 192.168.3.0/24 with outside interface 192.168.100.2/24

But unable to ping from inside host to internet or router interface 192.168.100.1 . Please suggest the show running is mentioned below.

Following is the logical diagram

                                      192.168.100.1/24                          192.168.100.2/24                192.168.3.1                          

  Internet(ISP) ------------------->------------------ Router------------------------->(e0/0)  ASA 5505 (9.1) eth0/4 ----- ---------- Host (192.168.3.22)

ASA Version 9.1(4)

!

hostname ciscoasa

enable password 2KFQnbNIdI.2KYOU encrypted

xlate per-session permit tcp any4 any4

xlate per-session permit udp any4 any4

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

ciscoasa(config)# object network Generic_All_Network

ciscoasa(config-network-object)# sub

ciscoasa(config-network-object)# subnet 0.0.0.0 0.0.0.0

ciscoasa(config-network-object)# ex

ciscoasa(config)# nat (inside,outside) source dynamic Generic_All_Network inte$

ciscoasa(config)#

ciscoasa(config)#

ciscoasa(config)# wr

Building configuration...

Cryptochecksum: fe5175c6 25dfd45a 117bd6e3 867486db

3211 bytes copied in 1.120 secs (3211 bytes/sec)

[OK]

ciscoasa(config)# sh run

: Saved

:

ASA Version 9.1(4)

!

hostname ciscoasa

enable password 2KFQnbNIdI.2KYOU encrypted

xlate per-session permit tcp any4 any4

xlate per-session permit udp any4 any4

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.3.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address 192.168.100.2 255.255.255.0

!

ftp mode passive

object network inside_hosts

subnet 192.168.3.0 255.255.255.0

object network Generic_All_Network

subnet 0.0.0.0 0.0.0.0

access-list inbound extended permit ip any any

access-list inbound extended permit icmp any4 any4

access-list inside_access_in extended permit ip 192.168.3.0 255.255.255.0 any

pager lines 24

logging enable

logging asdm informational

mtu outside 1500

mtu inside 1500

ip verify reverse-path interface outside

ip verify reverse-path interface inside

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

arp permit-nonconnected

nat (inside,outside) source dynamic Generic_All_Network interface

!

object network inside_hosts

nat (inside,outside) dynamic interface

access-group inbound in interface outside

access-group inside_access_in in interface inside

route outside 0.0.0.0 0.0.0.0 192.168.100.1 1

timeout xlate 3:00:00

timeout pat-xlate 0:00:30

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

user-identity default-domain LOCAL

http server enable

http 192.168.3.0 255.255.255.0 inside

http 0.0.0.0 0.0.0.0 outside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart

crypto ipsec security-association pmtu-aging infinite

crypto ca trustpool policy

telnet timeout 5

ssh timeout 5

ssh key-exchange group dh-group1-sha1

console timeout 0

dhcpd auto_config outside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny

  inspect sunrpc

  inspect xdmcp

  inspect sip

  inspect netbios

  inspect tftp

  inspect ip-options

  inspect icmp

!

service-policy global_policy global

prompt hostname context

call-home reporting anonymous prompt 2

Cryptochecksum:fe5175c625dfd45a117bd6e3867486db

: end

2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Green

ASA 5505 version 9.1(4) NAT issue

Is there a specific reason why you are NATing on the ASA?  Is the router managed by your company?

--
Please remember to rate and select a correct answer

-- Please remember to rate and select a correct answer
VIP Green

ASA 5505 version 9.1(4) NAT issue

Just for testing and eliminating add a permit ip any any to the outside interface.

access-list test extended permit ip any any

access-group test in interface outside

and then test again please.

--
Please remember to rate and select a correct answer

-- Please remember to rate and select a correct answer
29 REPLIES
VIP Green

ASA 5505 version 9.1(4) NAT issue

Please remove the following command

nat (inside,outside) source dynamic Generic_All_Network interface

You already have a dynamic NAT for the inside hosts:

object network inside_hosts

  subnet 192.168.3.0 255.255.255.0

  nat (inside,outside) dynamic interface

does the router have a route back to the 192.168.3/24 network?

could you issue a packet tracer on the ASA and post the output here please.

packet-tracer input inside tcp 192.168.3.22 1234 4.2.2.2 80 detail

--
Please remember to rate and select a correct answer

-- Please remember to rate and select a correct answer
New Member

ASA 5505 version 9.1(4) NAT issue

Following is the output from packet tracer

ciscoasa# packet-tracer input inside tcp 192.168.3.22 1234 4.2.2.2 80 detail

Phase: 1

Type: ACCESS-LIST

Subtype:

Result: ALLOW

Config:

Implicit Rule

Additional Information:

Forward Flow based lookup yields rule:

in  id=0xcb12af48, priority=1, domain=permit, deny=false

        hits=0, user_data=0x0, cs_id=0x0, l3_type=0x8

        src mac=0000.0000.0000, mask=0000.0000.0000

        dst mac=0000.0000.0000, mask=0100.0000.0000

        input_ifc=inside, output_ifc=any

Phase: 2

Type: ROUTE-LOOKUP

Subtype: input

Result: ALLOW

Config:

Additional Information:

in   0.0.0.0         0.0.0.0         outside

Phase: 3

Type: ROUTE-LOOKUP

Subtype: input

Result: ALLOW

Config:

Additional Information:

in   192.168.3.0     255.255.255.0   inside

Phase: 4

Type: ACCESS-LIST

Subtype: log

Result: ALLOW

Config:

access-group inside_access_in in interface inside

access-list inside_access_in extended permit ip 192.168.3.0 255.255.255.0 any

Additional Information:

Forward Flow based lookup yields rule:

in  id=0xcb202db8, priority=13, domain=permit, deny=false

        hits=0, user_data=0xc9234ab0, cs_id=0x0, use_real_addr, flags=0x0, protocol=0

        src ip/id=192.168.3.0, mask=255.255.255.0, port=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0

        input_ifc=inside, output_ifc=any

Phase: 5

Type: NAT

Subtype:

Result: ALLOW

Config:

nat (inside,outside) source dynamic Generic_All_Network interface

Additional Information:

Dynamic translate 192.168.3.22/1234 to 192.168.100.2/1234

Forward Flow based lookup yields rule:

in  id=0xcb1fcee0, priority=6, domain=nat, deny=false

        hits=0, user_data=0xcb1fc080, cs_id=0x0, flags=0x0, protocol=0

        src ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0

        input_ifc=inside, output_ifc=outside

Phase: 6

Type: NAT

Subtype: per-session

Result: ALLOW

Config:

Additional Information:

Forward Flow based lookup yields rule:

in  id=0xc7669ae8, priority=1, domain=nat-per-session, deny=false

        hits=0, user_data=0x0, cs_id=0x0, reverse, use_real_addr, flags=0x0, protocol=6

        src ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0

        input_ifc=any, output_ifc=any

Phase: 7

Type: IP-OPTIONS

Subtype:

Result: ALLOW

Config:

Additional Information:

Forward Flow based lookup yields rule:

in  id=0xcb1baae8, priority=0, domain=inspect-ip-options, deny=true

        hits=0, user_data=0x0, cs_id=0x0, reverse, flags=0x0, protocol=0

        src ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0

        input_ifc=inside, output_ifc=any

Phase: 8

Type: HOST-LIMIT

Subtype:

Result: ALLOW

Config:

Additional Information:

Forward Flow based lookup yields rule:

in  id=0xcb1e86f8, priority=0, domain=host-limit, deny=false

        hits=1, user_data=0x0, cs_id=0x0, flags=0x0, protocol=0

        src ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0

        input_ifc=inside, output_ifc=any

Phase: 9

Type: NAT

Subtype: rpf-check

Result: ALLOW

Config:

nat (inside,outside) source dynamic Generic_All_Network interface

Additional Information:

Forward Flow based lookup yields rule:

out id=0xcb1fd6f0, priority=6, domain=nat-reverse, deny=false

        hits=1, user_data=0xcb1fc138, cs_id=0x0, use_real_addr, flags=0x0, protocol=0

        src ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0

        input_ifc=inside, output_ifc=outside

Phase: 10

Type: NAT

Subtype: per-session

Result: ALLOW

Config:

Additional Information:

Reverse Flow based lookup yields rule:

in  id=0xc7669ae8, priority=1, domain=nat-per-session, deny=false

        hits=2, user_data=0x0, cs_id=0x0, reverse, use_real_addr, flags=0x0, protocol=6

        src ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0

        input_ifc=any, output_ifc=any

Phase: 11

Type: IP-OPTIONS

Subtype:

Result: ALLOW

Config:

Additional Information:

Reverse Flow based lookup yields rule:

in  id=0xcb1e3f10, priority=0, domain=inspect-ip-options, deny=true

        hits=1, user_data=0x0, cs_id=0x0, reverse, flags=0x0, protocol=0

        src ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0

        input_ifc=outside, output_ifc=any

Phase: 12

Type: FLOW-CREATION

Subtype:

Result: ALLOW

Config:

Additional Information:

New flow created with id 1, packet dispatched to next module

Module information for forward flow ...

snp_fp_tracer_drop

snp_fp_inspect_ip_options

snp_fp_tcp_normalizer

snp_fp_translate

snp_fp_adjacency

snp_fp_fragment

snp_ifc_stat

Module information for reverse flow ...

snp_fp_tracer_drop

snp_fp_inspect_ip_options

snp_fp_translate

snp_fp_tcp_normalizer

snp_fp_adjacency

snp_fp_fragment

snp_ifc_stat

Result:

input-interface: inside

input-status: up

input-line-status: up

output-interface: outside

output-status: up

output-line-status: up

Action: allow

VIP Green

ASA 5505 version 9.1(4) NAT issue

Well, the packet is allowed through the ASA, which leads me to believe this is a routing issue on the router...or more acurately, this is a NAT issue on the ASA.  Really depends on how you want to look at it.

Why are you NATing on the ASA when you have a router between the ASA and the internet?

I suspect that the router has an incorrect route with regards the inside network being NATed.  If the router is managed by you, then I suggest removing all NAT configuration on the ASA and perform NAT on the router.

--
Please remember to rate and select a correct answer

-- Please remember to rate and select a correct answer
New Member

Re: ASA 5505 version 9.1(4) NAT issue

If packet is allowed through ASA then how is it NAT issue?

New Member

ASA 5505 version 9.1(4) NAT issue

Please see below trace for icmp its dropped.

ciscoasa(config)# packet-tracer input inside icmp 192.168.3.22 12 34 4.2.2.2 d$

Phase: 1

Type: ROUTE-LOOKUP

Subtype: input

Result: ALLOW

Config:

Additional Information:

in   0.0.0.0         0.0.0.0         outside

Phase: 2

Type: ROUTE-LOOKUP

Subtype: input

Result: ALLOW

Config:

Additional Information:

in   192.168.3.0     255.255.255.0   inside

Phase: 3

Type: ACCESS-LIST

Subtype: log

Result: ALLOW

Config:

access-group inside_access_in in interface inside

access-list inside_access_in extended permit ip 192.168.3.0 255.255.255.0 any

Additional Information:

Forward Flow based lookup yields rule:

in  id=0xcb202db8, priority=13, domain=permit, deny=false

        hits=2, user_data=0xc9234ab0, cs_id=0x0, use_real_addr, flags=0x0, protocol=0

        src ip/id=192.168.3.0, mask=255.255.255.0, port=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0

        input_ifc=inside, output_ifc=any

Phase: 4

Type: NAT

Subtype:

Result: ALLOW

Config:

object network inside_hosts

nat (inside,outside) dynamic interface

Additional Information:

Forward Flow based lookup yields rule:

in  id=0xcb200698, priority=6, domain=nat, deny=false

        hits=1, user_data=0xcb1fc1f0, cs_id=0x0, flags=0x0, protocol=0

        src ip/id=192.168.3.0, mask=255.255.255.0, port=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0

        input_ifc=inside, output_ifc=outside

Phase: 5

Type: NAT

Subtype: per-session

Result: ALLOW

Config:

Additional Information:

Forward Flow based lookup yields rule:

in  id=0xcab4fd00, priority=0, domain=nat-per-session, deny=true

        hits=0, user_data=0x0, cs_id=0x0, reverse, use_real_addr, flags=0x0, protocol=0

        src ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0

        input_ifc=any, output_ifc=any

Phase: 6

Type: IP-OPTIONS

Subtype:

Result: ALLOW

Config:

Additional Information:

Forward Flow based lookup yields rule:

in  id=0xcb1baae8, priority=0, domain=inspect-ip-options, deny=true

        hits=3, user_data=0x0, cs_id=0x0, reverse, flags=0x0, protocol=0

        src ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0

        input_ifc=inside, output_ifc=any

Phase: 7

Type: INSPECT

Subtype: np-inspect

Result: ALLOW

Config:

class-map inspection_default

match default-inspection-traffic

policy-map global_policy

class inspection_default

  inspect icmp

service-policy global_policy global

Additional Information:

Forward Flow based lookup yields rule:

in  id=0xcb7774d0, priority=70, domain=inspect-icmp, deny=false

        hits=1, user_data=0xcb7769f8, cs_id=0x0, use_real_addr, flags=0x0, protocol=1

        src ip/id=0.0.0.0, mask=0.0.0.0, icmp-type=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, icmp-code=0, tag=0, dscp=0x0

        input_ifc=inside, output_ifc=any

Phase: 8

Type: INSPECT

Subtype: np-inspect

Result: ALLOW

Config:

Additional Information:

Forward Flow based lookup yields rule:

in  id=0xcb1ba5e8, priority=66, domain=inspect-icmp-error, deny=false

        hits=1, user_data=0xcb1b9bf8, cs_id=0x0, use_real_addr, flags=0x0, protocol=1

        src ip/id=0.0.0.0, mask=0.0.0.0, icmp-type=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, icmp-code=0, tag=0, dscp=0x0

        input_ifc=inside, output_ifc=any

Phase: 9

Type: HOST-LIMIT

Subtype:

Result: ALLOW

Config:

Additional Information:

Forward Flow based lookup yields rule:

in  id=0xcb1e86f8, priority=0, domain=host-limit, deny=false

        hits=3, user_data=0x0, cs_id=0x0, flags=0x0, protocol=0

        src ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0

        input_ifc=inside, output_ifc=any

Result:

input-interface: inside

input-status: up

input-line-status: up

output-interface: outside

output-status: up

output-line-status: up

Action: drop

Drop-reason: (acl-drop) Flow is denied by configured rule

New Member

Re: ASA 5505 version 9.1(4) NAT issue

Does 192.168.3.0/24 requires any route in the Router because it will be NAT with outside interface. first

ASA required to create an IPSEC tunnel, but first need to resolve NAT issue.

Message was edited by: Rizwan Siddiqi

New Member

ASA 5505 version 9.1(4) NAT issue

problem is in this phase

Phase: 5

Type: NAT

Subtype: per-session

Result: ALLOW

Config:

Additional Information:

Forward Flow based lookup yields rule:

in  id=0xcab4fd00, priority=0, domain=nat-per-session, deny=true

        hits=0, user_data=0x0, cs_id=0x0, reverse, use_real_addr, flags=0x0, protocol=0

        src ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0

        input_ifc=any, output_ifc=any

Phase: 6

Type: IP-OPTIONS

Subtype:

Result: ALLOW

Config:

Additional Information:

Forward Flow based lookup yields rule:

in  id=0xcb1baae8, priority=0, domain=inspect-ip-options, deny=true

        hits=3, user_data=0x0, cs_id=0x0, reverse, flags=0x0, protocol=0

        src ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0

        input_ifc=inside, output_ifc=any

VIP Green

ASA 5505 version 9.1(4) NAT issue

could you post the output of the command please:

show service-policy inspect ip-options

--
Please remember to rate and select a correct answer

-- Please remember to rate and select a correct answer
VIP Green

ASA 5505 version 9.1(4) NAT issue

Is there a specific reason why you are NATing on the ASA?  Is the router managed by your company?

--
Please remember to rate and select a correct answer

-- Please remember to rate and select a correct answer
VIP Green

ASA 5505 version 9.1(4) NAT issue

Also check your logs when you ping the router.  This could give some helpful pointers as to what is dropping the packet.

--
Please remember to rate and select a correct answer

-- Please remember to rate and select a correct answer
New Member

ASA 5505 version 9.1(4) NAT issue

Fiber is terminating at router.

New Member

ASA 5505 version 9.1(4) NAT issue

ciscoasa(config)# show service-policy inspect ip-options

Global policy:

  Service-policy: global_policy

    Class-map: inspection_default

      Inspect: ip-options _default_ip_options_map, packet 0, drop 0, reset-drop 0, v6-fail-close 0

        Router Alert:  allow 0, clear 0

New Member

ASA 5505 version 9.1(4) NAT issue

I ping from inside interface and get following output

     

ciscoasa(config)# ping

TCP Ping [n]:

Target IP address: 192.168.100.1

Repeat count: [5]

Datagram size: [100]

Timeout in seconds: [2]

Extended commands [n]:

Sweep range of sizes [n]:

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:

%ASA-6-110003: Routing failed to locate next hop for icmp from NP Identity Ifc:192.168.3.1/0 to inside:192.168.100.1/0

?????

Success rate is 0 percent (0/5)

ciscoasa(config)# %ASA-5-111008: User 'enable_15' executed the 'ping' command.

%ASA-5-111010: User 'enable_15', running 'CLI' from IP 0.0.0.0, executed 'ping'

ciscoasa(config)#

New Member

ASA 5505 version 9.1(4) NAT issue

Do you have any idea about nat-per-session for icmp because for it deny = true see below output

Phase: 5

Type: NAT

Subtype: per-session

Result: ALLOW

Config:

Additional Information:

Forward Flow based lookup yields rule:

in  id=0xcab4fd00, priority=0, domain=nat-per-session, deny=true

        hits=0, user_data=0x0, cs_id=0x0, reverse, use_real_addr, flags=0x0, protocol=0

        src ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0

        input_ifc=any, output_ifc=any

Phase: 6

Type: IP-OPTIONS

Subtype:

Result: ALLOW

Config:

Additional Information:

Forward Flow based lookup yields rule:

in  id=0xcb1baae8, priority=0, domain=inspect-ip-options, deny=true

        hits=3, user_data=0x0, cs_id=0x0, reverse, flags=0x0, protocol=0

        src ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0

        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0

        input_ifc=inside, output_ifc=any

VIP Green

ASA 5505 version 9.1(4) NAT issue

could you try removing the following command and then testing.

nat (inside,outside) source dynamic Generic_All_Network interface

You already have dynamic NAT configured with the following command

object network inside_hosts

nat (inside,outside) dynamic interface

--
Please remember to rate and select a correct answer

-- Please remember to rate and select a correct answer
New Member

ASA 5505 version 9.1(4) NAT issue

yep I have already removed  nat (inside,outside) source dynamic Generic_All_Network interface

Following is the latest show-running

ciscoasa(config)# sh run

: Saved

:

ASA Version 9.1(4)

!

hostname ciscoasa

enable password 2KFQnbNIdI.2KYOU encrypted

xlate per-session permit tcp any4 any4

xlate per-session permit udp any4 any4

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.3.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address 192.168.100.2 255.255.255.0

!

ftp mode passive

object network inside_hosts

subnet 192.168.3.0 255.255.255.0

access-list inbound extended permit ip any any

access-list inbound extended permit icmp any4 any4

access-list inside_access_in extended permit ip 192.168.3.0 255.255.255.0 any

access-list capi extended permit ip host 192.168.3.22 host 192.168.100.1

access-list capi extended permit ip host 192.168.100.1 host 192.168.3.22

access-list capo extended permit ip host 192.168.100.2 any

access-list capo extended permit ip any host 192.168.100.2

pager lines 24

logging enable

logging asdm informational

mtu inside 1500

mtu outside 1500

ip verify reverse-path interface inside

ip verify reverse-path interface outside

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

arp permit-nonconnected

!

object network inside_hosts

nat (inside,outside) dynamic interface

access-group inside_access_in in interface inside

access-group inbound in interface outside

route outside 0.0.0.0 0.0.0.0 192.168.100.1 1

timeout xlate 3:00:00

timeout pat-xlate 0:00:30

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

user-identity default-domain LOCAL

http server enable

http 192.168.3.0 255.255.255.0 inside

http 0.0.0.0 0.0.0.0 outside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart

crypto ipsec security-association pmtu-aging infinite

crypto ca trustpoint _SmartCallHome_ServerCA

crl configure

crypto ca trustpool policy

crypto ca certificate chain _SmartCallHome_ServerCA

certificate ca 6ecc7aa5a7032009b8cebcf4e952d491

    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130

    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117

    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b

    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504

    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72

    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56

    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043

    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31

    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b

    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20

    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65

    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420

    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329

    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365

    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7

    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597

    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10

    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc

    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b

    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845

    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8

    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced

    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f

    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201

    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868

    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101

    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8

    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777

    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a

    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406

    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973

    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403

    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969

    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b

    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973

    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30

    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603

    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355

    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609

    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80

    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e

    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a

    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc

    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16

    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0

    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8

    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28

    6c2527b9 deb78458 c61f381e a4c4cb66

  quit

telnet timeout 5

ssh timeout 5

ssh key-exchange group dh-group1-sha1

console timeout 0

dhcpd auto_config outside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny

  inspect sunrpc

  inspect xdmcp

  inspect sip

  inspect netbios

  inspect tftp

  inspect ip-options

  inspect icmp

!

service-policy global_policy global

prompt hostname context

call-home reporting anonymous

Cryptochecksum:b5958fd342c81895465887026d1423b3

: end

New Member

ASA 5505 version 9.1(4) NAT issue

It does not make any difference

VIP Green

ASA 5505 version 9.1(4) NAT issue

Another thing you could do is do a packet capture.

access-list capi extended permit ip host 192.168.3.22 host 192.168.100.1

access-list capi extended permit ip host 192.168.100.1 host 192.168.3.22

access-list capo extended permit ip host 192.168.100.2 any

access-list capo extended permit ip any host 192.168.100.2

capture cap-in interface inside access-list capi

capture cap-out interface outside access-list capo

show capture cap-in

show capture cap-out

--
Please remember to rate and select a correct answer

-- Please remember to rate and select a correct answer
VIP Green

ASA 5505 version 9.1(4) NAT issue

what is the output of

show interface ip brief

Are there any interfaces that are down?

--
Please remember to rate and select a correct answer

-- Please remember to rate and select a correct answer
New Member

ASA 5505 version 9.1(4) NAT issue

Following is the required output for interfaces

ciscoasa(config)# sh interface ip brief

Interface                  IP-Address      OK? Method Status                Protocol

Ethernet0/0                unassigned      YES unset  up                    up

Ethernet0/1                unassigned      YES unset  down                  down

Ethernet0/2                unassigned      YES unset  down                  down

Ethernet0/3                unassigned      YES unset  down                  down

Ethernet0/4                unassigned      YES unset  up                    up

Ethernet0/5                unassigned      YES unset  down                  down

Ethernet0/6                unassigned      YES unset  down                  down

Ethernet0/7                unassigned      YES unset  down                  down

Internal-Data0/0           unassigned      YES unset  up                    up

Internal-Data0/1           unassigned      YES unset  up                    up

Vlan1                      192.168.3.1     YES CONFIG up                    up

Vlan2                      192.168.100.2   YES CONFIG up                    up

Virtual0                   127.1.0.1       YES unset  up                    up

VIP Green

ASA 5505 version 9.1(4) NAT issue

Just for testing and eliminating add a permit ip any any to the outside interface.

access-list test extended permit ip any any

access-group test in interface outside

and then test again please.

--
Please remember to rate and select a correct answer

-- Please remember to rate and select a correct answer
New Member

ASA 5505 version 9.1(4) NAT issue

Already added, Please see below

access-list inbound extended permit ip any any

access-list inbound extended permit icmp any4 any4

access-group inbound in interface outside

VIP Green

Re: ASA 5505 version 9.1(4) NAT issue

You configuration looks correct.  I would suggest a restart of the ASA.

can you ping the ASA (192.168.100.2) from the router, and vise versa?

--
Please remember to rate and select a correct answer

-- Please remember to rate and select a correct answer
New Member

ASA 5505 version 9.1(4) NAT issue

Should I downgrade ASA 5505 to ISO 8.4 ?

VIP Green

ASA 5505 version 9.1(4) NAT issue

I suggest trying a reboot first. before doing something as drastic as downgrading.  What type of router is infront of the ASA? can you ping the router from the ASA itself?

ping 192.168.100.1

--
Please remember to rate and select a correct answer

-- Please remember to rate and select a correct answer
New Member

ASA 5505 version 9.1(4) NAT issue

yes I can ping router from ASA and ping any website on internet. It is an ont router from Huawei

New Member

ASA 5505 version 9.1(4) NAT issue

From inside interface ping not working see below screenshot... but outside is working

ciscoasa(config)# ping 8.8.8.8

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 130/138/140 ms

icmp.png

New Member

ASA 5505 version 9.1(4) NAT issue

Any update ,,,suggestins awaited

VIP Green

ASA 5505 version 9.1(4) NAT issue

Since nothing is working I suggest scrubbing the configuration and reconfiguring the ASA.

Just add the folloing config first and then test.

hostname ciscoasa

enable password 2KFQnbNIdI.2KYOU encrypted

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.3.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address 192.168.100.2 255.255.255.0

ftp mode passive

object network inside_hosts

subnet 192.168.3.0 255.255.255.0

nat (inside,outside) dynamic interface

access-list inbound extended permit ip any any

access-list inbound extended permit icmp any4 any4

access-list inside_access_in extended permit ip 192.168.3.0 255.255.255.0 any

access-group inside_access_in in interface inside

access-group inbound in interface outside

route outside 0.0.0.0 0.0.0.0 192.168.100.1 1

aaa authentication http consol LOCAL

http server enable

http 192.168.3.0 255.255.255.0 inside

http 0.0.0.0 0.0.0.0 outside

--
Please remember to rate and select a correct answer

-- Please remember to rate and select a correct answer
972
Views
0
Helpful
29
Replies