Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

ASA 5505Trunking port issue

Hello everyone,

I've recently added 5 vlans into my network and turned my eth0/1 port which goes to my switch into a trunk port. Since this change I haven't been able to get out to the internet at all. From my switch I am able to ping all of the vlan IP addresses assigned to the ASA, and vice-versa. I have a feeling that the problem maybe with the ACLs, but I don't know exactly what to look for. I've attached my configuration file for all of you to look at. Any help is much appreciated.

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

First of all, remove the

First of all, remove the command switchport access vlan 4 from the interface

interface Ethernet0/1
 switchport access vlan 4
 switchport trunk allowed vlan 4,10,13-14,50-51
 switchport mode trunk

Also I notice you do not have any NAT statement configured, please add the following command:

object network obj_any
  nat (any,outside) dynamic interface

Though you should have specific dynamic NAT for each network, this is a quick and easy solution to configure NAT.

Try making these changes and then test, and let us know how it goes.

--

Please remember to select a correct answer and rate helpful posts

--
Please remember to rate and select a correct answer
4 REPLIES

What license do you have

What license do you have installed on your ASA (show version)?  If you have the base license then you will need to uprade to the security plus license.

--

Please remember to select a correct answer and rate helpful posts

--
Please remember to rate and select a correct answer
Community Member

Hello Marius,The device has

Hello Marius,

The device has the security plus license

First of all, remove the

First of all, remove the command switchport access vlan 4 from the interface

interface Ethernet0/1
 switchport access vlan 4
 switchport trunk allowed vlan 4,10,13-14,50-51
 switchport mode trunk

Also I notice you do not have any NAT statement configured, please add the following command:

object network obj_any
  nat (any,outside) dynamic interface

Though you should have specific dynamic NAT for each network, this is a quick and easy solution to configure NAT.

Try making these changes and then test, and let us know how it goes.

--

Please remember to select a correct answer and rate helpful posts

--
Please remember to rate and select a correct answer
Community Member

Thank you Marius, those 2

Thank you Marius, those 2 commands did the trick.

45
Views
0
Helpful
4
Replies
CreatePlease to create content