Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

ASA 5510 Routing failed to locate next hop

                   Hello

I have two interfaces connected to two different subnet -  interface 0/1 = 10.100.1.0/24 , interface0/2 = 10.100.113.0/24 as they are direct connected to the ASA i assume i dont need to add an static route but when i try to ping from one interface to the other (ping inside 10.100.113.1) i get "Routing failed to locate next hop". this is really driving me crazy and i need some help, here is the configuration:

ASA Version 8.2(1)
!
hostname OR-FW-01
enable password nF1ewpJIfsOH9CKy encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 10.100.104.0 AUS-UT-NET description Austin UT Network
name 10.100.120.0 HOU-ME-NET description Houston ME Network
name 10.100.121.0 HOU-KW-NET description Houston KW Network
name 10.100.105.0 AUS-RR-NET description AUS Round Rock Net
name 10.100.106.0 AUS-CA-NET description AUS Central Austin Net
name 10.100.122.0 HOU-SL-NET description Hosuton - Sugar Land - Net
name 10.100.110.0 AUS-CORP-MRK1 description AUS-CORP-MRK1
!
interface Ethernet0/0
speed 100
duplex full
nameif outside
security-level 0
ip address 10.200.207.26 255.255.255.0
!
interface Ethernet0/1
nameif Inside
security-level 100
ip address 10.100.1.1 255.255.255.0
!
interface Ethernet0/2
description inside2 Network
nameif inside2
security-level 100
ip address 10.100.113.1 255.255.255.0
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 192.168.1.1 255.255.255.0
management-only
!
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group service RDP tcp
port-object eq 3389
access-list outside_cryptomap extended permit ip 10.100.1.0 255.255.255.0 10.21.21.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 10.100.1.0 255.255.255.0 10.21.21.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 10.100.1.0 255.255.255.0 10.100.101.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 10.100.1.0 255.255.255.0 10.100.102.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 10.100.1.0 255.255.255.0 10.100.103.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip any 192.168.156.0 255.255.255.224
access-list Inside_nat0_outbound extended permit ip 10.100.1.0 255.255.255.0 AUS-UT-NET 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 10.100.1.0 255.255.255.0 HOU-ME-NET 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 10.100.1.0 255.255.255.0 HOU-KW-NET 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 10.100.1.0 255.255.255.0 AUS-RR-NET 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 10.100.1.0 255.255.255.0 AUS-CA-NET 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 10.100.1.0 255.255.255.0 HOU-SL-NET 255.255.255.0
access-list Inside_nat0_outbound extended permit ip any AUS-CORP-MRK1 255.255.255.0
access-list Inside_nat0_outbound extended permit ip any 10.100.113.0 255.255.255.0
access-list outside_access_in extended permit ip any any
access-list outside_access_in extended permit tcp any any eq 3389
access-list outside_access_in remark TS Services
access-list outside_access_in extended permit tcp any host 207.200.18.35 eq https
access-list outside_access_in extended permit icmp any any
access-list outside_cryptomap_1 extended permit ip 10.100.1.0 255.255.255.0 10.100.101.0 255.255.255.0
access-list outside_cryptomap_2 extended permit ip 10.100.1.0 255.255.255.0 10.100.102.0 255.255.255.0
access-list outside_cryptomap_3 extended permit ip 10.100.1.0 255.255.255.0 10.100.103.0 255.255.255.0
access-list outside_6_cryptomap extended permit ip 10.100.1.0 255.255.255.0 AUS-RR-NET 255.255.255.0
access-list outside_cryptomap_5 extended permit ip 10.100.1.0 255.255.255.0 AUS-UT-NET 255.255.255.0
access-list outside_cryptomap_6 extended permit ip 10.100.1.0 255.255.255.0 HOU-ME-NET 255.255.255.0
access-list outside_cryptomap_7 extended permit ip 10.100.1.0 255.255.255.0 HOU-KW-NET 255.255.255.0
access-list outside_7_cryptomap extended permit ip 10.100.1.0 255.255.255.0 AUS-CA-NET 255.255.255.0
access-list outside_8_cryptomap extended permit ip 10.100.1.0 255.255.255.0 HOU-SL-NET 255.255.255.0
access-list inside2_nat0_outbound extended permit ip any AUS-CORP-MRK1 255.255.255.0
access-list inside2_nat0_outbound extended permit ip any 10.100.1.0 255.255.255.0
access-list inside2_nat0_outbound extended permit ip any any
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu Inside 1500
mtu inside2 1500
mtu management 1500
ip local pool RAS_POOL 192.168.156.1-192.168.156.20 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (outside) 1 192.168.156.0 255.255.255.0
nat (Inside) 0 access-list Inside_nat0_outbound
nat (Inside) 1 0.0.0.0 0.0.0.0
nat (inside2) 0 access-list inside2_nat0_outbound
nat (inside2) 1 0.0.0.0 0.0.0.0
static (Inside,outside) 207.200.18.35 10.100.1.20 netmask 255.255.255.255
static (Inside,outside) 207.200.18.33 10.100.1.10 netmask 255.255.255.255
static (Inside,outside) 207.200.18.34 10.100.1.11 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 10.200.207.25 1
route inside2 AUS-CORP-MRK1 255.255.255.0 10.100.113.3 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa-server acme-Radius protocol radius
aaa-server acme-Radius (Inside) host 10.100.1.10
key OSDVII
radius-common-pw OSDVII
http server enable
http 192.168.1.0 255.255.255.0 management
http 0.0.0.0 0.0.0.0 Inside
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 0.0.0.0 0.0.0.0 outside
telnet 0.0.0.0 0.0.0.0 Inside
telnet timeout 5
ssh timeout 5
console timeout 0
management-access inside2
dhcpd address 10.100.1.200-10.100.1.239 Inside
dhcpd dns 10.100.1.10 10.100.1.11 interface Inside
dhcpd domain acme.local interface Inside
dhcpd enable Inside
!
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:3de3071465cf57eb8748938cf53ab51d
: end

I apreciate any help on this.

Thanks

David

Everyone's tags (1)
1 REPLY
Cisco Employee

ASA 5510 Routing failed to locate next hop

You can't ping from one interface to the other interface on ASA firewall, nor can you ping from a subnet behind an interface across the other interface.

You should be able to ping from a host on the inside interface to a host on the Inside2 interface and vice versa.

Might need to configure icmp inspection:

policy-map global_policy

class inspection_default

  inspect icmp

2236
Views
0
Helpful
1
Replies
CreatePlease to create content