Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

ASA 8.0(2) - ASDM HTTP Server Problem - Could not start admin

Hi all,

I'm having a weird problem, probably a bug, with my ASA 5520 running version 8.0(2) and ASDM 6.0(2)

In a factory default configuration with normal ASDM access I put the attached config on the Firewall.

After I save and reboot the Firewall I get the following message during the reboot:

Could not start admin

I check the config and I realize that the http server section is like this:

http server enable

http 10.99.250.0 255.255.255.0 WAN

It lost one line and I cannot get through ASDM from anywhere to the Firewall. Even from the WAN interface.

I try to activate the HTTP server and I get the following:

ciscoasa(config)# no http server enable

ciscoasa(config)# no http 10.99.250.0 255.255.255.0 WAN

ciscoasa(config)# no http 192.168.1.0 255.255.255.0 management

ciscoasa(config)#

ciscoasa(config)#

ciscoasa(config)# http 10.99.250.0 255.255.255.0 WAN

WARNING: http server is not yet enabled to allow ASDM access.

ciscoasa(config)# http 192.168.1.0 255.255.255.0 management

WARNING: http server is not yet enabled to allow ASDM access.

ciscoasa(config)# http server enable

Could not start admin

After some trial and error I was able to put it back to work after taking out 3 VLAN interfaces. This configuration has 17 VLAN interfaces.

Some bug is preventing the HTTP Server to start if there are more than 14 VLAN interfaces configured on the ASA running this version because I don't have this kind of problem running this config in version 7.

Anyone having the same problem?

4 REPLIES
Silver

Re: ASA 8.0(2) - ASDM HTTP Server Problem - Could not start admi

Go into Configuration -- > Properties --> DNS

Add rule there.. instead of NO and NO.

Regards,

Dharmesh Purohit

Community Member

Re: ASA 8.0(2) - ASDM HTTP Server Problem - Could not start admi

Hi Dharmesh,

Can you explain this, please?

In ASDM 6.0 I don't have the path like you are telling me.

And what DNS has to do with influencing the HTTP Server depending on the number of configured VLAN interfaces?

Thanks in advance.

Community Member

Re: ASA 8.0(2) - ASDM HTTP Server Problem - Could not start admi

I am having the same problem and my engineer recommended that I upgrade to 8.0.3. Don't bother, it doesn't help. I upgraded on Sunday, and by Monday, I had the same problem again.

Apparently, it is a known bug and will be resolved in 8.1.1. I don't know of an ETA on 8.1.1, though.

See the following link:

http://www.tek-tips.com/viewthread.cfm?qid=1419872&page=1

Community Member

Re: ASA 8.0(2) - ASDM HTTP Server Problem - Could not start admi

Yesterday I've upgraded the firewall to 8.0.3 and the problem didn't happen again. Let's see if it keeps that way.

I've followed the tek-tips link you've posted and I really had the management interface on HTTP Server but I don't think that was my real problem.

My issue was really the number of VLAN interfaces configured. If I reached a certain number of VLAN interfaces the HTTP admin would stop working after a reboot.

Version 8.0.3 seems to have solved my issue.

Let's see how long we will have to wait for version 8.1.1 to solve your problem.

3696
Views
1
Helpful
4
Replies
CreatePlease to create content