Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

ASA Basic Ping Failing

Hi All, Just bought a ASA to start learning about Firewalls and run in to some basic ping issues...

My Home network is like this.

ISP - > Netgear Router (192.168.1.250) -> PC (192.168.1.10)

                                                                       -> CiscoASA 'Outside Interface' Vlan 1000 (192.168.1.1) Configured on eth 0/6

Then on the ASA eth 0/6 is a server , This is configured as a 'Inside Interface' Vlan 2000 (10.0.0.1) .

The server IP conneted to eth 0/1 is 10.0.0.100

From the ASA i can ping everything fine

What i want to do is be able to connect from my PC (192.168.1.10) to the server (10.0.0.100)

The netgear router has a static route telling it the 10.0.0.x network is located on the gateway of 192.168.1.1

The ASDM is receiving the pings from the PC but it looks like it is being denied

The error message is









Deny inbound icmp src inside:10.0.0.100 dst inside:10.0.0.1 (type 8, code 0)

Please see the below config , Can you advise what i need to do to get everything working ?

: Saved
:
ASA Version 8.4(3) 
!
hostname ciscoasa
!
interface Ethernet0/0
 switchport access vlan 1000
!
interface Ethernet0/1
 shutdown
!
interface Ethernet0/2
 shutdown
!
interface Ethernet0/3
 shutdown
!
interface Ethernet0/4
 shutdown
!
interface Ethernet0/5
 shutdown
!
interface Ethernet0/6
 switchport access vlan 2000
!
interface Ethernet0/7
 shutdown
!
interface Vlan1
 no nameif
 no security-level
 no ip address
!
interface Vlan1000
 nameif outside
 security-level 0
 ip address 192.168.1.1 255.255.255.0 
!
interface Vlan2000
 nameif inside
 security-level 100
 ip address 10.0.0.1 255.255.255.0 
!
ftp mode passive
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat (inside,outside) source static any interface
route outside 0.0.0.0 0.0.0.0 192.168.1.250 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
telnet timeout 5
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect ip-options 
  inspect netbios 
  inspect rsh 
  inspect rtsp 
  inspect skinny  
  inspect esmtp 
  inspect sqlnet 
  inspect sunrpc 
  inspect tftp 
  inspect sip  
  inspect xdmcp 
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
: end
no asdm history enable
1 ACCEPTED SOLUTION

Accepted Solutions

ASA Basic Ping Failing

Hello Vishal,

Add the following on the CLI.

Fixup protocol ICMP

access-list out_in permit icmp host  192.168.1.10  host 10.0.0.100

acess-group out_in in interface outside

Regards,

Do rate all the helpful posts

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
1 REPLY

ASA Basic Ping Failing

Hello Vishal,

Add the following on the CLI.

Fixup protocol ICMP

access-list out_in permit icmp host  192.168.1.10  host 10.0.0.100

acess-group out_in in interface outside

Regards,

Do rate all the helpful posts

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
254
Views
0
Helpful
1
Replies
CreatePlease to create content