Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

ASA Routing problem

I have  a problem with a routing.

My ASA 5510 is at ip 192.168.1.20

I have alos a router on IP Adress 192.168.1.30

I have created static route on the ASA for network 10.1.1.0 and network 10.1.10.1 to the gateway 192.168.1.30.

Problem I cannot ping the 10.1.1.0 and 10.1.10.1 networks...

In the logging I get Inbound ICMP deny message

I have open everything in the inbound Inside Interface.

Why can't I reach those networks?

My computer's gateway is the ASA 192.168.1.20. Everything else is working fine (WAN to LAN and LAN to WAN)

Only the LAN to LAN thing blocks...

Thanks for your help.

17 REPLIES
Red

ASA Routing problem

Can you add this??

policy-map global_policy

  class inspection_default

    inspect icmp

and if it doesn.t work can you providfe th nat and acl's that you have added??

Thanks,

Varun

Thanks, Varun Rao Security Team, Cisco TAC

Re: ASA Routing problem

Yes, I have added the inspect ICMP

I have created routes like this

route inside 10.1.1.0 255.255.255.0 192.168.1.30

route inside 10.1.10.0 255.255.255.252 192.168.1.30

Is this a problem of nat? Do i have to create Nat rules instead of static routes?

access-list Inside_access_in extended permit ip any any

access-list Inside_access_in extended permit tcp any any

access-list Inside_access_in extended permit udp any any

access-list Inside_access_in extended permit icmp any any

Red

ASA Routing problem

No if you are pinging from outside interface to inside interface, then you would need to appli these access-list on the outside interface:

access-list outside_access_in extended permit ip any any

access-group outside_access_in in interface outside

alongwith the static.

Let me know from where are you pinging, inside to outside or outside to inside??

Thanks,

Varun

Thanks, Varun Rao Security Team, Cisco TAC

Re: ASA Routing problem

Actually it's inside inside...

-----------------------------------------------------

Mycomputer = 192.168.1.101

To Gateway = 192.168.1.20

Connected to subnet= 192.168.1.0

------------------------------------------------------

ASA = 192.168.1.20

Routes

route inside 10.1.1.0 255.255.255.0 192.168.1.30

route inside 10.1.10.0 255.255.255.252 192.168.1.30

Connected to subnet: 192.168.1.0 and WAN

-----------------------------------------------------

Router= 192.168.1.30

Connected to subnet 10.1.1.0 and 10.1.10.0

Hope it makes more sense

Purple

ASA Routing problem

Hi,

then you must permit traffic entering an interface to exit the same interface with the global config command:

same-security-traffic permit inter-interface

Alain

Don't forget to rate helpful posts.

Re: ASA Routing problem

thanks I'll try this and get back to you

Sent from Cisco Technical Support iPhone App

Re: ASA Routing problem

shouldn't be intra-interface ??

Sent from Cisco Technical Support iPhone App

Red

Re: ASA Routing problem

Hi Jean,

You would need the following configuration then:

static (inside,inside) 10.1.1.0 10.1.1.0 norand nailed

static (inside,inside) 10.1.10.0 10.1.10.0 norand nailed

nat (inside) 10 0.0.0.0 0.0.0.0

global (inside) 10 interface

same-security-traffic permit intra-interface

sysopt noproxyarp inside

this should do.

Thanks,

Varun

Thanks, Varun Rao Security Team, Cisco TAC

Re: ASA Routing problem

it's not working Alain

Sent from Cisco Technical Support iPhone App

Re: ASA Routing problem

Now I get error: portmap translation creation failed for icmp src

Sent from Cisco Technical Support iPhone App

Red

ASA Routing problem

Did you try the config I suggested??? Its missing a nat statement, according to the error message.

Can you share your config with us? alongwith the source and teh destination.

Thanks,

Varun

Thanks, Varun Rao Security Team, Cisco TAC

Re: ASA Routing problem

varun

Because the 10.1.1.0 and 10.1.10.0 are routed by the other router, not this one

Sent from Cisco Technical Support iPhone App

Re: ASA Routing problem

Varun

The 10.1.1.0 and 10.1.10.0 are connected to the other router 192.168.1.30

So I can't nat this subnet on this particular ASA. So I've created routes on the ASA to route this particular traffic to the 192.168.1.30 router.

Re: ASA Routing problem

any ideas?

Sent from Cisco Technical Support iPhone App

Re: ASA Routing problem

my problem is exactly like this one:

http://www.cisco.com/en/US/products/ps6120/products_tech_note09186a0080734db7.shtml

But how come it doesn't work??

Sent from Cisco Technical Support iPhone App

Re: ASA Routing problem

So far, I found that it seems to be a problem of natting. I've tried excluding inside traffic from natting but it blocks later on.

here's a screen shot of packet tracer and my config. Please help, I'm reaaly bumped out about this.

: Saved
: Written by enable_15 at 08:56:18.018 EST Tue Nov 8 2011
!
ASA Version 8.2(5)
!
hostname FW-SERVERS
domain-name logid.com
enable password nC1TgPA/j9j.bzQi encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.23.122 FTPServer
name 192.168.23.18 MailServer
name 192.168.23.3 VPNServer
!
interface Ethernet0/0
nameif Inside
security-level 100
ip address 192.168.1.20 255.255.252.0
!
interface Ethernet0/1
nameif outside
security-level 0
ip address X.X.X.X
!
interface Ethernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
no ip address
management-only
!
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup outside
dns server-group DefaultDNS
domain-name XXXX
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_Access_in extended permit tcp any host X.X.X.X eq ftp
access-list outside_Access_in extended permit tcp any host X.X.X.X eq https
access-list outside_Access_in extended permit tcp 67.22.232.0 255.255.255.0 host X.X.X.X eq smtp
access-list outside_Access_in extended permit tcp any host X.X.X.X eq pptp
access-list outside_Access_in extended permit tcp any host X.X.X.X eq 47
access-list outside_Access_in extended permit tcp any any eq 123
access-list outside_Access_in extended deny tcp any any
access-list outside_Access_in extended deny udp any any
access-list NAT0 standard permit any
access-list outside_1_cryptomap extended permit ip 192.168.23.0 255.255.255.0 192.168.20.0 255.255.255.0
access-list Inside_Access_in standard permit any
access-list 101 extended permit ip 192.168.1.0 255.255.252.0 10.0.0.0 255.0.0.0
pager lines 24
logging enable
logging asdm informational
mtu Inside 1500
mtu outside 1500
mtu management 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (Inside) 0 access-list 101
nat (Inside) 1 0.0.0.0 0.0.0.0
static (Inside,outside) tcp X.X.X.X ftp FTPServer ftp netmask 255.255.255.255
static (Inside,outside) tcp X.X.X.X https MailServer https netmask 255.255.255.255
static (Inside,outside) tcp X.X.X.X pptp VPNServer pptp netmask 255.255.255.255
static (Inside,outside) tcp X.X.X.X smtp MailServer smtp netmask 255.255.255.255
access-group outside_Access_in in interface outside
route outside 0.0.0.0 0.0.0.0 199.255.30.89 1
route Inside 10.1.1.0 255.255.255.0 192.168.1.30 2
route Inside 10.1.10.0 255.255.255.252 192.168.1.30 2
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.252.0 Inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 192.168.1.0 255.255.252.0 Inside
telnet timeout 5
ssh timeout 5
console timeout 0
management-access Inside
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 192.168.X.X source Inside prefer
webvpn
group-policy DfltGrpPolicy attributes
vpn-idle-timeout none
vpn-filter value NAT0
vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
pre-shared-key LOGIS2SLOGIS2SLOGIS2S
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
inspect pptp
inspect http
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:12b6abd11e12da8ecc8bcb3298f62ca7
: end

Re: ASA Routing problem

Good news, I found the problem

Adding those routes to the NAT 0 did the trick

Sent from Cisco Technical Support iPhone App

755
Views
0
Helpful
17
Replies