Cisco Support Community
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member


i have two public IP address that needs to be configured to ASA5505-UL-BUN-K9 of which are these and respectively and are in the same network and both has internet.the is the IP given to my clients to access the systems and other databases outside.the is the interface 2 but it does not question is iam trying to configure these IP but it does not work with this ASA but when i configure with only one public IP it works well.Anyone to with an idea,help me please am stuck>>>> below is the sample of one IP but how could two IP be configured?

ASA Version 9.0(1)
hostname ......
enable password .......encrypted
passwd ......encrypted
interface Ethernet0/0
switchport access vlan 2
interface Ethernet0/1
interface Ethernet0/2
interface Ethernet0/3
interface Ethernet0/4
interface Ethernet0/5
interface Ethernet0/6
interface Ethernet0/7
interface Vlan1
nameif inside
security-level 100
ip address
interface Vlan2
nameif outside
security-level 0
ip address
ftp mode passive
clock timezone EAT 3
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
object network lan
object network s1
access-list out1 extended permit ip any any
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source static s1 interface
nat (inside,outside) source dynamic lan interface
access-group out1 in interface outside
route outside 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http inside
http inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
ssh timeout 5
console timeout 0

dhcpd auto_config outside


Consult your ISP to verify

Consult your ISP to verify which of the two address blocks is directly connected on the ISP router and which one is routed to your firewall. The latter addresses can be used on your ASA as a staticly NATed entry.

Community Member

Hi Peter,

Hi Peter,

the ISP told me that both IP and are connected to ISP router and are having the Internet and if i put to my computer one by one both are having internet.

Community Member

This is because we need both

This is because we need both these two IP to be used on our side of which the should be nated and accessibly outside,and the is the  IP going to the internet and we use it for sms platform and short codes from different mobile service provider. 

Please see attached scenario.


Any progress?

Any progress?

CreatePlease to create content