Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

asa5510 Split tunnel config kills VPN entirely

Activating a split-tunnel configuration managed to kill VPN access to hosts on the inside interface completely.  (as in a logged in VPN user can no longer ping or RDP to a host on the inside)  Did I miss something at 4am? Bug in 9.0(2) ?  It worked before adding the split-tunnel config...

redacted config: 

Result of the command: "show run"

: Saved
:
ASA Version 9.0(2) 
!
hostname redacted
enable password redacted/ encrypted
names
ip local pool ippool3 192.168.10.1-192.168.10.254 mask 255.255.255.0
ip local pool ippool150 172.16.1.150-172.16.1.200 mask 255.255.255.0
!
interface Ethernet0/0
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/1
 nameif inside
 security-level 100
 ip address 172.16.1.1 255.255.255.0 
!
interface Ethernet0/2
 nameif outside
 security-level 0
 ip address 6.76.156.30 255.255.255.240 
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 management-only
 nameif management
 security-level 100
 ip address 10.10.10.3 255.255.255.0 
!
ftp mode passive
access-list split standard permit 172.16.1.0 255.255.255.0 
pager lines 24
logging enable
logging asdm informational
mtu management 1500
mtu outside 1500
mtu inside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-645-206.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
nat (any,outside) after-auto source dynamic any interface
route outside 0.0.0.0 0.0.0.0 6.76.156.17 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.10.0 255.255.255.0 management
http 0.0.0.0 0.0.0.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec security-association pmtu-aging infinite
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ca trustpool policy
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication crack
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 20
 authentication rsa-sig
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 30
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 40
 authentication crack
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 60
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 70
 authentication crack
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 80
 authentication rsa-sig
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 90
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 100
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 120
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 130
 authentication crack
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 140
 authentication rsa-sig
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 150
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 65535
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
group-policy analyticDEV internal
group-policy analyticDEV attributes
 vpn-tunnel-protocol ikev1 
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value split
username redacted password redacted encrypted
username redacted password redacted encrypted
tunnel-group analyticDEV type remote-access
tunnel-group analyticDEV general-attributes
 address-pool ippool150
 default-group-policy analyticDEV
tunnel-group analyticDEV ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
  inspect icmp 
  inspect icmp error 
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
Cryptochecksum: redacted
: end

3 REPLIES
Super Bronze

Hi, You dont seem to have any

Hi,

 

You dont seem to have any NAT0 configuration and that means that all traffic matches the Dynamic PAT configuration and because of that the connection attempts fail the NAT RPF check.

 

I would suggest that you start with changing your VPN pool to something else than the LAN network.

 

Since you have another VPN Pool configured and not in use you could do the following

 

tunnel-group analyticDEV general-attributes
 address-pool ippool3

 

Then configure NAT0

 

object network VPN-POOL
 subnet 192.168.10.0 255.255.255.0

 

object network LAN
 subnet 172.16.1.0 255.255.255.0

 

nat (inside,outside) source static LAN LAN destination static VPN-POOL VPN-POOL

 

These changes to my understanding should correct your problem

 

Hope this helps :)

 

 

EDIT: Corrected the typo where I mentioned NAT Pool instead of VPN Pool

 

- Jouni

 

 

 

New Member

Well that didn't seem to help

Well that didn't seem to help.  Any other ideas?

Super Bronze

Hi, Well the suggest

Hi,

 

Well the suggest configurations should do the trick. We really need more information about what the situation is when you are connected with the VPN Client.

 

Can you show us the Secured Routes (or similiar) section of the VPN Client when its connected? Could you also show the Statistics page after you have tested connectivity so we can see if any traffic is actually forwarded to the VPN connections.

 

You could also use the following commands on the ASA when you have connected with the VPN Client and have tested some connections

 

show crypto ipsec sa

 

show nat

 

Have you tried connections to multiple hosts on the LAN so that the problem is not for example a single server that you cannot access?

 

Also, just to make sure, can you list the following configurations again

 

show run object network

 

show run nat

 

show run group-policy

 

show run tunnel-group

 

- Jouni

40
Views
0
Helpful
3
Replies