Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

ASDM 6.1.5 and Java 6 update 10

I just updated my Sun Java from 1.6u7 to 1.6u10. Now when I try to launch ASDM 6.1.5 on my ASA 5520 running 8.0(4) I get "ASDM cannot be loaded. Click OK to exit ASDM. Unconnected sockets not implemented." My only option is to click OK and the java app goes away.

The output of java console is:

Server Version = 6.1(5)

Server Launcher Version = 1.5.30, size = 319488 bytes

invoking SGZ Loader..

Cache location = C:/Documents and Settings/thunt.GENSCAPE/.asdm/cache

Cannot connect

I know I can just downgrade java and I'll be fine but was curious if anyone else had run into this and if they had found a fix.

I have deleted my .asdm folders but no joy. This happens on fedora 9 and Windows XP SP3.

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: ASDM 6.1.5 and Java 6 update 10

same problem; working good with Java update 7

uninstalled Java update 11 from control panel

ASDM now works again

flashed asdm-61551.bin

ASDM still working

updated Java to 11 once again

ASDM still working

DEFINETLY SOLVED

and thanks everybody else for the tips

9 REPLIES

Re: ASDM 6.1.5 and Java 6 update 10

I had the same problem too when I upgraded to Java 1.6 Update 10. I downgraded Java and had no problem connecting to ASDM. I would also be curious to know if there is a known work around for this.

Mark

New Member

Re: ASDM 6.1.5 and Java 6 update 10

Cisco has released ASDM 6.1(5)51

Update ASDM to 6.1(5)51 if your os level can take it. I think you have to have at least 8.0.1 but verify.

New Member

Re: ASDM 6.1.5 and Java 6 update 10

I am having the same issue with Java 6 Update 10 when connecting to a FWSM with ASDM 5.2(4)F. Running Vista SP1. Other versions of Java 6 worked fine. Something in Update 10 broke ASDM. It works sometimes if I launch the applet from the FWSM web interface. It does not work from ASDM Launcher.

Now I can't find a place to download Java 6 Update 7. Anyone want to share a download link?

New Member

Re: ASDM 6.1.5 and Java 6 update 10

New Member

Re: ASDM 6.1.5 and Java 6 update 10

You can find the current and many previous versions of Java on filehippo.com

http://filehippo.com/download_java_runtime/

New Member

Re: ASDM 6.1.5 and Java 6 update 10

I too have been having the same problem. I upgraded ASDM to 6.15 w/o any luck. So I went to my Windows Add/Remove Programs, un-installed the Java 6 to 10 Upgrade, and now my ASDM is working.

New Member

Re: ASDM 6.1.5 and Java 6 update 10

In case anyone cares (I see no activity from Cisco on this on any of the other half dozen threads on the same subject). The problem still exists in Java 6 update 11.

New Member

Re: ASDM 6.1.5 and Java 6 update 10

Cisco has released ASDM 6.1(5)51

Update ASDM to 6.1(5)51 if your os level can take it. I think you have to have at least 8.0.1 but verify.

New Member

Re: ASDM 6.1.5 and Java 6 update 10

same problem; working good with Java update 7

uninstalled Java update 11 from control panel

ASDM now works again

flashed asdm-61551.bin

ASDM still working

updated Java to 11 once again

ASDM still working

DEFINETLY SOLVED

and thanks everybody else for the tips

3077
Views
0
Helpful
9
Replies
CreatePlease to create content