Cisco Support Community
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

ASDM 6.2(1) appears to be very buggy


Several months ago we upgraded our ASA firewalls to v8.2(1) and along with it the ASDM to v6.2(1).

Since then we have had nothing but problems with the GUI. It regularly freezes and crashes, and its general responsiveness is sluggish to say the least.

Is anyone else experiencing these problems ? Could it be a java memory / cache issue ?

The IOS seems to be stable enough and we can still make the necessary config changes through the CLI, but we now rely quite heavily on the GUI due to its relative ease of use.

Community Member

Re: ASDM 6.2(1) appears to be very buggy


I have not had severe issues with ASDM 6.2(1). I would try a different Java version (ASDM 5.2(4) was very sensitive what the java version was concerned).

Java Version 6 (Update 7) is working best for me for both 6.2(1) and 5.2(4).

A sluggish interface might also be the result of lacking resources on the PC.


Community Member

Re: ASDM 6.2(1) appears to be very buggy

I am also experiencing some major issues with ASDM 6.2. The program crashes very regularly on me. Almost every time I click on something that would causes a popup window to appear, the program just shuts down. I can not see an error in the java console because when the program crashes, so does the console. I have tried uninstalling, then reinstalling various versions of Java (version 6, updates 18,20 and 22) with no success. Rebooting the computer does nothing. I even uninstalled my virus scanner, with no change in the behaviour. The ASDM is completely useless to me in this state. Does anybody have the same problem? Can anybody help me?



Cisco Employee

Re: ASDM 6.2(1) appears to be very buggy

Sorry to hear that. I have not heard of this many problems with ASDM. Have you tried another PC/laptop? What browser are you using? You can try firefox.

Try to download the lastest ASA code and upload it to the ASA.


CreatePlease to create content