Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

asdm laucher problem on asa 5510

Hi,

I am having problem lauching my asdm-633, when ever i types in the ip address of ASA5510 into the  browser, i found an error page 404. Below is my run:

:
ASA Version 7.0(6)
!
hostname SubASA
domain-name suburban
enable password AYWIUZP3a2RE5as1 encrypted
names
dns-guard
!
interface Ethernet0/0
nameif inside
security-level 100
ip address 10.10.10.5 255.255.255.0
!
interface Ethernet0/1
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 192.168.2.15 255.255.255.0
management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
boot system disk0:/
ftp mode passive
pager lines 24
mtu inside 1500
mtu management 1500
asdm image disk0:/
no asdm history enable
arp timeout 14400
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
username SubsysASA password ZMbro4mkAe..eLHg encrypted
http server enable
http 192.168.2.0 255.255.255.0 management
http 192.168.1.1 255.255.255.255 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 192.168.2.0 255.255.255.0 management
telnet timeout 5
ssh timeout 5
console timeout 0
Cryptochecksum:b85119757d17d17efa98ef247656abd3
: end

Thanks in Anticipation?

16 REPLIES
Cisco Employee

Re: asdm laucher problem on asa 5510

Hi Tunde,

Make sure you specifiy a valid ASDM image with the 'asdm image' command. The latest ASDM version available for ASA 7.0(6) is ASDM 5.0(9). The command should look like this:

asdm image disk0:/asdm509.bin

If you want to use ASDM 6.3(3), you'll need to upgrade the ASA to at least 8.0

Hope that helps.

-Mike

Community Member

Re: asdm laucher problem on asa 5510

Hi Mike,

I tried using the old asdm506 that came with it, i can now log on using the web browser, but when i typed in my credential into the asdm dialog box, it will show lauchings status, but it will later disappear without bringing up the  asdm configuartion interface.

Thanks In Anticipations!

Re: asdm laucher problem on asa 5510

Please attach a copy of the ''sh ver'' where it shows both the image and the ASDM version.

Federico.

Community Member

Re: asdm laucher problem on asa 5510

This is the output of sho version:

SubASA# sho ver

Cisco Adaptive Security Appliance Software Version 7.0(6)
Device Manager Version 5.0(6)

Compiled on Tue 22-Aug-06 13:22 by builders
System image file is "disk0:/asa706-k8.bin"
Config file at boot was "startup-config"

SubASA up 4 mins 22 secs

Hardware:   ASA5510-K8, 256 MB RAM, CPU Pentium 4 Celeron 1600 MHz
Internal ATA Compact Flash, 256MB
BIOS Flash AT49LW080 @ 0xffe00000, 1024KB

Encryption hardware device : Cisco ASA-55x0 on-board accelerator (revision 0x0)
                             Boot microcode   : CNlite-MC-Boot-Cisco-1.2
                             SSL/IKE microcode: CNlite-MC-IPSEC-Admin-3.03
                             IPSec microcode  : CNlite-MC-IPSECm-MAIN-2.04
0: Ext: Ethernet0/0         : address is 000a.b89c.defc, irq 9
1: Ext: Ethernet0/1         : address is 000a.b89c.defd, irq 9
2: Ext: Ethernet0/2         : address is 000a.b89c.defe, irq 9
3: Ext: Not licensed        : irq 9
4: Ext: Management0/0       : address is 000a.b89c.df00, irq 11
5: Int: Not licensed        : irq 11
6: Int: Not licensed        : irq 5

Licensed features for this platform:
Maximum Physical Interfaces : 4
Maximum VLANs               : 10
Inside Hosts                : Unlimited
Failover                    : Disabled
VPN-DES                     : Enabled
VPN-3DES-AES                : Enabled
Security Contexts           : 0
GTP/GPRS                    : Disabled
VPN Peers                   : 50

This platform has a Base license.

Serial Number: JMX1045K12N
Running Activation Key: 0x8c2e0c48 0xf4c1a8a9 0x3c328908 0x96685cfc 0x473ee992
Configuration register is 0x7
Configuration has not been modified since last system restart.

Awaitng your responds soon!

Thanks

Cisco Employee

Re: asdm laucher problem on asa 5510

Hello,

What version of Java you have? Can you match the Java on your PC to the ones

specified in the release notes and see if that helps?

http://www.cisco.com/en/US/docs/security/asa/asa70/asdm50/release/notes/rn50

6.html#wp231810

Regards,

NT

Cisco Employee

Re: asdm laucher problem on asa 5510

Hi Tunde,

When u get the box for entering your credentials in the ASDM launcher, there will be a java button at the bottom right corner in the shape of a cup telling show java console. Click on that and u will get a display of java console . On that press 5 to set the trace level. Now enetr your credentials in the ASDM launcher and click ok. can you copy and paste the logs that come on the java console so that we can see if there is any exception. Also tell me what java version and update are you using.

Regards

Rahul

Community Member

Re: asdm laucher problem on asa 5510

Hi,

have you disabled your pop-up blocker? That can also cause some problems. Otherwise configure the ASA with CLI until you can set the permitted admin network and IP address. Are you directly connected to the ASA? Or is there another Firewall in the infrastructure?

greatings Martin

Community Member

Re: asdm laucher problem on asa 5510

Hi All,

I have ful access to the ASA, its on my table,no other firewall is between us.

Below show the erro log on the Java Console:


Java Plug-in 1.6.0_21
Using JRE version 1.6.0_21-b07 Java HotSpot(TM) Client VM
User home directory = C:\Documents and Settings\Tunde Kushimo
----------------------------------------------------
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
l:   dump classloader list
m:   print memory usage
o:   trigger logging
q:   hide console
r:   reload policy configuration
s:   dump system and deployment properties
t:   dump thread list
v:   dump thread stack
x:   clear classloader cache
0-5: set trace level to
----------------------------------------------------


INFO: Cannot read preferences file C:/Documents and Settings/Tunde Kushimo/.asdm/data/preferences.conf.
Exception in thread "SGZ Loader: launchSgzApplet" java.lang.ArrayIndexOutOfBoundsException: No such child: 0
at java.awt.Container.getComponent(Unknown Source)
at symantec.itools.c.ab.getComponent(Unknown Source)
at java.awt.Component.calculateCurrentShape(Unknown Source)
at java.awt.Component.applyCurrentShape(Unknown Source)
at java.awt.Component.mixOnShowing(Unknown Source)
at java.awt.Container.mixOnShowing(Unknown Source)
at java.awt.Component.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at symantec.itools.c.ab.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at symantec.itools.c.ab.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Window.addNotify(Unknown Source)
at java.awt.Frame.addNotify(Unknown Source)
at java.awt.Window.show(Unknown Source)
at com.cisco.pdm.PDMApplet.start(Unknown Source)
at t.run(DashoA14*..:407)

Community Member

Re: asdm laucher problem on asa 5510

Hi Rahul,

Below is the error log after pressing for the trace level:

Java Web Start 1.6.0_21
Using JRE version 1.6.0_21-b07 Java HotSpot(TM) Client VM
User home directory = C:\Documents and Settings\Tunde Kushimo
----------------------------------------------------
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
m:   print memory usage
o:   trigger logging
p:   reload proxy configuration
q:   hide console
r:   reload policy configuration
s:   dump system and deployment properties
t:   dump thread list
v:   dump thread stack
0-5: set trace level to
----------------------------------------------------
Application Logging Started at Sat Sep 04 10:55:23 VET 2010
---------------------------------------------
Local Launcher Version = 1.5.31
Local Launcher Version Display = 1.5(31)
Trace level set to 5: all ... completed.
OK button clicked
Trying for ASDM Version file; url = https://192.168.2.15/admin/
network: Connecting https://192.168.2.15/admin/version.prop with proxy=DIRECT
network: Connecting socket://192.168.2.15:443 with proxy=DIRECT
security: Loading Root CA certificates from C:\Program Files\Java\jre6\lib\security\cacerts
security: Loaded Root CA certificates from C:\Program Files\Java\jre6\lib\security\cacerts
security: Loading SSL Root CA certificates from C:\Program Files\Java\jre6\lib\security\cacerts
security: Loaded SSL Root CA certificates from C:\Program Files\Java\jre6\lib\security\cacerts
security: Loading Deployment SSL certificates from C:\Documents and Settings\Tunde Kushimo\Application Data\Sun\Java\Deployment\security\trusted.jssecerts
security: Loaded Deployment SSL certificates from C:\Documents and Settings\Tunde Kushimo\Application Data\Sun\Java\Deployment\security\trusted.jssecerts
security: Loading certificates from Deployment session certificate store
security: Loaded certificates from Deployment session certificate store
security: Loading certificates from Internet Explorer ROOT certificate store
security: Loaded certificates from Internet Explorer ROOT certificate store
security: Checking if certificate is in Deployment denied certificate store
security: Checking if certificate is in Deployment session certificate store
security: Checking if SSL certificate is in Deployment permanent certificate store
Server Version = 5.0.6
Server Launcher Version = 1.2.01, size = 260096 bytes
Launcher version checking is successful.
invoking SGZ Loader..
Cache location = C:/Documents and Settings/Tunde Kushimo/.asdm/cache
network: Connecting https://192.168.2.15/admin/pdm.sgz with proxy=DIRECT
network: Connecting socket://192.168.2.15:443 with proxy=DIRECT
*** ASDM running in standlone app mode. ****
network: Connecting https://192.168.2.15/admin/exec/show%20version/perfmon%20interval%2010/show%20curpriv/show%20asdm%20sessions/show%20mode/show%20firewall/changeto%20system/show%20admin-context with proxy=DIRECT
network: Connecting socket://192.168.2.15:443 with proxy=DIRECT
network: Connecting https://192.168.2.15/admin/exec/show%20version/perfmon%20interval%2010/show%20curpriv/show%20asdm%20sessions/show%20mode/show%20firewall/changeto%20system/show%20admin-context with proxy=DIRECT
network: Connecting socket://192.168.2.15:443 with proxy=DIRECT
network: Connecting https://192.168.2.15/admin/exec/show%20module with proxy=DIRECT
network: Connecting socket://192.168.2.15:443 with proxy=DIRECT
network: Connecting https://192.168.2.15/admin/exec/show%20module with proxy=DIRECT
network: Connecting socket://192.168.2.15:443 with proxy=DIRECT
INFO: Cannot read preferences file C:/Documents and Settings/Tunde Kushimo/.asdm/data/preferences.conf.
Calling hideDMLauncherWindow...
Hiding the login window
Exception in thread "SGZ Loader: launchSgzApplet" java.lang.ArrayIndexOutOfBoundsException: No such child: 0
at java.awt.Container.getComponent(Unknown Source)
at symantec.itools.c.ab.getComponent(Unknown Source)
at java.awt.Component.calculateCurrentShape(Unknown Source)
at java.awt.Component.applyCurrentShape(Unknown Source)
at java.awt.Component.mixOnShowing(Unknown Source)
at java.awt.Container.mixOnShowing(Unknown Source)
at java.awt.Component.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at symantec.itools.c.ab.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at symantec.itools.c.ab.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Panel.addNotify(Unknown Source)
at java.awt.Container.addNotify(Unknown Source)
at java.awt.Window.addNotify(Unknown Source)
at java.awt.Frame.addNotify(Unknown Source)
at java.awt.Window.show(Unknown Source)
at com.cisco.pdm.PDMApplet.start(Unknown Source)
at com.cisco.nm.dice.loader.r.run(DashoA19*..:410)

expecting your response Rahul?

Thanks

Cisco Employee

Re: asdm laucher problem on asa 5510

Hi Tunde,

You are hitting a bug. The work around is either to downgradeto java version 6 update 11 or below or upgrade ASDM to version 5.0.9.

This should solve your problem. Hope this post will be useful to you.

Regards,

Rahul

Community Member

Re: asdm laucher problem on asa 5510

Hi Rahul,

I downgraded the java version 6 update 11 and it worked,but there is still another problem: when the asdm page open, another dialog box will pop displaying :

ASDM Is unable to read the configuration from the ASA. Please
check the configuration and your connection and then try again
by clicking the refresh icon.

Kindly assist me on this.

Thanks In Anticipation

Community Member

Re: asdm laucher problem on asa 5510

hi,

you should try the following steps:

  1. click on the file menu, clear your cache
  2. click on the file menu again, clear the internal log buffer
  3. click on the refresh button on the toolbar

regards Martin

Community Member

Re: asdm laucher problem on asa 5510

Hi,


I am still having problem loading my asdm, the error remains:

when the asdm page open, another dialog box will pop displaying :

ASDM Is unable to read the configuration from the ASA. Please
check the configuration and your connection and then try again
by clicking the refresh icon.

Kindly assist me on this.

Thanks In Anticipation

Cisco Employee

Re: asdm laucher problem on asa 5510

Hi Tunde,

You should be able to get this error message corrected if you use jave 6 update 7. Do tell me how it goes.

Regards,

Rahul

Cisco Employee

Re: asdm laucher problem on asa 5510

Get the latest ASDM for the ASA code you are running.

There are known defects that are resolved:

CSCsx39786

CSCsv12681

ASA code: http://tools.cisco.com/squish/10C815

ASDM image: http://tools.cisco.com/squish/a5338C

Also check this link to troubleshoot the problem: https://supportforums.cisco.com/docs/DOC-13012

-KS

Community Member

Re: asdm laucher problem on asa 5510

Hi,

I have resolved the issue by installing J2SE 5.0 Update 22.

It working like a  breeze now.

Thanks Guys!!!!!!!!!!!!!!!!!!!!!

3170
Views
0
Helpful
16
Replies
CreatePlease to create content