Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ASDM or SSH cannot login

ASA Version 8.0(3)

ASDM 6.11

Cannot login to an ASA 5520 using asdm or SSH just hangs on the login screen. This has been working fine for the last few months. I can still connect to the ASA via telnet from the one permitted ip address. Do I need to enter a 'crypto key generate rsa' command?

There have been no recent changes to the device is this something that can break or needs renewing periodically?

As always thanks for your help.

2 REPLIES

Re: ASDM or SSH cannot login

Yes you need to create a key for any secure method of administration, such as ssh or asdm.

PIX(config)#hostname PIXOne

PIXOne(config)#domain-name mydomain.com

PIXOne(config)#ca generate rsa key 1024

PIXOne(config)#ssh time-out 60

PIXOne(config)#ssh 0.0.0.0 0.0.0.0 inside

PIXOne(config)#username somedude password MySeCrEtPaSsWoRd

New Member

Re: ASDM or SSH cannot login

Thank you - I'm still not certain what the problem was - the ASDM and SSH had been working on this device and just failed one morning with no changes having been made to the config. I backed up the running config and copied it to a spare ASA ssh and ASDM worked fine on that. I rebooted the faulty asa this morning and everything is fine again can use ASDM and SSH to it. Would applying your command:

PIXOne(config)#ca generate rsa key 1024

have saved me the bother of the the reboot?

714
Views
0
Helpful
2
Replies