Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
New Member

Assigning IP Address on Cisco 5515 FW

Hello,

I have purchased new Cisco 5515 firewall. I want to assign ip address on interfaces but 'ip address' command is not available under interface section...

Please guide. How to enable this feature.

Everyone's tags (2)
6 REPLIES
Super Bronze

Assigning IP Address on Cisco 5515 FW

Hi,

Have not heard of such a problem before.

I wonder if your ASA is at the moment configured as Transparent for some reason.

To my understanding the ASA5505 model is the only model which doesnt allow to configure IP address under the physical interface as ASA5505 physical interfaces are all Switchports and not Routerports

If you can provide the CLI Configuration we should be able to see easily if the firewall is in Transparent mode for some reason.

To my understanding it should not be this by default.

- Jouni

VIP Green

Re: Assigning IP Address on Cisco 5515 FW

The 5515 does not support IP address configuration on the physical interface so all interface configuration is done on the SVI and the physical ports are assigned to the appropriate VLAN.  For example

int vlan 1

security-level 100

nameif inside

ip add 192.168.1.1 255.255.255.0

int gig0/1

switchport access vlan 1

no shut

--
Please remember to rate and select a correct answer

--

Please remember to rate and select a correct answer
Super Bronze

Assigning IP Address on Cisco 5515 FW

Hi,

Vlan interfaces are only supported on ASASM and ASA5505 to my understanding.

ASA5515-X is like any other ASA with router ports and no switch ports.

- Jouni

VIP Green

Assigning IP Address on Cisco 5515 FW

My bad, I read it as 5505

--
Please remember to rate and select a correct answer

--

Please remember to rate and select a correct answer
New Member

Assigning IP Address on Cisco 5515 FW

Hi,

I think some things missing. Recently i have configured ASA 5512-X with SW, 6 GE Data, 1 GE Mgmt. Here is the below Interface configuration details.

interface GigabitEthernet0/0

description *** Connected to Internet Router-01 ***

nameif outside

security-level 0

ip address x.x.x.x 255.255.254.0 standby x.x.x.x

!

interface GigabitEthernet0/1

description *** Connected to CORE-SW ***

nameif inside

security-level 100

ip address x.x.x.x 255.255.255.248 standby x.x.x.x

!

Regards

Parosh

New Member

Assigning IP Address on Cisco 5515 FW

Hey Jouni,

It worked Man !!!

issue was with the firewall mode. It was set to Transparent Mode.

I changed it to Routed Mode and it started working.

Many thanks for your valuable input !!!!

- Viral Rana

157
Views
5
Helpful
6
Replies
CreatePlease to create content