Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

cannot ping outside hostnames only (IPs work)

Hi, 

 

I have an ASA 5505 at home... I have connected it to my Router/ Wi-fi ap and configured it to get DHCP IP and routes..

 

all works except pinging netbios names on my inside network... 

 

For example, on my outside network (connected to my router) I have a NAS called diskstation. From my inside network I can ping 192.168.1.101 but I cannot ping it using (Diskstation)

 

The odd this if that if I do ping -a 192.168.1.101 it will reply:

 

Pinging DISKSTATION [192.168.1.101] with 32 bytes of data and it replies...

 

Any Ideas?

Everyone's tags (1)
3 REPLIES

hi,did you configure DNS

hi,

did you configure DNS lookup?

dns domain-lookup inside
dns server-group DefaultDNS
 name-server 8.8.8.8

New Member

Hi, If I ping from my inside

Hi,

 

If I ping from my inside network:

C:\Users\user>ping -a 192.168.1.101

Pinging DISKSTATION [192.168.1.101] with 32 bytes of data:
Reply from 192.168.1.101: bytes=32 time=1ms TTL=64
Reply from 192.168.1.101: bytes=32 time=1ms TTL=64
Reply from 192.168.1.101: bytes=32 time=1ms TTL=64
Reply from 192.168.1.101: bytes=32 time=1ms TTL=64

but:

C:\Users\user>ping diskstation
Ping request could not find host diskstation. Please check the name and try agai
n.

 

DNS seems correct to me:

 

 sh run
: Saved
:
ASA Version 9.1(5)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute
!
ftp mode passive
dns domain-lookup inside
dns server-group DefaultDNS
 name-server 192.168.1.254
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network Belkin
 host 192.168.1.254
object-group protocol DM_INLINE_PROTOCOL_1
 protocol-object ip
 protocol-object udp
 protocol-object tcp
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group service DM_INLINE_TCP_1 tcp
 port-object eq www
 port-object eq https
object-group service DM_INLINE_SERVICE_1
 service-object tcp destination eq netbios-ssn
 service-object udp destination eq netbios-dgm
 service-object udp destination eq netbios-ns
access-list inside_access_in extended permit object-group DM_INLINE_PROTOCOL_1 any any
access-list inside_access_in extended permit object-group TCPUDP 192.168.2.0 255.255.255.0 any
access-list inside_access_in extended permit icmp 192.168.2.0 255.255.255.0 interface outside
access-list inside_access_in extended permit icmp interface outside 192.168.2.0 255.255.255.0
access-list global_access extended permit tcp any interface outside object-group DM_INLINE_TCP_1
access-list global_access extended permit icmp any any
access-list global_access extended permit object-group DM_INLINE_SERVICE_1 any any
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-716.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
object network obj_any
 nat (inside,outside) dynamic interface dns
!
nat (inside,outside) after-auto source dynamic any interface dns
access-group inside_access_in in interface inside
access-group global_access global
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.2.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
no ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0

dhcp-client client-id interface outside
dhcpd auto_config outside
!
dhcpd address 192.168.2.5-192.168.2.132 inside
dhcpd auto_config outside interface inside
dhcpd enable inside
!
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
username cisco password 3USUcOPFUiMCO4Jk encrypted privilege 15
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:c03c6115777e59fc29aab285b1faf3be

 

 

 

Hi,Could you issue this

Hi,

Could you issue this command?

>nslookup diskstation

 

Also, make sure you've set up correctly the host file/zone records on your DNS (192.168.1.254).

377
Views
0
Helpful
3
Replies