Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cannot Ping Static Nat public ip in ASA 8.4(2)

I have setup Cisco Asa 8.4 Lab in GNS3 to understand new Nat changes in asa 8.4 because im new to asa.

I have configured one of my internal webserver to static NAT with one public ip. I’m able to access hosted webpage from static public ip 192.168.1.4 means NAT is working fine, the problem here I’m facing i'm not able to ping to Mapped public IP 192.168.1.4 from outside interface sitting on pc (ip 192.168.1.100) which is also connected to same outside network and neither from ASA console but I’m able to ping outside interface ip address which is 192.168.1.3 from pc (192.168.1.100) and from asa console. I’m posting my ASA configuration can anyone help me on this

This how my network topology

Inside Network 192.168.72.0/24 outside Network 192.168.1.0
inside ip 192.168.72.2/24---------------ASA8.4-----------------------outside ip 192.168.1.3/24 (connected to ADSL router 192.168.1.1)


This is how i done static NAT for the internal webserver ip 192.168.72.132 to 192.168.1.4 public ip

#object network myWebServ

#host 192.168.72.132

#nat (inside,outside) static 192.168.1.4

#access-list outsidetoinsidehost extended permit tcp any host 192.168.72.132 eq www
access-list outsidetoinsidehost extended permit object-group DM_INLINE_SERVICE_1 any host 192.168.72.132

# access-group outsidetoinsidehost in interface outside

I have created object-group for icmp services DM_INLINE_SERVICE_1

# object-group service DM_INLINE_SERVICE_1
service-object icmp
service-object icmp echo-reply


-----------------------------------------------------------------------
full config

ASA Version 8.4(2)
!
hostname asafw01
domain-name google.com
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface GigabitEthernet0
nameif outside
security-level 0
ip address 192.168.1.3 255.255.255.0
!
interface GigabitEthernet1
nameif inside
security-level 100
ip address 192.168.72.2 255.255.255.0
!
interface GigabitEthernet2
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet3
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet4
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet5
shutdown
no nameif
no security-level
no ip address
!
ftp mode passive
dns domain-lookup outside
dns server-group DefaultDNS
name-server 8.8.8.8
domain-name google.com
object network internal-192.168.72.0
subnet 192.168.72.0 255.255.255.0
object network myWebServ
host 192.168.72.132
object-group service DM_INLINE_SERVICE_1
service-object icmp
service-object icmp echo-reply
access-list outsidetoinsidehost extended permit tcp any host 192.168.72.132 eq www
access-list outsidetoinsidehost extended permit object-group DM_INLINE_SERVICE_1 any host 192.168.72.132
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-647.bin
no asdm history enable
arp timeout 14400
!
object network internal-192.168.72.0
nat (inside,outside) dynamic interface
object network myWebServ
nat (inside,outside) static 192.168.1.4
access-group outsidetoinsidehost in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.72.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
telnet timeout 5
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
username admin password WJuRUkaiwnVQrwPa encrypted privilege 15
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect ip-options
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
inspect icmp
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
call-home
profile CiscoTAC-1
no active
destination address http https://tools.cisco.com/its/service/odd ... DCEService
destination address email callhome@cisco.com
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
crashinfo save disable
Cryptochecksum:cff1d53897a52c21238cfc92c04f7690
: end


  • Firewalling
1 REPLY
New Member

Cannot Ping Static Nat public ip in ASA 8.4(2)

Hi

Just Check by adding one more service object in your object group

object-group service DM_INLINE_SERVICE_1

service-object icmp

service-object icmp echo-reply

service-object icmp echo

4066
Views
0
Helpful
1
Replies
This widget could not be displayed.