Cisco Support Community
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Super Bronze

Cisco ASA - 8.4(3) - PCTV Not working


I have an ASA 5505 running 8.4(3) at home and I'm banging my head against the wall trying to get the PCTV working from my local ISP.

Basically I open a web page for the service and I can stream all the basic TV channels to my PC screen.

I just simply cant get this working through the ASA.. Ofcourse doesn't help that I know absolutely nothing about voice/video in networking.

My setup regarding ASA configurations are as follows

interface Vlan1

description LAN

nameif LAN

security-level 100

ip address

igmp forward interface WAN


interface Vlan10

description WAN

nameif WAN

security-level 0

ip address dhcp setroute

interface Ethernet0/0

description WAN Access

switchport access vlan 10


interface Ethernet0/1

description PC1


interface Ethernet0/2

description PC2

object network LAN-PAT


nat (LAN,WAN) dynamic interface

access-list LAN-IN extended permit ip any

access-group LAN-IN in interface LAN


I can get the PCTV working if i bypass the ASA. I can for example get the PCTV working on PC2 if I simply change the port Ethernet0/2 to access vlan 10. So theres just simply something that I havent configured on the ASA or the ASA doesnt support something?

I took a capture from my PC2 just as I opened the browser and connected to the PCTV url (opens our local channe 1 right away)

Only thing I can see in the capture at that point is:

- V2 Membership report / Join group

- Right after a remote host from the ISP networks starts sending the stream with the destination port udp/2000 with the destination address of

Any suggestions on what I could check in my configuration? Or is there something that I have simply configured wrong already on the partial configuration shown above?

Please ask for any additional information you might need.

- Jouni

Super Bronze

Re: Cisco ASA - 8.4(3) - PCTV Not working


If I try to configure the following in the ASAs WAN interface

ASA(config-if)# igmp join-group

I get and message

%Exclude mode join on WAN ignored for SSM group

And I have no idea what it means.


When I have "debug igmp" on I can every now and then see messages: "Report has illegal group address x.x.x.x" just after a "Reveived v2 report on LAN from y.y.y.y for x.x.x.x"

Super Bronze

Cisco ASA - 8.4(3) - PCTV Not working

Oh well,

This is just stupid.

Found this on a Cisco document:


FWSM/ASA does not support 232.x.x.x/8  subnet as a group number as it is reserved for ASA SSM. So FWSM/ASA  does not allow this subnet to be used or traversed and mroute does not  get created. But, you can still pass this multicast traffic through  ASA/FWSM if you encapsulate it in GRE tunnel.

So basicly no deal for PCTV through with my current setup.

- Jouni


Cisco ASA - 8.4(3) - PCTV Not working

Can you NAT multicast?     ;-)

Please remember to rate useful posts, by clicking on the stars below.

CreatePlease to create content