Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco PIX 515E Firewall Basic Configuration

Hi

My topology is simple:

My PC <------> PIX <-------> My Cable modem Motorola <------> ISP (internet)

I follow the steps on this video tutorial, and in theory it should do the trick. I dont know what am I doing wrong.

https://www.youtube.com/watch?v=D6E2kFPwvTo

On the physical setup side:

1) If I connect the ethernet cable from my Motorola cable modem to my PIX Public int e0, everything looks fine, the network light blinks in green, so is passing data through it and there is connectivity. Same for the ACT light in green and it blinks in the back of the PIX. Ok, so far so good.

2) Now, the ethernet cable that goes from the PIX Private int e1 to my PC, look like something is not right there, all the lights look ok,

except for the light ACT in the back of the PIX, it blinks but not at the same speed as the Public int e0 ACT light, it blinks way slower. I think that indicates that data is not passing through correctly, I could be wrong.

3) My ISP asign my IP address through dhcp server

4) I connect to my ISP using cable modem, the model is a Motorola Surf Board SB5100i, with enable DHCP server option turn ON

5) And I want to enale NAT, so my real public IP address assigned to me via ISP can be hide from let say hackers on the internet.

My configuration on PIX:

I dont want to put my information about my real ip address or gateway or ranges that my ISP assign me for security reasons, but if you guys tell me that you need that info in order to help me, I would put it. Or any other information.

This is what I got so far:

PART 1: (Everything looks fine, no errors)

config t

int e0

ip address dhcp setroute

nameif outside

no shut

int e1

ip address 172.16.1.1 255.255.255.0

nameif inside

no shut

exit

sh int ip brief (shows all interfaces are UP and with IP's assigned properly, exactly the same as the video tutorial)

PART 2: (Everything looks fine, no errors)

global (outside) 1 inter

nat (inside) 1 172.16.1.0 255.255.255.0

exit

show route

But final result, I got no internet connection. If I go to my browser and go to google or other website there is no connection at all.

And finally I want to enable encryption to my internet connection, kinda like a vpn, but I dont know if PIX is able to do that via hardware. If not I got a cisco vpn 3000 concentrator. I think that one would do the trick for encryption, but I have to learn how to configure it. But that one is for another post I think.

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Cisco PIX 515E Firewall Basic Configuration

Sounds like you are missing DNS setting on your local PC.

Value our effort and rate the assistance!
3 REPLIES
Silver

Cisco PIX 515E Firewall Basic Configuration

Sounds like you are missing DNS setting on your local PC.

Value our effort and rate the assistance!
New Member

Cisco PIX 515E Firewall Basic Configuration

Yep that was the problem. I did not configure my PC IP, subnetmask, gateway, dns.

Now is working

Thanks

Silver

Cisco PIX 515E Firewall Basic Configuration

Great to know!!!

Value our effort and rate the assistance!

Value our effort and rate the assistance!
319
Views
5
Helpful
3
Replies
CreatePlease to create content