Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

creating static route help - VPN in play

I can't seem to create a static route based on following criteria.  Can anyone help?  ASA 5505 and VPN tunnel is in play:

Interesting Traffic = your single host is trying to talk to our side.

Will need to create a static, 1:1 policy NAT of interesting traffic to host 10.1.12.164

Will need to make an IPSec ACL from host 10.1.12.164 to 192.168.50.0/24
Will need to make an IPSec ACL from host 10.1.12.164 to 10.10.3.0/24

 

Can anyone tell me the commands to do this? Start of my config:

 

interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!             
interface Vlan2
 nameif outside

 

Thank you,

Derek

6 REPLIES

Hi,Could you please explain

Hi,

Could you please explain more about your query?

 

Regards

Karthik

New Member

The 3rd party software vendor

The 3rd party software vendor gave me those configs..  I really have no other details.  The current config is above..

Super Bronze

Hi, I am not sure I follow.

Hi,

 

I am not sure I follow. There is mention of static routes, Static Policy NAT and VPN ACLs?

 

For starters you should not need to modify/add any static routes when we are talking about a L2L VPN. VPN connections are 99% of the time formed through the interface that has the default route out of the network so you wont need to add additional routes for remote networks typically.

 

As to the Static Policy NAT or NAT0 configuration we would need to know both your current ASA software level (since it determines the configuration format of the NAT) and we would also need to confirm that your local IP address for the VPN connection is 10.1.12.164? and the remote networks are 192.168.50.0/24 and 10.10.3.0/24?

 

Let us know the software level of the ASA.

 

- Jouni

New Member

: Saved:ASA Version 8.2(5)

: Saved
:
ASA Version 8.2(5)
!
hostname ciscoasa
domain-name dfm.local
enable password ******* encrypted
passwd ******** encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!             
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!             
interface Vlan2
 nameif outside
 security-level 0
 pppoe client vpdn group AT&T
 ip address 99.24.60.86 255.255.255.255 pppoe setroute
!             
banner motd # DFM.  Unauthorized access to this device is prohibited!#
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns domain-lookup inside
dns server-group DefaultDNS
 name-server 68.94.156.1
 name-server 68.94.157.1
 domain-name dfm.local
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_access_in extended permit ip any any
access-list test extended permit udp any host 192.168.1.1
access-list test extended permit udp host 192.168.1.1 any
access-list test2 extended permit udp any any eq bootps
access-list test2 extended permit udp any any eq bootpc
access-list vpn extended permit ip host 10.1.12.164 192.168.50.0 255.255.255.0
access-list vpn extended permit ip host 10.1.12.164 10.10.3.0 255.255.255.0
access-list nat extended permit ip host 192.168.1.2 192.168.50.0 255.255.255.0
access-list out extended permit tcp any interface outside eq 3389
access-list out extended permit tcp any interface outside eq www
pager lines 24
logging enable
logging buffered debugging
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 3389 192.168.1.2 3389 netmask 255.255.255.255
static (inside,outside) tcp interface www 192.168.1.2 www netmask 255.255.255.255
static (inside,outside) 10.1.12.164  access-list nat
access-group outside_access_in in interface outside control-plane
access-group out in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set vpn esp-aes-256 esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside 10 match address vpn
crypto map outside 10 set pfs
crypto map outside 10 set peer 216.117.40.14
crypto map outside 10 set transform-set vpn
crypto map outside 10 set security-association lifetime seconds 28800
crypto map outside interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 1
 authentication pre-share
 encryption aes-192
 hash sha     
 group 2      
 lifetime 43200
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
vpdn group AT&T request dialout pppoe
vpdn group AT&T localname kjsdhkjshfkjfh
vpdn group AT&T ppp authentication pap
vpdn username kjdhkjdhfskjdfhksjdhf password ***** store-local
dhcpd dns 68.94.156.1 68.94.157.1
!             
dhcpd address 192.168.1.10-192.168.1.41 inside
dhcpd dns 68.94.156.1 68.94.157.1 interface inside
dhcpd enable inside
!             
              
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn    
tunnel-group 216.117.40.14 type ipsec-l2l
!             
class-map inspection_default
 match default-inspection-traffic
!             
!             
policy-map type inspect dns preset_dns_map
 parameters   
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp
!             
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:1dc94019ec9548ad9b7eb9fb54121ceb
: end  

 

Super Bronze

Hi, The Static Policy NAT

Hi,

 

The Static Policy NAT seems to be correct but its missing the other destination network. You can add the ACL line

 

access-list nat extended permit ip host 192.168.1.2 10.10.3.0 255.255.255.0

 

- Jouni

New Member

Jouni, You asked for this

Jouni,

 

You asked for this earlier and I forgot to give this to you:

 

Remote Peer IP: 216.117.40.14
Remote Network: 192.168.50.0/24, 10.10.3.0/24

 

106
Views
0
Helpful
6
Replies