Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

dynamic PAT on ASA 9.1 unsuccessful

Hi,

I got stuck setting up dynamic PAT on a 5525-X, IOS 9.1.

The setup is as following:
- the ASA is supposed to route a /28 over a /29 linknet
- g0/0 is the outside interface, connecting to provider core
- ASA uses last address on /29 (provider uses static route to route /28 to said adress)
- static route 0.0.0.0/0.0.0.0 on ASA points everything at the first address of the linknet (.17), hosted on the provider's SVI
- g0/1 uses a number of subinterfaces, to (eventually) route the /28 (to be configured on 0/1.100) and PAT a number of RFC1918 networks to grant them Internet access *via* unused addresses on the /29 (.19, in this case)

I have set up subinterfaces as seen in config below, but can't get out to the Internet on VLAN 200. The downstream switch has VLAN 200 trunked to it correctly and I can ping VLAN 200 gateway successfully (10.196.0.1). The ASA's default route also seems ok, as I can ping 8.8.8.8 from the ASA CLI.

Any tips greatly appreciated, as I run out of ideas..


ciscoasa(config)# sh run
: Saved
:
ASA Version 9.1(2)
!
hostname ciscoasa
enable password xxxxxxxxxx encrypted
names
!
interface GigabitEthernet0/0
 nameif outside
 security-level 0
 ip address 111.222.333.22 255.255.255.248
!
interface GigabitEthernet0/1
 nameif inside
 security-level 100
 no ip address
!
interface GigabitEthernet0/1.90
 vlan 90
 nameif device_management
 security-level 0
 ip address 10.192.0.1 255.255.255.0
!
interface GigabitEthernet0/1.100
 vlan 100
 nameif main
 security-level 0
 no ip address
!
interface GigabitEthernet0/1.110
 vlan 110
 nameif vpn
 security-level 0
 ip address 10.194.0.1 255.255.254.0
!
interface GigabitEthernet0/1.120
 vlan 120
 nameif rfc1
 security-level 0
 ip address 10.194.2.1 255.255.254.0
!
interface GigabitEthernet0/1.130
 vlan 130
 nameif rfc2
 security-level 0
 ip address 10.194.4.1 255.255.254.0
!
interface GigabitEthernet0/1.200
 vlan 200
 nameif student
 security-level 0
 ip address 10.196.0.1 255.255.252.0
!
interface GigabitEthernet0/1.210
 vlan 210
 nameif guest
 security-level 0
 ip address 10.196.4.1 255.255.252.0
!
interface GigabitEthernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/4
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/5
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/6
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/7
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 management-only
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
boot system disk0:/asa912-smp-k8.bin
ftp mode passive
object network services_public
 host 111.222.333.21
object network guest_private
 subnet 10.196.4.0 255.255.252.0
object network management_private
 subnet 10.192.0.0 255.255.255.0
object network student_public
 host 111.222.333.19
object network student_private
 subnet 10.196.0.0 255.255.252.0
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu device_management 1500
mtu main 1500
mtu vpn 1500
mtu rfc1 1500
mtu rfc2 1500
mtu student 1500
mtu guest 1500
mtu management 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-713.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
nat (student,outside) source dynamic student_private student_public
route outside 0.0.0.0 0.0.0.0 111.222.333.17 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
dhcpd dns 111.222.1.1 111.222.1.2
!
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ssl encryption rc4-sha1 aes128-sha1 aes256-sha1 3des-sha1
username admin password EoGC0ChIqyj0NIb5 encrypted
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:9406632d0fab8fd1d99fe845393e7641
: end
ciscoasa(config)#


I tried to PAT student_private onto the outside interface (.22), but also without luck:/

Any tips much appreciated!

R.

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Most of your internal

Most of your internal networks have a security-level of 0. So by default you can't communicate to outside which also has a security-level of 0.

As these are all internal networks, I would give them quite high security-levels. 100 if they are equally to inside, 90 or so if they are not of same security-level as inside.

If you end up to still have more then one interface with the same security-level, you'll need to configure the command

same-security-traffic permit inter-interface

 


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
2 REPLIES
VIP Purple

Most of your internal

Most of your internal networks have a security-level of 0. So by default you can't communicate to outside which also has a security-level of 0.

As these are all internal networks, I would give them quite high security-levels. 100 if they are equally to inside, 90 or so if they are not of same security-level as inside.

If you end up to still have more then one interface with the same security-level, you'll need to configure the command

same-security-traffic permit inter-interface

 


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
New Member

Many thanks for the tip,

Many thanks for the tip, Karsten - correcting security levels has done the job!

Best wishes,

R.

145
Views
0
Helpful
2
Replies