Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ERROR: % Incomplete command

Hello,

I have an ASA 5505 that won't take the static or global commands for NAT.

ASA5505# conf t
ASA5505(config)# static
ERROR: % Incomplete command

or

ASA5505# conf t
ASA5505(config)# global
ERROR: % Incomplete command

Sorry I have very little Cisco firewall experience, but isn't the below command valid?

static (inside,outside) 74.1.1.1 10.1.1.1 netmask 255.255.255.255

I am running Cisco Adaptive Security Appliance Software Version 8.3(1).

I also have the base license.  ASA5505-50-BUN-K9

Thanks

  • Firewalling
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: ERROR: % Incomplete command

No, from version 8.3.1 onwards, the NAT statements have completely changed.

Pre 8.3.1:

static (inside,outside) 74.1.1.1 10.1.1.1 netmask 255.255.255.255

Now change to:

object network obj-10.1.1.1

     host 10.1.1.1

     nat (inside,outside) static 74.1.1.1

NAT in version 8.3.1 is divided into 2:

1) Network object NAT (auto NAT)

2) Twice NAT (manual NAT)

Here is more information to get familiarise with the new NAT:

http://www.cisco.com/en/US/docs/security/asa/asa83/configuration/guide/nat_overview.html#wp1122015

Hope that helps.

2 REPLIES
Cisco Employee

Re: ERROR: % Incomplete command

No, from version 8.3.1 onwards, the NAT statements have completely changed.

Pre 8.3.1:

static (inside,outside) 74.1.1.1 10.1.1.1 netmask 255.255.255.255

Now change to:

object network obj-10.1.1.1

     host 10.1.1.1

     nat (inside,outside) static 74.1.1.1

NAT in version 8.3.1 is divided into 2:

1) Network object NAT (auto NAT)

2) Twice NAT (manual NAT)

Here is more information to get familiarise with the new NAT:

http://www.cisco.com/en/US/docs/security/asa/asa83/configuration/guide/nat_overview.html#wp1122015

Hope that helps.

New Member

Re: ERROR: % Incomplete command

Thanks, so much.  Everything makes sense now.  I am no longer confused.  I rolled back to 8.2(2).

1908
Views
0
Helpful
2
Replies