Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

Firewall conf issue........

Hi

Below is Firewall / Switch and my router configurations,

from firewall i am able to ping my LAN pc 172.22.0.10 / 172.22.1.10 and outside ISP 172.23.43.33 and

172.23.43.13 but from my PC unable to ping that out IP's ...................pls. suggest.....

Firewall Configuration

================

PRIMFW# sh run

: Saved

:

ASA Version 8.4(2)

!

hostname SPANCO-PRIM

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Ethernet0/0

nameif outside

security-level 0

ip address 10.10.10.2 255.255.255.0 standby 10.10.10.3

!

interface Ethernet0/1

no nameif

security-level 0

no ip address

!

interface Ethernet0/1.101

description INSIDE1

vlan 101

nameif INSIDE1

security-level 90

ip address 172.22.0.2 255.255.255.0 standby 172.22.0.3

!

interface Ethernet0/1.102

description INSIDE2

vlan 102

nameif INSIDE2

security-level 80

ip address 172.22.1.2 255.255.255.0 standby 172.22.1.3

!

interface Ethernet0/2

shutdown

no nameif

no security-level

no ip address

!

interface Ethernet0/3

description LAN Failover Interface

!

interface Management0/0

nameif management

security-level 100

ip address 192.168.1.1 255.255.255.0

management-only

!

ftp mode passive

clock timezone AST 3

object-group service DM_INLINE_TCP_1 tcp

port-object eq ftp

port-object eq www

port-object eq pop3

port-object eq smtp

object-group-search access-control

access-list global_mpc remark ALL TRAFFIC

access-list global_mpc extended permit tcp any any object-group DM_INLINE_TCP_1

pager lines 24

logging asdm informational

mtu outside 1500

mtu INSIDE1 1500

mtu INSIDE2 1500

mtu management 1500

failover

failover lan unit primary

failover lan interface FAILOVER Ethernet0/3

failover replication http

failover interface ip FAILOVER 192.168.3.1 255.255.255.0 standby 192.168.3.2

monitor-interface INSIDE1

monitor-interface INSIDE2

icmp unreachable rate-limit 1 burst-size 1

asdm history enable

arp timeout 14400

route outside 0.0.0.0 0.0.0.0 10.10.10.1 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

no user-identity enable

user-identity default-domain LOCAL

http server enable

http 192.168.1.0 255.255.255.0 management

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart

crypto ca trustpoint _SmartCallHome_ServerCA

crl configure

crypto ca certificate chain _SmartCallHome_ServerCA

certificate ca 6ecc7aa5a7032009b8cebcf4e952d491

    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130

    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117

    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b

    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504

    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72

    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56

    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043

    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31

    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b

    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20

    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65

    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420

    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329

    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365

    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7

    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597

    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10

    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc

    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b

    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845

    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8

    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced

    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f

    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201

    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868

    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101

    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8

    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777

    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a

    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406

    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973

    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403

    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969

    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b

    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973

    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30

    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603

    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355

    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609

    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80

    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e

    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a

    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc

    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16

    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0

    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8

    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28

    6c2527b9 deb78458 c61f381e a4c4cb66

  quit

crypto ikev2 policy 40

encryption des

integrity sha

group 5 2

prf sha

lifetime seconds 86400

crypto ikev1 policy 20

authentication rsa-sig

encryption aes-256

hash sha

group 2

lifetime 86400

crypto ikev1 policy 30

authentication pre-share

encryption aes-256

hash sha

group 2

lifetime 86400

crypto ikev1 policy 40

authentication crack

encryption aes-192

hash sha

group 2

lifetime 86400

crypto ikev1 policy 50

authentication rsa-sig

encryption aes-192

hash sha

group 2

lifetime 86400

crypto ikev1 policy 60

authentication pre-share

encryption aes-192

hash sha

group 2

lifetime 86400

crypto ikev1 policy 70

authentication crack

encryption aes

hash sha

group 2

lifetime 86400

crypto ikev1 policy 80

authentication rsa-sig

encryption aes

hash sha

group 2

lifetime 86400

crypto ikev1 policy 90

authentication pre-share

encryption aes

hash sha

group 2

lifetime 86400

crypto ikev1 policy 100

authentication crack

encryption 3des

hash sha

group 2

lifetime 86400

crypto ikev1 policy 110

authentication rsa-sig

encryption 3des

hash sha

group 2

lifetime 86400

crypto ikev1 policy 120

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

crypto ikev1 policy 130

authentication crack

encryption des

hash sha

group 2

lifetime 86400

crypto ikev1 policy 140

authentication rsa-sig

encryption des

hash sha

group 2

lifetime 86400

crypto ikev1 policy 150

authentication pre-share

encryption des

hash sha

group 2

lifetime 86400

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd address 192.168.1.2-192.168.1.254 management

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

ssl encryption des-sha1

webvpn

username sanjeev password UzLK4/8fy0bhw2Nl encrypted privilege 1

username cisco password 3USUcOPFUiMCO4Jk encrypted

!

class-map global-class

match access-list global_mpc

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny 

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect ip-options

class global-class

  csc fail-open

!

service-policy global_policy global

prompt hostname context

service call-home

call-home reporting anonymous

call-home

contact-email-addr pradeepan.s@redingtongulf.com

profile CiscoTAC-1

  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService

  destination address email callhome@cisco.com

  destination transport-method http

  subscribe-to-alert-group diagnostic

  subscribe-to-alert-group environment

  subscribe-to-alert-group inventory periodic monthly

  subscribe-to-alert-group configuration periodic monthly

  subscribe-to-alert-group telemetry periodic daily

Cryptochecksum:b9d56036aaf4b6dafdf3764946e808f7

: end

SWITCH Configuration

=================

Switch#sh run

Building configuration...

Current configuration : 4586 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Switch

!

boot-start-marker

boot-end-marker

!

!

!

!

no aaa new-model

system mtu routing 1500

ip routing

!

!

!

!

crypto pki trustpoint TP-self-signed-1213331968

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1213331968

revocation-check none

rsakeypair TP-self-signed-1213331968

!

!

crypto pki certificate chain TP-self-signed-1213331968

certificate self-signed 01

  3082023F 308201A8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31323133 33333139 3638301E 170D3933 30333031 30303031

  31375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32313333

  33313936 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100C09B 76A54237 9C118C90 E2A12B04 7731EE8C 4EE2136F 93A75202 9BAA7019

  5B735B3C A1CBE60E 431EE7F6 828463A7 797124C3 17ABDB6E 331159B2 34C251E7

  07EB43F8 E801EE18 AE19D358 7B54269B D65B6D51 89483AC0 6BE1F39F CDE026EF

  92DAC152 4D3F817C D8EBA4F9 C7C412FD 73536446 30AA3BBA 806BFF04 2BF0D997

  4C170203 010001A3 67306530 0F060355 1D130101 FF040530 030101FF 30120603

  551D1104 0B300982 07537769 7463682E 301F0603 551D2304 18301680 14E57573

  42C453D9 5539DB26 670C3009 EE0DF0C9 C1301D06 03551D0E 04160414 E5757342

  C453D955 39DB2667 0C3009EE 0DF0C9C1 300D0609 2A864886 F70D0101 04050003

  81810061 7D3E4954 4DE7724B 37FC4D4E 4AA11BEF 54A0F141 4DE49BEB 3E36CF14

  B6B30807 F1E8D532 654E6FE1 0422B7D5 4E5FE5D3 C93599D6 053CA340 798CC46F

  8170A73A 8015EF02 74E4925F 9EFB5D13 44E109D6 522EB4F9 C297C317 99FB8DF9

  35B9B39B 130D7017 CA222114 4C34C7EB ACB32392 2D5DE43A E31B1A4C 54396B30 7EE6F9

  quit

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

vlan internal allocation policy ascending

!

!

!

interface FastEthernet0

no ip address

no ip route-cache cef

no ip route-cache

no ip mroute-cache

shutdown

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface GigabitEthernet0/5

!

interface GigabitEthernet0/6

!

interface GigabitEthernet0/7

switchport access vlan 101

switchport mode access

!

interface GigabitEthernet0/8

switchport access vlan 101

switchport mode access

!

interface GigabitEthernet0/9

switchport access vlan 101

switchport mode access

!

interface GigabitEthernet0/10

switchport access vlan 101

switchport mode access

!

interface GigabitEthernet0/11

switchport access vlan 101

switchport mode access

!

interface GigabitEthernet0/12

switchport access vlan 101

switchport mode access

!

interface GigabitEthernet0/13

switchport access vlan 101

switchport mode access

!

interface GigabitEthernet0/14

switchport access vlan 102

switchport mode access

!

interface GigabitEthernet0/15

switchport access vlan 102

switchport mode access

!

interface GigabitEthernet0/16

switchport access vlan 102

switchport mode access

!

interface GigabitEthernet0/17

switchport access vlan 102

switchport mode access

!

interface GigabitEthernet0/18

switchport access vlan 102

switchport mode access

!

interface GigabitEthernet0/19

switchport access vlan 102

switchport mode access

!

interface GigabitEthernet0/20

switchport access vlan 102

switchport mode access

!

interface GigabitEthernet0/21

switchport access vlan 102

switchport mode access

!

interface GigabitEthernet0/22

switchport access vlan 102

switchport mode access

!

interface GigabitEthernet0/23

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 101,102

switchport mode trunk

switchport nonegotiate

spanning-tree portfast

!

interface GigabitEthernet0/24

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 101,102

switchport mode trunk

switchport nonegotiate

spanning-tree portfast

!

interface GigabitEthernet1/1

!

interface GigabitEthernet1/2

!

interface GigabitEthernet1/3

!

interface GigabitEthernet1/4

!

interface TenGigabitEthernet1/1

!

interface TenGigabitEthernet1/2

!

interface Vlan1

ip address 10.10.50.1 255.255.255.0

!

interface Vlan101

ip address 172.22.0.1 255.255.255.0

!

interface Vlan102

ip address 172.22.1.1 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.22.0.2

ip route 0.0.0.0 0.0.0.0 172.22.1.2

ip http server

ip http secure-server

!

ip sla enable reaction-alerts

!

!

line con 0

line vty 0 4

login

line vty 5 15

login

!

end

ROUTER Configuration

=================

Core_2RTR#sh run

Building configuration...

Current configuration : 1679 bytes

!

! Last configuration change at 20:04:49 UTC Wed Jun 6 2012

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Spanco_Core_2

!

boot-start-marker

boot-end-marker

!

!

enable password spanco@987

!

no aaa new-model

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

!

multilink bundle-name authenticated

!

!

crypto pki token default removal timeout 0

!

!

license udi pid C3900-SPE150/K9 sn FOC15324QJF

!

!

!

!

!

!

!

!

interface Loopback0

ip address 1.1.1.1 255.255.255.0

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description *** Spanco Airtel Core Connectivity ***

ip address 172.23.43.34 255.255.255.252

duplex full

speed 100

!

interface GigabitEthernet0/1

ip address 10.10.10.1 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/2

ip address 172.23.43.14 255.255.255.252

duplex auto

speed auto

!

router ospf 30

network 10.10.10.0 0.0.0.255 area 10

network 172.22.0.0 0.0.0.255 area 10

network 172.23.43.12 0.0.0.3 area 10

network 172.23.43.32 0.0.0.3 area 10

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 10.10.16.71

ip route 172.22.0.0 255.255.255.0 GigabitEthernet0/1

!

!

no cdp run

!

snmp-server community public RO

snmp-server location SPANCO_GEMI

!

control-plane

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

password 7 111A09041911042C5D727C

login

transport input all

!

scheduler allocate 20000 1000

end

4 REPLIES
Cisco Employee

Firewall conf issue........

You can configure PAT on the firewall as the router doesn't have route back to your internal networks.

nat (INSIDE1) 1 172.22.0.0 255.255.255.0

nat (INSIDE2) 1 172.22.1.0 255.255.255.0

global (outside) 1 interface

Also enable icmp inspection on the firewall:

policy-map global_policy

class inspection_default

   inspect icmp

Community Member

Firewall conf issue........

HI Jen,

Thanks as usual for your kind support.

ASA Version is 8.4(2) and i don't see global command...on it.

Reg

Sanjeev

Red

Firewall conf issue........

Hi Sanjeev,

what Jennifer suggested are these commands in 8.4.2:

object network obj-172.22.0.0

subnet 172.22.0.0 255.255.255.0

nat (inside,outside) dynamic interface

object network obj-172.22.1.0

   subnet 172.22.1.0 255.255.255.0

   nat (inside,outside) dynamic interface

policy-map global_policy

class inspection_default

   inspect icmp

Hope that helps.

Thanks,
Varun Rao
Security Team,
Cisco TAC

Thanks, Varun Rao Security Team, Cisco TAC
Cisco Employee

Firewall conf issue........

To be exact, it should be:

object network obj-172.22.0.0

subnet 172.22.0.0 255.255.255.0

nat (INSIDE1,outside) dynamic interface

object network obj-172.22.1.0

   subnet 172.22.1.0 255.255.255.0

   nat (INSIDE2,outside) dynamic interface

268
Views
0
Helpful
4
Replies
CreatePlease to create content