Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

First ASA5505 configuration

Hi,
 
I work in a tiny society and we just have bought a firewall Cisco ASA 5505.
 
The IP address of this firewall is by default : 192.168.1.1
Our network address is : 192.168.0.1
Our internet box was linked to a switch
 
I tried this :
I put the RJ45 of the internet box to the firewall on port 0
And I put a new RJ45 from the firewall on port 1 to the switch.
 
Then, we have lost internet on all the computers.
 
If I go to https://192.168.1.1/admin/public/index.html, I have 3 buttuns :
- Install ADSM Launcher
- Run ASDM
- Run Startup Wizard
 
The Quick Start Guide tell me to Run Startup Wizard.
This downloads the java file : startup.jnlp
 
When I launch this file, I have a first security warning wich tell me the local web site is not secured (https://192.168.1.1:443) and if I want to continue. I click the Continue buttun, and I have an other warning wich tell me if I want to execute the application (name = com.cisco.launcher.Launcher, editor = Cisco Systems, emplacement = https://192.168.1.1). I click the Execute button and I have an error "Impossible to launch the application" (name = ADSM Startup Wizard on 192.168.1.1, editor = Cisco Systems Inc., emplacement = https://192.168.1.1).
 
If I click the Details button, I have a new windows with 2 tabpages. The title is :
Error : Missing required Permissions manifest attribute in main jar:
https://192.168.1.1/admin/puclic/dm-launcher.jar
 
The first tabpage (File of launcher) is :
 
<jnlp spec="1.0+" codebase="https://192.168.1.1/admin/public" href="https://192.168.1.1/admin/public/startup.jnlp">
  <information>
    <title>ASDM Startup Wizard on 192.168.1.1</title>
    <vendor>Cisco Systems, Inc.</vendor>
    <homepage href="http://www.cisco.com/go/asdm"/>
    <description>ASDM Startup Wizard on 192.168.1.1</description>
    <description kind="short">ASDM Startup Wizard on 192.168.1.1</description>
    <description kind="tooltip">ASDM Startup Wizard on 192.168.1.1</description>
    <icon href="asdm32.gif"/>
    <offline-allowed/>
  </information>
  <security>
    <all-permissions/>
  </security>
  <resources>
    <j2se version="1.6+" initial-heap-size="64m" max-heap-size="256m"/>
    <jar href="dm-launcher.jar" main="true" download="eager"/>
    <jar href="lzma.jar" download="eager"/>
    <jar href="jploader.jar" download="eager"/>
    <jar href="retroweaver-rt-2.0.jar" download="eager"/>
    <property name="http.agent" value="ASDM/"/>
  </resources>
  <application-desc main-class="com.cisco.launcher.Launcher">
    <argument>/webstart</argument>
    <argument>192.168.1.1</argument>
    <argument>/asdm.runStartupWizard=true</argument>
  </application-desc>
</jnlp>
 
The second tabpage (Exception) is :
 
java.lang.SecurityException: Missing required Permissions manifest attribute in main jar: https://192.168.1.1/admin/public/dm-launcher.jar
at com.sun.deploy.security.DeployManifestChecker.verifyMainJar(Unknown Source)
at com.sun.deploy.security.DeployManifestChecker.verifyMainJar(Unknown Source)
at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
at com.sun.javaws.Launcher.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
 
For information, the java installed is :
Java 7 updated 55
And my OS is Windows 7 Professional 64
 
So, I return to the local website 192.168.1.1, and I click on the second button (Run ASDM) wich downloads an other java file and I have exactly the same error.
 
So, I try the first button (Install ADSM Launcher), and the system ask me to log in. I found somewhere on internet how to log (blanck username and password), and I download a msifile : dm-launcher.msi.
A window appear, named Cisco ASDM-IDM Launcher v1.5(56), and ask me 3 things :
The Device IP Address / Name : 192.168.1.1
The username that I don't find anywhere
And the password that I don't know either
 
So, I can't configure the firewall by any of the 3 ways.
 
Note that I am french, and I know only a little in the configurations.
 
Please, can you help me ?

 

  • Firewalling
2 REPLIES
Hall of Fame Super Silver

In your last method, you are

In your last method, you are quite close. If the ASA 5505 is factory default, you can simply leave the username and password blank when launching ASDM for the first time. This is mentioned in the ASA 5505 Quick Start Guide:

"Step 5 Leave the username and password fields empty and click OK."

Once you login, you can use the startup wizard to accomplish basic configuration.

If the unit is not factory default, you would need to supply the credentials the previous owner setup or else go through some more involved steps via the console connection to restore the unit to factory default.

New Member

Thanks Marvin for your answer

Thanks Marvin for your answer.

 

I had already tried leave empty.

 

However, I found what was wrong : in the Java configuration, Securitytab, I have downgrade the Security level to Average, and after, I can access the Cisco ASDM. (I didn't see that anywhere on internet)

 

I have now another problems, but I will post another topic if I will need help later.

584
Views
0
Helpful
2
Replies