Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

having problems with brand new ASA5505 and ASDM

I have a brand new out of the box ASA5505.  I can connect with https://192.168.1.1 and login with blank username/password

From there I get a screen that tells me I can either

- Install ASDM Launcher and run ASDM or

- Install Java Web Start

If I choose the first option, ASDM runs, I put in 192.168.1.1 (and leave the UNAP blank) and it just sits there trying to connect

If I choose option 2, it just loads java.com

I have gone to java.com and installed the Java SE package (32bit and 64bit just in case - I'm on a 64bit Windows OS) which the docs say include Java Web Start, but the router still tells me "Java Web Start is required to run ASDM, but it is not installed on this computer"

I'm stuck, I've been googling for 2 hours.  Found people say if ASDM doesn't run it could be a java mismatch and just to use the java web start client.  Any help is greatly appreciated.  Thanks.

Everyone's tags (4)
5 REPLIES
VIP Purple

having problems with brand new ASA5505 and ASDM

Are you trying an actual ASDM-Version? You should download the newest ASDM as MSI-package from cisco.com and try it with that.


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
New Member

having problems with brand new ASA5505 and ASDM

Other questions about ADSM say to download it from the router which is what I'm trying to do.  I think you need some sort of contract or subscription to download it directly from cisco. 

VIP Purple

Re: having problems with brand new ASA5505 and ASDM

That's right, you need a service contract to download software. If you use the ASA for business you should consider buying that.

For your actual problem, verify that ASDM has enough memory in the java-settings. Increasing the limits helped me with other java-applications.

Sent from Cisco Technical Support iPad App


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
Gold

Re: having problems with brand new ASA5505 and ASDM

Hi

Yes normally you need a smartnetcontract, but atleast in sweden you can talk to your ciscorep to get the newest software during the first 90 days.

And yes updating the Java have in several occations in the past made the ASDM stop working.

Thats the problem with java, it is incompatible with itself so the question must then be why use it to something as important as ASDM and log handeling ?

I am sorry but I have no answer to that.

Good luck

HTH

New Member

Re: having problems with brand new ASA5505 and ASDM

I think that's the issue is the java stack, but I simply have no way of knowing which version I need.  It's a new laptop so I  have the newest version of java.

update:

problem solved.  had to uninstall java 7 and install java 6 (x32 version)

1790
Views
0
Helpful
5
Replies